Install Canon LPB6030

I am trying to install a Canon ImageCLASS LPB6030. I have downloaded the latest driver package from Canon. I have made sure that CUPS and Ghostscript are installed. When I ran the installer, it said that libjbig0 and libglade2-0 could not be found, so that did not work. I have read numerous topics here and elsewhere about installing this and similar printers. I installed capt-src using yay. That did not seem to make a difference. The printer tab in settings can see the printer and identify it, but this printer does not appear in the Canon driver list. After installing capt-src, I tried running Canon’s driver install again, but no change. I have run out of ideas. I am not very command line proficient, though I have been using Linux for several years, first Mint and now Manjaro. Any help would be appreciated.

Edit: By the way, I am running KDE Plasma, kernel 5.15.89-1

It’s my understanding that this (AUR (en) - cnrdrvcups-sfp) is the driver you need. However it requires python2 which will most likely be a problem since it’s no longer supported.

Yes, the installer tries and fails to build Python 2. Am I completely screwed then?

Are you completely screwed, that I don’t know. If I were you I would first try installing the python2-bin from AUR, then cnrdrvcups-sfp

Python 2 installed, but cnrdrvcups-sfp did not because it could not find the same two files.

I also tried using a driver for another Canon LBP printer, but that did not work.

Which two files?

libjbig0 and libglade2-0. The last process I tried said it couldn’t find jbig0 and libglade2-0

Could you post the output?

It seems there’s more to do than just installing the package.

Also putting this here.

One of the things I see in the Canon_CAPT article is about enabling multilib. I don’t quite understand the instructions there. Is it saying that I have to open the pacman config file and edit it to remove the comment about multilib? I am getting way over my head here. Then would I reinstall capt-src?

It seems to me that the GUI version of pamac used to allow turning the AUR on and off and there was a setting for multilib. I don’t see that in there anymore. Maybe these things were removed in the last update.

At this point I have tried so many different ways of installing the driver that I am afraid things maybe be broken anyway. I keep going down rabbit holes and ending up at the same few pages of stuff that I don’t quite understand.

Here is the output from the last attempt:

:: Checking for conflicts…
:: Checking for inner conflicts…
[Repo Make:1] jbigkit-2.1-6
[Aur:1] cnrdrvcups-sfp-5.00-3
[Aur Make:1] libglade-2.6.4-8

:: Remove make dependencies after install? [y/N] y
:: (0/2) Downloaded PKGBUILD: cnrdrvcups-sfp
:: (1/2) Downloaded PKGBUILD: libglade
error: target not found: libglade
error: target not found: jbigkit
→ error fetching cnrdrvcups-sfp: fatal: could not create work tree dir ‘cnrdrvcups-sfp’: Permission denied
context: exit status 128

I’m not sure whether the Canon_Capt driver is actually the correct one.
It is not in the list on the Arch wiki @maycne.sonahoz linked to - but the name is explicitly mentioned in the driver @ydar mentioned.

Should it be the correct one then I have at least some help to offer, since the installation instructions in the Arch wiki are not exactly … intuitive and easy to follow.

I have another model which uses this driver
and I have written here on more than one occasion on how to install it.

for instance here and here and here and here.

When I try to follow your instructions it can’t find the ccpdadmin command. It also can’t find the ccp.service. CUPS is running though and it can see the printer on the USB port.

To follow the configuration advise it is of course a prerequisite to have the AUR package

AUR (en) - capt-src


Without it the commands like ccpdadmin are indeed not there.

You need both
cups.service and ccpd.service

But, again: I’m not sure whether this is the correct way to drive your printer.

I thought I had installed capt-src, but I hadn’t. Now I have.

I don’t quite understand the next step. When I check the status of CUPS it says, “scheduler started.” actually, it says that twice. Is that ok?

As far as the lpadmin command, my printer is not listed in the Wiki list so I don’t know which .ppd file to use in the command. The closest is LBP6020 I suppose. I am not sure how the local host thing works. Is that an address on the web to download the file?

Thanks for being patient.

Has anyone tried the open source driver captdriver-git? It has been updated fairly recently, thuogh it still says “unstable.”

It has been some time
and I said then:

sudo lpadmin -p LBP2900B -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59687 -E
(add the printer to cups - it didn’t work with ccp://localhost:59787 but they do mention this in the wiki)

I think I got this from here (also mentioned in the wiki):

CanonCaptDrv190 - Community Help Wiki

Don’t ask me why it works - but it did and still does. :man_shrugging:

The ppd file is actually not after the -p switch
but after the -m switch (-m CNCUPSLBP2900CAPTK.ppd)

The location for all of them on the filesystem is:

and - one more time (so you may not waste your time):

there is no ppd file for your printer model in there
(I just looked …)

Which tells me that this is not the correct way to try and make your printer work!

one of these:

AUR (en) - Packages

might be - I’d try the first in the list
(what @ydar suggested in the second comment is among them)

out of curiosity - and it may provide us (me) the basis for better help:

Where did you get it? - The address, the link.
I could look for myself - but you already know …

I got the driver here: Canon Support for imageCLASS LBP6030w | Canon U.S.A., Inc.

Maybe I should try installing it again.

You probably should.

I think, from comparing the software that you got
with the PKGBUILD here:

AUR (en) - cndrvcups-lt

that this is the same thing - just from a different source
(yours is from the site, the PKGBUILD draws it’s file from the european canon site

I tried the install again but once again it can’t find libglade2-0. libglad is installed, but not libglade2-0. It also can’t find libjbig0

These seem to be files that are found in Debian and Ubuntu, but not in Arch.

I can maybe try to build it, to see what it takes and whether it works.

The PKGBUILD lists a few dependencies - which will need to be present.

An AUR helper like yay or pamac should be able to do it. … should is the operative word …
It doesn’t always work for various reasons.

The PKGBUILD’s in AUR are supposed to be built using makepkg
which is (can be) a more tedious process.

Make sure the listed dependencies are actually present.

again: I may try - but not today. It’s way past bedtime …

So I decided to give it a try (installing), so I fired up a manjaro in Virtualbox (not really relevent). Anyway what I did was install the group base-devel, I also installed yay.

Now you already have python2-bin installed, so maybe try using yay and try installing cnrdrvcups-sfp again, it’ll try to install the dependancies and for whatever reason libglade installed this time (for whatever reason when I tried earlier today it didn’t (wouldn’t download), so you milege may vary.)

I noticed it didn’t make an entry in the application launcher so you’ll have run the command, which seemed to need sudo so: sudo cnsetuputil2l

:crossed_fingers: it works for you too.