Incorrect resolution after restart

Preface I’ve been using linux for 3 days so I’m basically an expert assume I know absolutely nothing.
I make snapshots before everything as well as daily.
I make one just before enabling AUR
I think maybe I should reboot
Now my screen is stuck at 1024x768 I cannot change this.
Drivers appear to be fine. As far as I can tell I’m still using the open source Nvidia drivers.

So far I have tried:
Turning monitor on/off.
Several reboots.
Restored snapshot.
Restored earlier snapshot.
Swap the which port the cable is plugged in.
Swap cable from Display Port to HDMI.

I don’t believe just enabling AUR ALONE would do anything like this, that sounds absurd. But the first reboot changed SOMETHING.
I did read a post on this forum
Nearly identical issue involving EDID related issues with the monitor. This is likely the same, but what made it stop working to begin with?
inxi output:

  Kernel: 6.6.26-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.6-x86_64
    root=UUID=2eb574ac-2aa1-4efa-9f14-df9ed9320f33 rw rootflags=subvol=@ quiet
    splash udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop System: MSI product: MS-7816 v: 1.0
    serial: <superuser required>
  Mobo: MSI model: Z87-G43 (MS-7816) v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: 1.11 date: 05/09/2015
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/3900 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 54418
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: conditional; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB]
    vendor: ASUSTeK DUAL-GTX1060-O6G driver: N/A alternate: nouveau
    non-free: 545.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-2021 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.12 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
    alternate: fbdev,nv,vesa gpu: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.63x7.99")
    s-diag: 338mm (13.3")
  Monitor-1: Unknown-1 mapped: None-1 res: 1024x768 hz: 60 size: N/A
    modes: 1024x768
  API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast x11: drv: swrast inactive: wayland
  API: OpenGL v: 4.5 vendor: mesa v: 24.0.2-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
    device-ID: ffffffff:ffffffff memory: 15.2 GiB unified: yes
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    vendor: Micro-Star MSI 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio
    vendor: ASUSTeK DUAL-GTX1060-O6G driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 10de:10f1 class-ID: 0403
  Device-3: Texas Instruments PCM2902 Audio Codec
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-7:5 chip-ID: 08bb:2902 class-ID: 0300
  API: ALSA v: k6.6.26-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek 802.11ac NIC driver: rtw_8821cu type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2 chip-ID: 0bda:c811
    class-ID: 0000 serial: <filter>
  IF: wlp0s20u3 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Local Storage: total: 1.46 TiB used: 31.01 GiB (2.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SV300S37A120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BBF0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BBF0 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD10EZRX-00L4HB0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Kingston model: SA400S37120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: B1D1 scheme: MBR
  ID-5: /dev/sde maj-min: 8:64 vendor: Kingston model: SV300S37A240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BBF0 scheme: GPT
  ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 31.01 GiB (13.9%) fs: btrfs dev: /dev/sde2 maj-min: 8:66
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/sde1 maj-min: 8:65
  ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 31.01 GiB (13.9%) fs: btrfs dev: /dev/sde2 maj-min: 8:66
  ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
    used: 31.01 GiB (13.9%) fs: btrfs dev: /dev/sde2 maj-min: 8:66
  Alert: No swap data was found.
  System Temperatures: cpu: 25.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.56 GiB used: 2.59 GiB (16.6%)
  Processes: 250 Power: uptime: 3m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.21 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1427 pm: pacman pkgs: 1420 libs: 400 tools: pamac pm: flatpak
    pkgs: 7 Compilers: clang: 16.0.6 gcc: 13.2.1 alt: 12 Shell: Zsh v: 5.9
    default: Bash v: 5.2.26 running-in: yakuake inxi: 3.3.34

So where do I go from here? If I need an EDID file how does one acquire/make one?

the drivers is not being loaded…
also your intel has integrated gpu, i assume its disabled in bios?
post output from:
mhwd -l -li
find /etc/X11/ -name "*.conf"
ls /etc/modprobe.d
pacman -Qm

Output from your commands

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:01:00.0 (0300:10de:1c03) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


Just adding this in case it matter. I just realized when I reboot I no longer see the Grub menu at all. Pressing Esc doesn’t bring it up and changing GRUB_TIMEOUT_STYLE from hidden to menu still don’t see it at all. I don’t feel like I need it but strange, maybe related.

you dont have the proper drivers installed, you are using nouveau, which doesnt work that good with newer kernels.
so uninstall this:
sudo mhwd -r pci video-linux
install this:
sudo mhwd -i pci video-nvidia

maybe you need to also enable early loading, so just in case do it:
kate /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it and update it:
sudo mkinitcpio -P

I appreciate the and will keep that in mind in case I need it. For the sake of learning a new operating system I would like to figure it what happened. So I loaded a snapshot from right after I installed and it works fine. And using inxi I can see it is actually loading the nouveau drivers. Something I did caused the driver to not load as in the inxi output from the initial post. I’m going to continue loading snapshot until it breaks again. Thank you for the help and I’ll report back when I find something.

Okay so going through snapshots I was able to recreate it. I installed blender and opted to also install cuda. I tried it on an older snapshot that worked. Adding blender and opting for cuda breaks it. I’m just guessing but it seems to unload the nouveau driver but not actually switch over to the nvidia one either. Since installing blender with cuda also brings other dependencies, I don’t actually know which package(s) broke it. Though as I tried to manually remove each part one by one it did end up back at the correct resolution and driver but it wasn’t “smooth” like the working snapshot.
Thanks again for the help.

You cannot possibly use CUDA without the proprietary nvidia driver.

First install the nvidia profile through mhwd as shown above.

(cuda depends on nvidia-utils and opencl-nvidia, but relying on those dependencies will not make for a clean/acceptable driver replacement)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.