Imagemagick6 build problem

Everything went swimmingly save for…

Building imagemagick6...
==> Making package: imagemagick6 (Thu 20 May 2021 02:38:12 AM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found ImageMagick6-6.9.12-12.tar.gz
==> ERROR: arch-fonts.diff was not found in the build directory and is not a URL.
Failed to build imagemagick6

Thanks always.

P.S. [Forum] search wasn’t working for me at this time, I don’t know if this had already been addressed but I did my best to skim through all responses.

Seems you did do not have the arch-fonts.diff in your build folder.

If you are building manually with makepkg, make sure you download all the sources and not just the PKGBUILD.


I’m fairly new to Linux and am using the Add/Remove Software app. I’m not even sure what app I’ve installed that required Imagemagick.

Since you mentioned the PKGBUILD I went to the Build Files tab and clicked to Reset Build Files and it just built successfully. Thanks!


I try to stick to command line. After reading this thread I tried pamac clean and it removed 1.3GB and yet the error persisted. I tried the following in GUI and it worked. I just wonder why the CLI didn’t.


Try pamac clean --build-files or pamac clean -b


The GUI solution worked for me as well. There were 400mb+ of data to be cleaned. Also 4gb+ of pacman cache :crazy_face: