I'm using the keyboard, but can't figure out how to type a hyphen ("-"), making it tough to issue commands

I have a Pinephone Pro running Manjaro Plasma. It has Manjaro testing installed. An update a while ago resulted in me not being able to access the GUI of the system. It read,

… out of the virtual session by pressing Ctrl+D, back to the running session (CTrl+Alt+F2) …
… locker is broken and unlocking is not possible to unlock switch to virtual terminal (e.g. Ctr …

Today I decided I’d try to fix it. So, I connected it to the keyboard case, and accessed the command line. I’d like to try to update the system again to see if that will fix it. But, I can’t figure out how to type a hyphen (“-”). It seems to exist as one of the many options at the “7” key (or maybe the “9” key). I’ve tried all sorts of key combinations to try to generate a hyphen, and yet none work.

The command I’m hoping to run is:

sudo pacman -Syyu

If anyone knows how I can type a hyphen, do please share. Thanks.

[edit] I did manage to update & upgrade the phone, and the GUI now is working again. I managed to do this via pressing the Up button (Fn + the period key) and this went into the history of commands, one of which was the update/upgrade command I wanted. That said, I still don’t know how to type a hyphen (aka minus sign) with the keyboard.

Hi - if you type sudo pacman and then use your tab-key a hyphen will automagically be filled in for you and the options that can follow the hyphen are shown.

1 Like

Or if you run that command recently then just use the “up” arrow and scroll thru your recent commands. You can also edit those commands with the arrow keys to move thru the command.

I apologize I didn’t see it was for a phone and I’m not sure how the terminal works there.

I looked for it and found this keyboard layout here:

File:Ppkb layout2.png - PINE64

It should be on F9 (or F7?)

and this here describes how to access it:

No underscore on pinephone keyboard

Just holding Fn+9 isn’t enough, the right key combination is:
Fn+(Left)Shift+9.

This is not experience - I just looked for it online.

From that picture, it looks to be PINE+9.

I’m apparently color blind - can’t see blue :sunglasses:

I tried Pine+9, and it didn’t work. However, I was able to upgrade the phone and get it working via using the up arrow key (Fn + the period key) and fortunately the command was in the history. Buy yeah, apparently the top row of keys can be a bit buggy, and it seems that is the case with my keyboard.

Wonderful! That works! Thanks so much. This is good to know for the future.

1 Like

Fn+(Left)Shift+9 gave the following:

2~

Some time ago I found out that all the keys that should be mapped with the Pine key were actually mapped to the AltG key due to he xkb package using a key mapper from a github repository with a popular Pine keyboard map configuration.

So for you you will need to press AltG + 7 for it to write the - character.

I wrote this whole message using my Pine Keyboard so I can confirm it works :stuck_out_tongue:

PS: Someone asked me if I could update the Pine64 wiki since it allows any user to propose an update (I’m not a maintainer or anything), but I have been extremely busy these last months, so if anyone else have the time and wants to do it, please do xD

so who will we blame?