I'm looking for a workable Android emulator for ARM

I am using the ViewCam v.1.5.7 application to control the DVR:


Unfortunately, it was created only for Android and Mac.
I couldn’t find any other similar applications for my DVR.

Hence, to use ViewCam in an environment for Manjaro ARM is needed emulator Android .
I tried to build an android-emulator 33.1.23-1

But unfortunately, I was unable to assemble it.
Please help me do this. Or recommend another emulator that is easy to assemble for ARM.

Waydroid is usually the recommended solution, but you have to check if it runs on arm. And it requires Wayland.

1 Like

Ok, could you explain in more detail the actions required for this?

I do not know if the package is up to date or not. It has not been mentioned in a long time. Look under “Tips and Tricks” here:


@Darksky, I’m sorry, but I don’t understand what package you’re talking about and why me need it here.
I am interested in the steps for Waydroid and Wayland.

Install KDE and boot with a wayland session and follow the steps in the link I gave above and install waydroid. I do not know if I can say it any plainer.


Depending on the device, this step may or may not make sense.

On the PinePhone or PinePhone Pro, you probably want to use Plasma Mobile or Phosh rather than Plasma Desktop (i.e., what is usually meant by “KDE”). They are all Wayland-based (and in fact their sessions are always Wayland).

He does not have a mobile phone. I think he has a tv box. Depending on his gpu he may or may not get waydroid working. The last time I tried the rpi would not work.

So this emulator requires KDE?
But I can’t use it, I only work with XFCE.
Therefore, your advice is unsuitable :confused:

And it’s all kind of complicated. Is there really no ready-made independent Android emulator package that was installed and worked without third-party applications?

These multiple limitations and features of Manjaro are starting to get pretty annoying.
I admit, I would love to test Armbian to compare it with a Manjaro , but unfortunately, he doesn’t want to work for me.

But Manjaro has a friendly community, while Armbian has a lazy and indifferent one.
And it keeps me on Manjaro :smiley:

The xfce roadmap has a projected wayland support in version 4.20.

I use XFCE 4.18. No more update.

It will be a while before 4.20 is released.

Alas, but I need to monitoring the DVR now :slightly_smiling_face:
Are there any other ways to solve this problem now?

See if you can get this to work

Generally, there is no easy way, it will always be some kind of virtual machine. I would try my best to find alternative program that does the same if i were you. It will probably be simpler.

P.s. that quoted version of the android app is 8 years old and not even in the playstore anymore. Just find an alternative.

P.s. that quoted version of the android app is 8 years old and not even in the playstore anymore. Just find an alternative.

Yes, you are right, this is the best way. But I bought this DVR back in 2014, and only old Windows, Android applications and web browser work with it. There are no other applications. Updates to them no too.
But only the Internet Explorer works from web browsers, others refuse to show the image because the N9_ActiveX.cab plugin cannot be connected to them.
Me now have to work like this:

- launch Debian, then VirtualBox, then Windows XP, then Internet Explorer.

It’s very cumbersome, long, and inconvenient, so I tried to use the Android emulator in Manjaro.
But so far it doesn’t work either :confounded:

What do you mean by that?

What hardware are you trying to connect to? (I’m guessing it is a camera of some sort?)

I use video DVR of old models ATIS 8904KM.

Sorry, a websearch give me nothing.

I was thinking if you could find another firmware to use.

Please, this is the DVR


He has the latest firmware installed, there is no newer one.
The release of this model and its technical support have long been discontinued.

And I was thinking if there could be an open source alternative for you to install, but a quick search gave me nothing.