Icons missing after update - taskbar and docks

After an update, several icons are missing. There is no Manjaro icon in the taskbar - the menu is still there to be clicked on, but no icon. Several of my programs are missing icons - Transmission, Terminal Emulator, for instance. They show in the taskbar with an error icon, and they show in my Plank dock as invisible icons.

All of the UI glyphs seem to have changed - all the icons in the xfce menu, folder and file icons in my file manager, etc. So I presume some glyph library somewhere updated and messed things up, but have no idea where to look to fix it.

Hi @Jbni,

  • Where did you install the icons to?
  • How did you install the icons?

Please provide the output of:

ls -l  /usr/share/icons/

The system icons.


ls -l ~/.icons


ls -l ~/.local/share/icons

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

I didn’t install the icons myself, they were the default Manjaro XFCE icons.

I tried to manually set icons, and noticed all the .svg icons failed to render in the selector. I reinstalled librsvg and lib32-librsvg and did a sudo gtk-update-icon-cache /usr/share/icons/* and logged out and back in, and my icons were working again. (I had already tried just updating the cache, and that didn’t work.)

From comments on past threads about this issue scattered around the internet, it seems to be related to harfbuzz updating.

But it’s fixed now, so yay!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.