I think I Installed wrong Nvidia drivers, and now I'm stuck on boot

This is where I messed up-
I skipped reading the first five lines where it gives different choice for laptops. (I have two graphic cards intel hd and Nvidia geforce gt 730 M)

And used yay to install - nvidia-470xx-dkms
And during install it gave two warnings, something like removing conflicting packages breaks dependency (I think their names were like linux-something, I don’t remember exactly ) ,
so i removed them individually using pacman and then installed this Nvidia 470xx dkms, and rebooted.

Now I am stuck on boot. At least I can access the terminal using ctrl-alt-f2 .

Also I tried installing and uninstalling Nvidia-video for some reason. (Using chmod -r pci)

I don’t have a live manjaro usb to chroot.

Here is some info that might be be helpful (using images since I can’t copy paste) -

  1. Neofetch, mhwd -li, inxi -Gazy

2.mhwd -l, pacman -Q | grep Nvidia

Remove nvidia-470xx-utils and nvidia-470xx-dkms and install the 390xx driver.

mhwd -l reveals that only 390xx will support your nvidia gpu (it checks the chipID).

EDIT: Ah wait… 470xx is supported for 1290: Appendix A. Supported NVIDIA GPU Products :man_facepalming:

Just removed the Nvidia-470xx-utils
Also can’t get pacman to work here so i used pamac.

And nvidia-470xx-dkms not found.

ok wait…

Remove every nvidia driver/utils and just ignore the list of mhwd.

Just install:

sudo mhwd --install pci video-hybrid-intel-nvidia-470xx-prime

And it should work…

How do i know which ones to remove.should I remove these ones?
The bumblebee one, video-nvidia-390xx and video-linux?

That are normally the packages:

pamac list | grep "nvidia" | grep -v "mhwd"

Yes also that one.

sudo mhwd --remove pci video-hybrid-intel-nvidia-390xx-bumblebee

but not video-linux.

I think I should add pci in mhwd command, just want to confirm before doing it.

Yeah correct… I forgot pci.

Should I remove opencl-nvidia-390xx as well?
Also bumblebee is still there after mhwd remove.so I’ll use pamac to remove it for good this time✌

Unable to remove using pamac.

That is a config (a script) which is called by mhwd and not a package.

Oh I see. So are the drivers removed? if not, how do i remove them?
Mhwd removed the bumblebee config the first time i ran the command.

Only you can know…

Good then it should be removed.

Ok , I’m just going to run

sudo mhwd --install pci video-hybrid-intel-nvidia-470xx-prime

And reboot and hope for the best.

Still stuck on boot.
So, i just did pamac list | grep “nvidia”

Could any of these be causing problem?
Should I just remove all of them?

Is there a config at

ls /etc/X11/xorg.conf.d 


Normally it should start with the intel driver and not nvidia.

And no… packages are normal… opencl is not necessary to boot.

It looks like there is-

Good I guess 90-mhwd.conf contains instructions to start with nvidia? Remove it. Default is a prime setup on hybrid gpus. So it starts with the iGPU (intel) and you can use the dGPU (nvidia) optionally if no xorg config is set.

Done, removed it and rebooted .
Still stuck at boot

Hm… guess it is then a problem with the display-manager which failed to start… ok well… before you share lots of pictures… please use this script:


curl -s "https://notabug.org/megavolt/random-scripts/raw/master/lognconf-report.sh" | sh


curl -s "https://notabug.org/megavolt/random-scripts/raw/master/lognconf-report.sh" | sh -s -- upload

and share the link here.