I Tested KDE 6 - Oh My, Oh My


This post is ment to help Devs. Please appraciate the test. You can by me a beer later.

I hope this post will help realize what is going on (since this is forum for Manjaro KDE and there isn’t any better place here on the forum) with KDE 6. I am not seaking help here, but merely put out the warning for useres and Manjaro devs. Things will break. Oh they will! So before putting Manjaro KDE based on qt6/KDE 6/gear 24.02 version out to the public, my sugesstion is… keep version 5.xxx as long as possbile.

So here are my findings (Arch…):

When you update to KDE 6 ($ pacman -Scc, $ pacman -Syyu) some libraries that have the “qt5” will not be updated to the “qt6” equivalents. For the functioning of the syststem they are required (even if you think that everything went smoothly…at first glance, you will soon discover they are missing). Of course Arch added “5” and new ones don’t have “6” prefix/suffix as the naming convention for the stable libraries is (no “6” prfix/suffix), but why did pacman not upgrade the necessary libraries - the “6” equivalent of “5”, I have no idea. So then the user has to hunt those missining libraries, because it looks like you have “a barebone” KDE 6. Majority of them went through and were updated to the newer “6” versions, but some were not at all.

Then we have 24.02 (or something like this) “qt6” applications (e.g. Dolphin). They’re the new “qt6” versions and rely on qt6 libraries. Then, why do I have “qt5” libraries left, that are now usless for those qt6 applications? (external ones? Strawberry has been qt6 for at least a year…,and they don’t use all those intertiwined libraries of qt5…). On top of it those (useless now) qt5 libraries are taking space and are … still updated when using pacman. Why? We switched to KDE6 and all apps (aka KDE gears) are now requireing qt6 libraries and qt5 libraries are useless for them. They don’t do a squat in KDE. Like a dummy library, because e.g. Dolphin, Elisa, Gwenview use qt6 equivalents, but not qt5 anymore. So why update them and keep them? This is not an upgrade. This is a “frankenstein/chimera” distro now.

There’s more. Some libraries of qt6 varieties have nasty bugs missing functionality from qt5 libraries. Did anyone test it? On top of it some KDE own libraries (for qt6) removed functioanlity and code because now this functionality is supported by Qt6 on its own. But some of those Qt6 libaries are not installed updated by doing pacman -Syyu. Oh my! Nor do they have removed functionality.

Easy to recognize by an example (maybe it will be more clear if I give you an example, you buy me a beer later):
Manjaro is Desktp, which is the most difficult. Everything should work and there are a lot of work to glue everything together. One common thing is that people play videos and browse/create photos. Simple right? Not on KDE 6:

By KISS and shared libraries everything should be smooth. You have kimageformats “5” you install it/upgrade to kimageformats “qt/6” and all should be as smooth as a butter. Are you sure? Are you? No! It will not work!

Even before we had a mess. And now its even worse: previously, for example, webp file formats were supported by kimageformats5. You update and… nope no support for webp. You check for kimageformats6 and… its there. You should file up a regression bug against kimageformats “qt6”, because “qt5” imageformats supported webp, right?

So after update (pacman -Syyu) you have no webp thumbnails in Dolphin and Gwenview cannot display those photos (webp). What will a typical user do? How they will know that they should installl qt6 library (qt6-imageformats). Why pacman did not install it? They will file a bug against kimageformats6. Not good. Not good at all!

But wait, there’s more. We also have webp-pixbuf-loader and kdegraphics-thumbnailers and, of course, libwep.

To summer up:
-[ffmpegthumbs] → for vids
-kimageformats 6.0.0-2 (kf6)
-varous libxxx (avif, webp, jxl, png, etc)

Why not one share library to rule them all (Dolphin, Gwenview, SDDM, Lock Screen, Elisa…)? Read on. Noting, that its not the above libraries…

But wait. PNGs thumbs are missing too in Dolphin. Long and behold, before you say that it works on your computer and Gwenview and Dolphin display PNG thumbnails OK and there is no issue, let me be clear: you are wrong. Only 8-bit thumbnails are displayed in Dolphin. If you have 12-bit or 16-bit PNGs (you should, 8-bit don’t compress properly, not enough bit-depth…) Dolphin will not display thumbnails. You can hunt the setting in Dolphin, but they don’t matter (…). Only 8-bit PNGs are supported in Dolphin. But wait: they can be displayed in Gwenview. And thumbnails (ctrl+shift+f and top left button) in Gwenview are also displeyd. So… this is the prove that Gwenview (qt6) is using different library and Dolphin (24.02/qt6) is using different library. [tallk about shared libraries]. And this is just PNG. Oh my!

But wait there’s more. Some AVIF files are not displayed. Dolphin cannot display AVIF thumbnails, despite all rellevant (hunted down after update) libraries being there and installed additionaly. (Note that all worked OK in qt5 an just doing $ pacman Syyu broke everything- no thumbs in Dolphin, no thumbs in Gwenview.

So now after update to KDE 6, we can no longer display a lot of photos of variuos types. Nor see their thumbnails. Total disaster. This is not a server. Its desktop…

Al off these are just a “visual examples” for updating to qt6/kde6, that everyone can check (what about other libraries? How about those “glitches/foibles” with kwallet vs WiFi…again…ehhh,…). So, so far we have:
-[ffmpegthumbs] → for vids
-kimageformats 6.0.0-2 (kf6)
-varous libxxx (avif, webp, jxl, png, etc)

And still no AVIF support (see attachments before you say “my AVIFs work and I have “thumbs” in Dolphin” …my own Avifs made from these PNGs whith “$ avifenc -c aom” don’t work in Dolphin!. No PNG support either (see attatchment).

To top it up different libraries are used for Gwenview and Dolphin (both are KDE and should work with thier own shared libraries…).

And there is more: on top of all of these we have some useless “dummy” libraries (qt5imagformats and the likes are still “hanging” in the system, but they are not used anymore, not to mention they got updated today]. What for?

And I do suspect that jpg is “natively” supported in Dolphin by its own.

On top of all these there is wayland. Well not so smooth as x11 (intel only). So i switched. Now we have floating panel (waisting pixels below, looks apple-ish but useless, what am I going to do with those pixels below the panel? Squeeze a window of “chrom” there to launch some “nice” javascript?).

There’s a qube. Nope pressing meta+c does nothing. No cube. Switching between desktop with cube, nope, no such thing- just the old, ugly slider.

Sorry. But don’t cry if you update. I was. And its enough. “sable”? As people frm jupiterbroadcasting say “horse-stable”.
Since You cannot uplaod files here and they will be converted, don’t get me that “it works on your computer” Here is your small AVIF file and PNG file:


If anyone is still in doubt, .cache was cleaned beforehand and “no thumbs limit was set” in Dolphin.

1 Like

Manjaro Stable has only just upgraded to Plasma 5.27.11 on 2024.03.13, so it is presumably not scheduled to be replaced by Plasma 6 in the next few weeks.

However, Manjaro Testing is now already on Plasma 6.0.2 as of 2024.03.16, and its progress both in Manjaro Testing and upstream is being monitored. Perhaps if you were to monitor that thread, you would be able to compare what people are reporting there with your own experiences? :man_shrugging:

Many of the things you are reporting however — such as this… :point_down:

— are beyond Manjaro’s control, because some of them are issues with the development of Plasma by KDE upstream, and others are with Arch’s own handling of the packaging.

It does however deserve recommendation for every Manjaro Plasma user to hunt down the qt6-specific versions of their currently installed qt5 packages in the repository, and to already install those qt6 versions right now before the upgrade to Plasma 6, so as to minimize the amount of missing functionality.

Strictly speaking, they are being updated because you have them installed and upstream still keeps on releasing updates for them. In practice, some things may also still depend on them — e.g. older themes and/or plugins. If that is not the case for you, then you should be able to safely uninstall them.

That is only the default on non-customized setups — read: out-of-the-box Plasma 6 installs — just as with the default of requiring double-clicking instead of single-clicking, and both of these things can easily be changed by, respectively, editing the panel options and opening up System Settings.

As I wrote higher up, on the Stable branch, we have only just upgraded to Plasma 5.27.11 a few days ago as I’m writing this, and given that 5.27 is an LTS release, we are in no hurry to upgrade to Plasma 6. But as I also wrote higher up already, Plasma 6 is already in Manjaro Testing now, after having spent about a week or so in Manjaro Unstable, which itself mirrors Arch Stable.

Hopefully @philm will have the wisdom to keep Plasma 6 confined to Manjaro Testing until all of the bugs have been ironed out, and especially so after the fiasco with the upgrade from 5.24 LTS to 5.25, which was… um… highly problematic for at least half of the Plasma users here.

Upstream is either way planning to release several more bugfixes in the coming months, so it doesn’t exactly look like Plasma 6 would be ready for prime time just yet. Personally, I’m in no hurry to upgrade. :man_shrugging:


Wrong place - use bugs.kde.org


If you are worried about the update to 6, may I suggest you wait for the ISO to come out. Run it live and see how it works for you. Even if the update fails you have an ISO which you can install from.


First learn how to even update properly. Not gonna even touch the rest. I’m using it for 2+ weeks and I’m not sorry. :joy:


Judging from the problems I am seeing with KDE 6, you may want to hold off on switching to it. I tried it and had several problems: None of my configurable buttons now worked, my window buttons were also broken. A panel kept flashing for no apparent reason, and my mouse had a terrible lag. So, what to do?

If you are on the testing branch, you will probably want to switch to stable. Use the following command:

sudo pacman-mirrors -aS stable

To keep plasma from updating you can add the following command to the /etc/pacman.conf file. Place it in the IgnorePkg = section.

IgnoreGroup = plasma

There are risks to doing this, but as long as you pay close attention to things like widgets breaking, appearance of odd behaviors after an update, etc, you should be ok. Note that command does not prevent frameworks from updating. This may be where you could experience a problem down the line.

To be really cautious, you could wait until a Manjaro ISO version is released running KDE 6 and install it to a thumb drive and see how it works on your system.

I don’t think we will need to create a temporary local repository like we did the last time. Fingers crossed. :slight_smile:

1 Like

If you’re still using the 340 nvidia driver (as mentioned in your profile) and you ran Plasma 6 which defaults to Wayland, I think this may be the source of your problem. Did you try X11 session?

Furthermore, I am not experiencing any show stopper bugs with KDE/Plasma 6, just a few minor annoyances, certainly nothing to severe enough to remain on KDE/Plasma 5. I didn’t seem to have the issues you or @radar have had.


I am using the nouveau driver. No, I did not try the X11 session.

did i get that correctly, that you tried out arch? And have no idea how manjaro has or has not improved upon it?

1 Like

No problems with plasma 6 here …
And pretty much everyone else that has tried it seems to be OK too.
(but those were mostly capable Unstable users who got it in the proper way…)


thanks for your infos. i already expected that this transition to plasma 6 will bring up a lot of problems and i’m sure it will last the upcoming months (if not the whole year) till it runs in an acceptable way. i was scared from the first time because the kde-developers were sooo euphoric and every time something sounds to good to be truth then it isn’t truth. there are too much construction-sites with it: the step to wayland (fully ignoring all nvidia-users), the application-developers who have to modify/test/verify their applications for full funtionality to qt6, the distro-packagers who have to repack the repositories. it remembers me to the transition of kde4 to kde5/plasma. i’ll try to stand at plasma5 as long as possible and i’m already thinking to switch to another gui (xfce,cinnamon or something else) until this plasma6 doesn’t fear me as it does right now.

Its only a default … so it doesnt really present a barrier.
Also … nvidia that is not legacy works with wayland now.
Also … its really the fault of nvidia, not the other way around.
(as with all things in the opensource world where something is ‘not supported’ due to proprietary bs)

OK, I will now take me exit from this wild world of speculation.

And enjoy my plasma 6 with wayland.
(even my ‘papirus icons’ and ‘simple application launcher’ widget got updated for 6, woohoo)


Like I said in another post, the only issue I noticed with nvidia/Wayland, was the flickering with Vivaldi, everything else seems to work okay. That said, I did switch back to X11, no big deal.

Perhaps those with much customization will feel more pain when upgrading, but that can mostly be avoided by restoring to defaults like selecting Breeze before proceeding. I think your fear is a bit overblown, and I doubt anyone needs to switch to another GUI (this isn’t anything like the switch from KDE3 to KDE4)


Oh hey, it’s :gnome: GNOME with Arc Menu and Dash to Panel. :stuck_out_tongue_closed_eyes:

1 Like

The Cube you will only draw with four virtual desktops.
Might be a triangle and the penta-gon with 3 or 5 as well.
Also the desktop effect must be activated, it’s not there by default.

1 Like

Yes, I am one of those with a lot of customization. I use a LOT of configurable window buttons for example. I assume a lot of my problems are due to that and those buttons will need to be modded to KDE 6. I also use xrandr, which does not work in Wayland. But I need it to configure gamma on my dual monitor setup.

I’m planning to set up x11 as a default in Manjaro for some time. Using wayland and there are some issues on both Nvidia and non Nvidia cards


Like what?
From the samplings here it seemed some folks experienced more bugs on x11, but I may be conflating that with ‘missing features’ such as the recording option in spectacle (that requires wayland).
I ask out of genuine curiosity … I had been using x11 until this release.

If you’re interested, you can read the issues I’ve had with nvidia/wayland/Plasma6 - https://forum.manjaro.org/t/kde-megarelease-6-plasma-6-is-here/157389/101

That said, besides the browsers thing, everything else seems alright but I don’t use the Wayland session much since the flickering/tearing in the browsers is often unbearable.