I Tested KDE 6 - Oh My, Oh My

I’m getting weird issues with windows geometry from time to time using different cards so assume it’s not GPU-related

And for nvidia there’s this

1 Like

I may confirm the issue mentioned in your post
I’ve also tested with no problems opening *.webp files via Dolphin on the most recent fedora 40 KDE nightly build and on openSUSE Tumbleweed with sudo zypper dup as of today (03/23/24). CachyOS 2024.3 (with sudo pacman -Syu also as of today) showed up failure to open via Dolphin *.webp images.

Is what I just saw I accidentally installed (with their screenshotter with pamac) and I now have 4 Gnome login options. Bad idea to keep it next to Plasma?

There is absolute no reason to be sorry for using Plasma 6.

Of course if you are relying on third-party extensions - then you will be sorry - otherwise not.

I have been testing Plasma 6 since many moons - earlier than the official release - quite pleasant in my opinion.

3 Likes

But if its only affecting you I might think its configuration related.
To be fair, I have no idea if you included testing vanilla configs or not.
Just its the only report of that I know about.

Flickering with xwayland on nvidia does seem to be a thing.
(and makes me wonder also if @ydar tried making sure to run the browsers in native wayland?)

I’ve seen absolutely no issues with vsync on either xwayland or natively, with Firefox …? In fact, since switching to Wayland several months ago, all has been fine and certainly far better than an Xorg session? :person_shrugging:

No NVIDIA here, in my case, though?

It’s reproducible under some very specific circumstances and actually minor.

And that’s pretty much the reason I don’t want to enable wayland by default for everyone. Also some remote desktop software doesn’t support Wayland (e.g. AnyDesk). I don’t really think it’s a good idea to break these kind of things.

1 Like

How about ssh -X? I guess similar? I haven’t yet tried that one with Wayland.

Please install the qt6-imageformats package.

  • webp : qt5-imageformatsqt6-imageformats
  • gimp : kimageformats5kimageformats

Thank you very much. It fixes the problem.

Thanks. No I didn’t know about about the option to run it in native Wayland.

So I found over here: KDE 6 - Wayland broken Chrome/Vivaldi - #10 by warcayac - Help - KDE Discuss, the solution.

However, Konqueror still crashes on Wayland, and I haven’t gone further investigating other potential bugs on Wayland. I think for now I’ll stay a little bit longer using X11 since everything works for me there without poking around to manually change configurations.

1 Like

Sadly the chromium situation is a bit fubared for me because vaapi works now on wayland … but is broken for amd. There is a patch available for chromium so that you can get hw-accel from vaapi in chromium again … but it only works for x11/xwayland. :cry:

1 Like

I don’t know about shortomings of dependecies, but I have tried KDE 6 with EndeavourOS, and I finally can actually use Wayland with KDE on my set up (AMD iGPU(CPU) + Nvidia dGPU + HDMI port bound to nv)

On KDE 5 it didn’t work, and on Gnome it works.

So KDE 6 is a must for me.

Waiting till it be available in Manjaro. Any idea when it would be?

1 Like

It is …

Stable snap - I don’t know - but it is in testing 6.0.2-3 - and of course - edge branch (unstable)

1 Like

And now I can’t see display settings in settings manager :scream:

Perhaps some other settings as well, as sidebar looks pretty empty. I’ve verified on EndevourOS installed on other partition and Display settings are still there.

Remove your ~/.cache folder and

 systemctl soft-reboot
1 Like

I was today years old when I learned about this.

So after executing it my DM accepted my password only to reinitialize SDDM again.
After that I could log in as normal.

But it weirded me out so I rebooted all the way. :sweat_smile:

4 Likes

It is a rather nifty way of reloading everything but the kernel

2 Likes