I cant update/install discord

Hello manjaro users. First of all, I will thank you in advance for your time.
My issue starts at the moment I try to install Discord, either from the “Add/Remove software” or with the command pamac install discord-canary
I have tried updating/refreshing mirrors and databases, and this solution won’t work. I have also tried using the following command, as found on the site SO solution .
The command goes as follows:

sudo rm -R /var/lib/pacman/sync
sudo pacman -Syu

After these commands, I try with sudo pacman install discord-canary and it throws me the following error, that is the same I get since it started to malfunction:

Synchronizing with database...
Updating core.db...
Updating extra.db...
Updating community.db...
Updating multilib.db...
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
invalid or corrupted database (PGP signature)
Failed on synchronizing database
error: failed on preparing an operation: objective not found: discord

It won’t work either, and at this moment I’m going crazy because I can’t find the solution :sweat_smile: :sweat_smile:
If any kind person could help me, it would be very appreciated

PD: Sorry if my grammar isn’t the best, not native english speaker here :stuck_out_tongue:


We have an actual proper tutorial


Tried to search the forum before posting?


You’re mixing pamac with pacman. It’s either:

sudo pacman -S discord-canary


pamac install discord-canary


1 Like

thanks! it worked : )

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.