I can't install Waydroid

I can’t install Waydroid even after installing Linux-zen and wayland
I tried to install Waydroid through the package manager. But it showed an error and aborted the function. I am new to Linux, and I need help.


From AUR (en) - waydroid:

“Before install Waydroid, make sure that your kernel supports binder and ashmem module (currently only linux-zen does).”

“Keep in mind that Waydroid only works with Wayland compositors. It also does not work yet with proprietary NVIDIA driver.”

"After install waydroid and waydroid-image, run this command to initialize the container:

# waydroid init

… Then the container can be started via waydroid-container.service."

If you require additional help, please read:

and the other related Tutorials, before you post again. Cheers.

Well, I already installed Linux Zen. Are these modules already installed on the kernel, or do I have to install them? And I have an Intel dedicated GPU, so I think my device is supported. And I don’t know how to install Waydroid and Waydroid Image. sorry for being an idiot.

Do you know how to use the package manager pacman in the terminal in Manjaro, generally?

The information posted above was from the AUR, they were not recommendations, or instructions; it was meant for your reference – ideally, for you to read, and gather information.

This too, is an important link for you to follow. It tells you what other forum members need from you in order to help you more. If you ignore it, you won’t get much help:

No, I just installed Manjaro out of excitement.

I see. Sorry, I can’t help. Maybe someone else will spend the time after you read those tutorials. Cheers.

Anyway, thanks for helping I will watch tutorials on how to use PACMAN by Luke, something I forgot. Then try to install Waydroid.

I did find this post which may be helpful once you’re more familiar with Manjaro:

Probably the most important thing to know before you even attempt to install waydroid, is that you must be installing it while running Wayland – If you don’t know what that is, then you have a lot of reading to do before you begin.

You can install Wayland (if not already installed) with this command ONLY if you’re running Manjaro KDE Plasma:

sudo pacman -S plasma-wayland-session

Then *reboot.

If successful, you will be able to switch to a Wayland session next time you login (bottom left corner of the login screen).

From that point, you could try the procedure in the post linked above; “How to install Waydroid in Manjaro…”.

IMPORTANT → If not using KDE Plasma, please don’t use that command. Instead, research what command or procedure is needed in your specific desktop environment.

pacman only works for the repositories and local packages - not the AUR.
Also … OP needs to make sure to have the prerequisites for using the AUR:

For better help it would make sense to actually provide the output and errors here.

1 Like

Yes, and as such, it’s ideal for installing plasma-wayland-session and it’s dependency xorg-xwayland :

sudo pacman -S plasma-wayland-session

I was responding to your first mention, which was not seemingly in relation to that package, but simply in response to the initial query:

Maybe some context was supposed to be inferred.


I see, yes. That was prepping for the Wayland installation, which would have been a prerequisite; as would be his ability to use pacman and the terminal. Context, indeed.

Recently I got into this problem as well, but after some long hours of research, it seems that (considering you are seeing the same error in building as me) a series of dependencies needed for the gbinder to be built could not be found in the system, making the whole process getting aborted. Now, what worked for me was looking into the last lines of log and taking note of every time a command got reported as not found and then looking into web to see if this specific command was in another package. If that command was in another package, i just needed to install that program first.

I hope this give some light into your troubles.

Sounds like you may have been missing base-devel, or perhaps the PKGBUILD was missing dependencies.

You can use the package manager for that (unless it’s in an AUR package):

# update the files database and search
sudo pacman -Fy patch
core/patch 2.7.6-10 [installed]
extra/bash-completion 2.11-3 [installed]
extra/gap-packages 4.12.2-3

# we can be more specific by supplying the full path
# if we've already updated then we can just search
pacman -F /usr/bin/patch
usr/bin/patch is owned by core/patch 2.7.6-10

# more info
man pacman

Unfortunately it pacman -Si no longer says patch is part of base-devel (since base-devel was switched from a group to a metapackage), but it is and you need base-devel for building AUR packages.


EDIT: Corrected ambiguous phrasing.

1 Like

Install Waydroid on Manjaro KDE Plasma

I have briefly documented my attempts to Install Waydroid; purely out of curiosity. This is intended to assist in general discussion about how to build and install Waydroid on Manjaro KDE. Naturally, the reader is expected to employ common sense, and perform additional research as needed.

Important – My attempts to build Waydroid using this procedure have consistently failed when building the python-gbinder dependency.

The author encourages any knowledgeable input from the community to enhance or correct the content below as needed; preferably with substantiated evidence; so that others may have better success.

Waydroid is “a container-based approach to boot a full Android system on a regular GNU/Linux system”.


Installing on a Manjaro KDE Plasma desktop environment is assumed.
Intel CPU’s on x86_64 (amd64) platforms seem to be highly recommended; Nvidia GPU’s are not. However, please verify your own CPU and GPU support and do your own research.

Install Wayland

The Wayland compositor is a prerequisite for installing and running Waydroid.
Install Wayland (reboot required) with this command:

sudo pacman -S plasma-wayland-session

Note: Wayland can be selected at the Login Screen (SDDM). Use the switch located at the bottom left corner of the screen, before logging in. If you previously elected to login automatically, you will need to logout immediately to reach the login screen, and then switch to Wayland, before logging in again.

Package Managers, Manjaro, and the AUR

Familiarity with the Linux command-line and use of pacman and pamac package managers is desired; as is the ability to setup and use the ArchLinux User Repository (AUR). Waydroid (for Manjaro) is only available from the AUR.

Use the AUR at your own risk as no official support will be provided if things go awry. Please also read Need-To-Know: About Manjaro and AUR for extended information and possible ramifications of using software from the AUR.

Installing Pamac GUI will also install the command-line (pamac-cli) version; which we will be using to build and install Waydroid. Additional information is available at the AUR ArchWiki Wiki page. Install Pamac (for KDE) with this command:

sudo pacman -Syu pamac pamac-tray-icon-plasma

Install Cython for Python

Waydroid has dependencies, and the build process itself has dependencies, that must be satisfied: Cython is not a built-in Python module, so it can be installed using pip or, pip3. More information. Note that building failed after installing Cython to the system using Pacman, but after using pip3 it succeeded.

pip install cython
pip3 install cython # for pip3

Note: Using just using cython would possibly install cython3 as required for the respective build.

Install Waydroid

Waydroid has the following dependencies: lxc, libglibutil, libgbinder and python-gbinder). The working theory was to build and install Waydroid (and dependencies) like this:

pamac install waydroid
  • Note:- sudo is not required using Pamac; if elevated privileges are needed Pamac will prompt for a password.

Build Failure :roll_eyes:

The process choked on building the python-gbinder dependency:

$ pamac install waydroid
To build (2):
  python-gbinder  1.1.2-1    AUR
  waydroid        1.4.1-1    AUR
Building python-gbinder...
==> Making package: python-gbinder 1.1.2-1 (Mon 02 Oct 2023 21:44:12)
  -> Creating working copy of python-gbinder git repo...
Cloning into 'python-gbinder'...
Switched to a new branch 'makepkg'
==> Starting build()...
Compiling gbinder.pyx because it changed.
[1/1] Cythonizing gbinder.pyx
error: command 'gcc-11' failed: No such file or directory
==> ERROR: A failure occurred in build().

The failed package GitHub repository is erfanoabdi / gbinder-python and the AUR repository is python-gbinder, for anyone interested.

The AUR shows the last update to the package was 2023-10-01 :neutral_face: – yesterday, for me – after an apparent sojourn of two years.

No solution here; at least, not yet.


1 Like

It worked for me I just needed to install base-devel.

1 Like

Which procedure did you use?

It does, it just slipped your eyes. :stuck_out_tongue:

1 Like

Oops, missed out the part I was talking about.

pacman -Si patch
Repository      : core
Name            : patch
Version         : 2.7.6-10
Description     : A utility to apply patch files to original sources
Architecture    : x86_64
URL             : https://www.gnu.org/software/patch/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : glibc  attr
Optional Deps   : ed: for patch -e functionality
Conflicts With  : None
Replaces        : None
Download Size   : 92.97 KiB
Installed Size  : 185.95 KiB
Packager        : Sébastien Luttringer <seblu@archlinux.org>
Build Date      : Tue 23 May 2023 22:18:19 BST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

It does show once it’s installed (I did so through base-devel, not sure it it makes a difference):

pacman -Qi patch
Required By     : base-devel

First, I installed linux-zen and then I installed Wayland After that, I tried installing Waydroid, but it kept aborting. But then I installed base-devel and again, I tried installing Waydroid, and it installed: smiling_face: