I cannot install wifi driver for my usb ( tp-link ac1300 archer t4u)

I have tried many times to install the driver but all failed

What have you tried? Please post inxi output as described below. Have you tried searching this forum for help with this issue?

In addition, I have come across this page as well as many others.

But from what I understand, you must install the t4u drivers. And those are in the AUR:

$ pamac search t4u
rtl8822bu-dkms                                                                                                                                                                                           AUR
Kernel module for Edimax EW7822ULC USB3, Asus AC53 Nano USB 802.11ac and TP-Link Archer T4U adapter. Patched for Linux v5.12.

So, you should just be able to build rtl8822bu-dkms:

pamac build rtl8822bu-dkms


If that doesn’t work, you should give more information as @jrichard326 indicated.

1 Like
  Kernel: 5.13.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=62ed7d2d-a00e-457f-b77f-481a1a9fc52d rw quiet apparmor=1 
  security=apparmor resume=UUID=2a02e95d-6e3c-41fb-87ca-96482bf5126a 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: H310CM-HDV serial: <filter> 
  UEFI: American Megatrends v: P4.20 date: 05/14/2019 
  Message: No system battery data found. Is one present? 
  RAM: total: 7.7 GiB used: 3.06 GiB (39.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i5-9400F bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: EA 
  cache: L2: 9 MiB bogomips: 34814 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 470.63.01 
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f82 
  class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: nvidia display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7") 
  s-diag: 554mm (21.8") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403 
  Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 10de:10fa class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  IF-ID-1: enp0s20f0u5 state: unknown speed: -1 duplex: half mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: vivo iQOO Z1x type: USB driver: rndis_host v: kernel bus-ID: 1-5:6 
  chip-ID: 2d95:600a class-ID: 0a00 serial: <filter> 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 931.51 GiB used: 143.04 GiB (15.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-00WN4A0 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: GPT 
  Optical-1: /dev/sr0 vendor: ATAPI model: iHAS122 rev: ZL0F dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%) 
  used: 143.04 GiB (15.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 62ed7d2d-a00e-457f-b77f-481a1a9fc52d 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: CC2E-F3FB 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 label: swap 
  uuid: 2a02e95d-6e3c-41fb-87ca-96482bf5126a 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-5:6 info: vivo iQOO Z1x type: Bluetooth,CDC-Data 
  driver: rndis_host interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 2d95:600a class-ID: 0a00 serial: <filter> 
  Device-2: 1-6:2 info: Logitech Wireless Receiver type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 50mA 
  chip-ID: 046d:c542 class-ID: 0301 
  Device-3: 1-7:3 info: TP-Link Archer T4U ver.3 type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA 
  chip-ID: 2357:0115 class-ID: 0000 serial: <filter> 
  Device-4: 1-9:4 info: Logitech Keyboard K120 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 90mA chip-ID: 046d:c31c class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
  Processes: 209 Uptime: 7m wakeups: 0 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1209 pacman: 1189 lib: 363 flatpak: 17 
  snap: 3 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06 

Sorry I am new to this forum.
What should I do next?

There is no other network device… is it not initialized or not plugged in?

I am very sure that the usb are plugged in. I have tried it in Windows and it worked. I don’t know why the system is not noticing the device. Thank you

Oh… I overead it… here:

So this device is reconized…

When I look for chipID: TP-Link Archer T4U ver.3 You will see some github repos with drivers, but when I investigate the official driver here: Download für Archer T4U | TP-Link Deutschland then only the source code is provided which seems to be same as on GitHub - RinCat/RTL88x2BU-Linux-Driver: Realtek RTL88x2BU WiFi USB Driver for Linux and AUR (en) - rtl88x2bu-dkms-git

So installing this:

pamac build rtl88x2bu-dkms-git

Should do it. You need to reboot OR just modprobe the module and plugin in the device after installing.

The driver seems to have successfully installed
However, I cannot modprobe the module. The wifi are still not detected.
I am thankful for your support
tbh I have installed some drivers for wifi before in linux, but this time it really bothers me lol

modprobe: FATAL: Module rtl88x2bu-dkms-git not found in directory /lib/modules/5.13.15-1-MANJARO

What command did you use?

Maybe try this:

sudo modprobe 88x2bu 

or possibly sudo modprobe 8812bu

sudo modprobe rtl88x2bu

The 88x2bu give me with no response and the other one is not found in the directory. Thank you

Giving no response may mean it was loaded successfully

Reboot and post output of inxi -N again.

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 

Also inxi -Fazy --filter
You should see a driver loaded for your USB wifi adapter

Sorry aafsmarak but after reading through all of the instructions. I am finally able to fix the usb ( Maybe because file system, or I read something wrong)
I appreciate all of the help from this thread, your replies make the forum very welcoming
Now i am just trying to make the wifi connect to a 5 ghz one.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.