HP Spectre X360 - No Sound

When I go to settings - sound. I can only see headphones. There are no headphones connected to my device.

In pulseaudio volume control I see Speakers (unavailable). I can select them there and then there is sound. After a reboot it’s again changed to headphones…
Schermafdruk van 2021-11-08 12-22-02
inxi -Fza:
Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.13-x86_64
root=UUID=ed2c3c67-a959-49f8-a295-518c5138836f rw rootflags=subvol=@ quiet
resume=UUID=491b5fcb-fa12-402f-874d-6ee725fbc0e0 udev.log_priority=3
Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
Distro: Manjaro Linux base: Arch Linux
Type: Convertible System: HP product: HP Spectre x360 Convertible 13-ae0xx
v: N/A serial: Chassis: type: 31 serial:
Mobo: HP model: 83B9 v: 56.50 serial: UEFI: AMI v: F.31
date: 08/07/2019
ID-1: BAT0 charge: 47.1 Wh (88.0%) condition: 53.5/53.5 Wh (100.0%)
volts: 12.1 min: 11.6 model: HP Primary type: Li-ion serial: N/A
status: Discharging
Device-1: hid-0018:04F3:2592.0001-battery model: ELAN2514:00 04F3:2592
serial: N/A charge: N/A status: N/A
Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP
arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10)
microcode: EA cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
bogomips: 28808
Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision FHD Camera
type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 05c8:0815 class-ID: 0e02
Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver:
loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0
resolution: <missing: xdpyinfo>
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.4
direct render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.39 running: no
Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280
IF: wlp2s0 state: up mac:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
v: 0.8 bus-ID: 1-7:3 chip-ID: 8087:0a2b class-ID: e001
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Local Storage: total: 357.98 GiB used: 9.28 GiB (2.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLW256HEHP-000H1 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: CXB73H1Q temp: 29.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung
model: Flash Drive FIT size: 119.51 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: rev: 1100 scheme: MBR
ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 9.28 GiB (4.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 568 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 9.28 GiB (4.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 9.28 GiB (4.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 41.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 259 Uptime: 9m wakeups: 3 Memory: 7.52 GiB
used: 1.93 GiB (25.6%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: N/A Packages: pacman: 981 lib: 282 Shell: Zsh v: 5.8
running-in: gnome-terminal inxi: 3.3.08
   ~   :heavy_check_mark:

aplay -l  :heavy_check_mark:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -L | grep PCH  :heavy_check_mark:
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog
HDA Intel PCH, ALC295 Analog

Kernel v5.13 has been marked End Of Life in recent Manjaro update announcements

So you should install kernel v5.14 (or v5.15) using Manjaro Settings Manager GUI
( manjaro-settings-manager -m msm_kernel )

OR use this terminal command

sudo mhwd-kernel --install linux514

Archwiki suggests that onboard audio is working for kernels later than v5.14.2 with package sof-firmware installed to provide snd_soc_skl driver to support internal digital array microphones

HP Spectre x360 - 13-ae005na - ArchWiki

Exactly same issue after changing kernels. (Tried 5.14 and 5.15)

There are no headphones connected to my device.

Is there anything else plugged in to the headphone/headset jack socket?

I suggest deleting PulseAudio user settings to clear any old information about audio devices

rm ~/.config/pulse/cookie ~/.config/pulse/*.tdb

and reboot system so PulseAudio can create new user files

If audio is still not working, please post more ALSA information about audio devices

sudo alsa-info.sh --upload

Thanks for helping
Performed these steps but still not working.

alsa info: https://alsa-project.org/db/?f=0a7fad005018f9cd933173a74f75c7a28d2389a9

ALSA data shows onboard ALC295 audio settings that headphone output is turned on and set to 100% level

Simple mixer control 'Headphone',0

  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]

But the output for the internal speakers has level set to zero and is muted

Simple mixer control 'Speaker',0

  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]

The output for the speakers may have been muted in error by the Auto-Mute Mode in ALSA
This feature is supposed to mute speakers when a jack is plugged in for external headphones
but might be not be working correctly

Simple mixer control 'Auto-Mute Mode',0

  Item0: 'Enabled'

Since the headphone socket is not in use, I suggest turning off the Auto-Mute Mode in ALSA

amixer --card=0 sset 'Auto-Mute Mode' Disabled

The Speaker output might automatically unmute when the Auto-Mute is disabled
But if needed, this command will increase audio level and unmute speakers

amixer --card=0 sset 'Speaker' 80% unmute