HP Ryzen 5300u laptop locks up on wake

Hey guys I’ve got a 15 inch HP laptop with a Ryzen 5300u and Radeon graphics but when you shut the lid and wake it the screen will either be black or lock up the lock screen or desktop and go back to a black screen. I’ve tried both kernel 5.15 LTS which it came with and kernel 6.0.6 but it’s basically still the same issue

Would you guys like any extra information and is this a known issue?

Would this be a simular issue?

EDIT: Nevermind I don’t even have that option in the bios.

Would disabling the cstate in Linux itself fix it?

I think I might of found a fix to the issue and it did have to do with cstate

You will need to add these Kernel flags

open up /etc/default/grub with nano or with whatever text editor as root and add amd_iommu=on iommu=pt processor.max_cstate=5 rcu_nocbs=0_11 in the GRUB_CMDLINE_LINUX_DEFAULT line in the “”
than do sudo update-grub

And that should fix it

I hope this helps everyone on Manjaro running into this issue :smile: