HP F4240 printer prints every text with shadow

I cleaned the print heads with the HPLIP control panel, aligned the heads etc.

When I print anything from the computer (Manjaro xfce), the text has shadows as if I was trying to print 3D text. It hurts my eyes to try to read it.

But when I make a copy using only the printer’s scanner - it prints the text correctly.

I’ve been using this printer for several years and the shadow text only started a few weeks ago.
I reinstalled HPLIP 3.22.2 according to manjaro and other help sites, it didn’t help; and then installed 3.18 because of pamac install note for HPLIP which didn’nt work either.

Before posting the problem here, I posted it on the HPLIP support website on 3-18-22, they have not responded back with any question or comment as of yet.
Since the printer prints text as it should without the shadow text when making a copy on the printer without any input from the computer, I thought it may be a problem with the text signal getting to the printer from the PC. Images and objects print as they should as well from the PC.

I’ve looked on several web sites, including Manjaro and Arch and I cannot get anyone’s solutions to work.
Here is a printer test page of the corrupted text.

What is going on?

Thanks for your help

I suppose I’m ignorant of this forum’s preferred procedures or I’m so technical minded that I understand your instruction exactly as you wrote it instead of how you may have intended it.
So, my question andreas85 is when I clicked on the 3 dots below my post and selected the pencil, it took me back to my original post. If I post INXI results there, it will either post over and erase the 1st post or append to the 1st post. Then I and everyone who looks at this will have to constantly go the top of the thread every time to see my next post. Is that what this forum wants? I’m not trying to be hard to get along with, just trying to understand.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
  • Please press the three dots below your post and then press the :pencil2:

andreas85, please read the edit of my 1st post, and you will understand why I posted the way I did.
Then I’ll get to the inxi results. thank you

Ok, what do I do? keep appending to my 1st post or Reply to the last post submitted?

[ultra@ultra-ms7b86 ~]$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=6be889fb-e5cd-4676-8afd-4e7140a6da75 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS MAX (MS-7B86) v: 3.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: H.D3
    date: 09/28/2021
  Message: No system battery data found. Is one present?
  RAM: total: 15.61 GiB used: 2.29 GiB (14.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1501 high: 2422 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1380 2: 1303
    3: 1337 4: 1378 5: 1375 6: 1374 7: 1982 8: 2422 9: 1332 10: 1375 11: 1378
    12: 1377 bogomips: 81628
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
    cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
    fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm
    mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
    nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
    pse36 rapl rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap
    smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock
    syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 26:00.0 chip-ID: 10de:1c82
    class-ID: 0300
  Display: x11 server: X.Org v: compositor: xfwm v: 4.16.1 driver:
    X: loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 445x278mm (17.52x10.94")
    s-diag: 525mm (20.66")
  Monitor-1: HDMI-0 res: 1680x1050 hz: 60 dpi: 90
    size: 473x296mm (18.62x11.65") diag: 558mm (21.97") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.54 direct render: Yes
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 26:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 28:00.3 chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.5 TiB used: 639.75 GiB (25.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 043 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC46 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HUA723020ALA641
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A840 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSC0 rev: LI00
    dev-links: cdrom
  Features: speed: 12 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 52.68 GiB (23.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 6be889fb-e5cd-4676-8afd-4e7140a6da75
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 679A-1508
  ID-3: /run/media/ultra/Ht1 raw-size: 550 GiB size: 540.37 GiB (98.25%)
    used: 437.72 GiB (81.0%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: Ht1
    uuid: 48d40e11-d416-4079-9abd-c3115f9bdfc3
  ID-4: /run/timeshift/backup raw-size: 232.88 GiB size: 228.22 GiB (98.00%)
    used: 149.35 GiB (65.4%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
    label: DDrive2 uuid: 353601dc-0eb6-45f9-9475-50f8fb8def2c
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-1: /dev/sdb1 maj-min: 8:17 size: 232.88 GiB fs: ext4 label: DDrive1
    uuid: 6e4c97b7-826e-445e-8796-72d0e38f7e36
  ID-2: /dev/sdc3 maj-min: 8:35 size: 640 GiB fs: ext4 label: Ht2
    uuid: db9f7c41-b09a-462e-a202-e0cd136c5ee7
  ID-3: /dev/sdc4 maj-min: 8:36 size: 673.02 GiB fs: ext4 label: Ht3
    uuid: dc1ff585-f270-4de5-ae19-45a09aa1bbb7
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: HP Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 03f0:134a class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 51 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 298 Uptime: 2h 37m wakeups: 0 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 alt: 6 clang: 13.0.1 Packages: 1536
  pacman: 1527 lib: 397 flatpak: 0 snap: 9 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.14

[ultra@ultra-ms7b86 ~]$ inxi --admin --verbosity=7 --filter --no-host --width

  • Did you already try to print a test-page with cups ?
  • What program did you use to print the text with ?
  • Does this happen, if you print a picture (gimp)?
  • Does this happen if you print a PDF-File (ocular)?

Here is the cups test page.

I printed text with these: Libreoffice writer, mousepad, onlyoffice and Firefox.

The image I printed with gimp had text within the image and the image and text in the image were both shadow text and shadow image. Do you want me to import both original image and scan of the printed image? I scanned the image with Xsane (on the same printer) at 600dpi because HP manager is not working.

The same shadow text and shadow image happens when I printed a pdf with qpdfview 0.4.18


  • Every printing seems to be affected no matter what program
  • Images (gimp) are affected
  • However, the colored squares do not appear to be affected (weird)

The printing process goes from the program through cups, then ends up in the printer driver and is finally transferred to the printer.

Depending on the variant of the driver, the print image is rendered on the PC or lastly in the printer.

Did you set up the PDF printer driver?

(which could now help with the analysis)

Then you could repeat the same print processes, not specify your printer as the target, but a pdf file. You can then view the PDF file with Okular.
The question would be whether the shadows are already in the PDF file. If so, you have to look further at cups.

Oh yes, please take also a look at the printer properties in the printer management :face_with_monocle:

And please try to remove the power from the printer for a few minutes :wink:

Also you could try a reset of the printer (if possible)

Have you tried to print from a different computer ?

(this would exclude the printer as source of the trouble)

Yes, the PDF printer driver is already setup and I’ve been using it for some time.
I couldn’t upload the pdf file I created from mousepad, but it doesn’t have shadow text.

I have tried to reset the printer by turning power off several times, plus I don’t leave it on 24/7 either, it is
turned off every night.

I just printed a single sentence from my manjaro xfce laptop and it is shadow text as well. Here is what it looks like from the scanned image.

I also made a “COPY” of a page of text with the same printer, which scans the text then instantly prints it - without going to the computer at all. I have done this with the usb cable completely unplugged from the printer. The copied - printed text did not have shadows - it is perfect as it should be. But any text or image that is printed from either computer is incorrectly shadowed.

Thanks for helping thus far.


  • Every print seems to be affected, no matter what program
  • Images (Gimp) are affected
  • However, the colored squares don’t seem to be affected (strange)
  • CUPS is not affected (since the pdf would then also have shadows)
  • A second computer also prints with shadows

The problem is clearly in the printer

Did you switch it off at the printer or did you disconnect it from the power supply by unplugging all cables (230V and USB)?

This is a possible step, but not a printer reset!

For a reset you must

  • Read your printer manual, or
  • Contact HP website (perhaps read FAQ)

From your tests it seems clear that the problem is not in your computer but in the printer

This is where I can’t help any further :man_shrugging:

Thank you for your help.

I do not use the printer’s power button, my printer power cable is plugged into a power strip/lightening arrester which I turn off every night.

I posted this problem on HP’s support website on the 18th of this month and the post is still “open” but nobody has asked me anything or commented at all since then. Who knows, they might not be able to help either. I may have to get another printer since this is an old printer.

I’ll have to download a manual if I can find one for the “Reset” option.

Thank you andreas85 very much for your help and guidance to my next step in this problem.

Since there is no solution as of yet - should I leave this question open just in case someone comes up with a solution?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.