Howto get rid of a popupmessage about mullvad vpn connection?

I get this message all the time when I have shutoff the mullvadclient:
Mullvad_Banner

I have even uninstalled the mullvad app, but the popup message still appears

How to make it disappear forever ?

What desktop environment is that? Is it Plasma? If so, did you have that application set up to automatically start on login?

Check the following in System Settings:arrow_down:

Workspace → Startup and Shutdown → Autostart

If you see that application in there, delete the entry. Also, remove anything to do with that application from…

  • ~/.local
  • ~/.config
  • ~/.cache

Thread tentatively moved to #desktop-environments:Plasma.

I use Manjaro original Xfce

Did you have that application set up to automatically start on login ? YES !

Well, then at least this here below still applies… :arrow_down:

I’m sure XFCE also has a settings page for automatically starting applications on login, so check that, and also make sure there isn’t a hidden directory (“folder”) with the name of the application in your $HOME.


Thread moved to #desktop-environments:XFCE.

Got this from the manual :

Session

Autostart

To launch custom applications when Xfce starts up, click the Applications Menu > Settings > Settings Manager and then choose the Session and Startup option and click the tab Application Autostart . You will see a list of programs that get launched on startup. To add an entry, click the Add button and fill out the form, specifying the path to an executable you want to run.

Autostart applications are stored as name.desktop in ~/.config/autostart/ .

Alternatively, add the commands you wish to run (including setting environment variables) to xinitrc (or [xprofile] when a [display manager] is being used).

Tip: Sometimes it might be useful to delay the startup of an application . Note that specifying under Application > Autostart a command such as sleep 3 && command does not work; a workaround is to use the syntax sh -c "sleep 3 && command"

How did you install it to begin with and which package?

1 Like

Found this:
/home/philip/.config/Mullvad VPN/

Will erase the mullvad catalog and see if it disappears.

Installed with Pamac and Mullvad package

What’s the output of:

pacman -Qs mullvad

Nope, removed the Mullvad VPN catalog but the message still popsup

[philip@Acer ~]$ pacman -Qs mullvad
[philip@Acer ~]$

[philip@Acer ~]$ sudo pacman -Qs mullvad
[sudo] password for philip:
[philip@Acer ~]$

Nothing …

Which package did you install to begin with?

❯ pamac search mullvad
polybar-mullvad-git                                                                                                                                              r10.3eeff2f-1   AUR 
    A module for showing connection status of the Mullvad VPN service.
gnome-shell-extension-mullvad-indicator                                                                                                              [Installed] 3-1              
    GNOME extension to track Mullvad connectivity
chrome-extension-mullvad-connectivity-checker                                                                                                        [Installed] 1.4-1            
    Browser extension that checks if you are connected to a Mullvad VPN server
amimullvad                                                                                                                                           [Installed] 1.1-1           AUR 
    Utility to check for a Mullvad VPN connection status
mullvad-vpn-cli                                                                                                                                                  2020.6-1        AUR 
    The Mullvad VPN client cli
mullvad-vpn-bin                                                                                                                                                  2020.6-1        AUR 
    The Mullvad VPN client app for desktop
mullvad-vpn-beta-bin                                                                                                                                             2020.7.beta1-1  AUR 
    The Mullvad VPN client app for desktop (latest/beta release)
mullvad-vpn                                                                                                                                                      2020.6-1        AUR 
    The Mullvad VPN client app for desktop
mullvad-tray                                                                                                                                                     0.3-1           AUR 
    Mullvad VPN connection status in system tray.
mullvad-vpn-beta                                                                                                                                     [Installed] 2020.7.beta1-1  AUR 

I think it was that package …

In Pamac everything Mullvad is uninstalled.

Very strange that I get the poppup message still.
Mullvad_Banner

Is it something local in the networkmanager that is wrong ?

What’s the output of:

grep -a mullvad /var/log/pacman.log
    [philip@Acer ~]$ grep -a mullvad /var/log/pacman.log
[2020-02-27T22:34:42+0100] [ALPM] installed mullvad-tray (0.3-1)
[2020-02-27T22:56:52+0100] [ALPM] installed mullvad-vpn (2020.3-3)
[2020-02-27T22:56:52+0100] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service → /usr/lib/systemd/system/mullvad-daemon.service.
[2020-05-15T00:06:41+0200] [ALPM] upgraded mullvad-vpn (2020.3-3 -> 2020.4-1)
[2020-05-15T00:18:14+0200] [ALPM] removed mullvad-tray (0.3-1)
[2020-05-15T00:18:16+0200] [ALPM-SCRIPTLET] Removed /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service.
[2020-05-15T00:18:16+0200] [ALPM] removed mullvad-vpn (2020.4-1)
[2020-05-15T00:18:16+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/log/mullvad-vpn/
[2020-05-15T00:18:16+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/cache/mullvad-vpn/
[2020-05-15T00:18:16+0200] [ALPM-SCRIPTLET] sudo rm -rf /etc/mullvad-vpn
[2020-05-15T00:26:58+0200] [ALPM] installed mullvad-vpn-cli (2020.4-1)
[2020-05-15T00:26:58+0200] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service → /usr/lib/systemd/system/mullvad-daemon.service.
[2020-05-24T22:18:22+0200] [ALPM-SCRIPTLET] Removed /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service.
[2020-05-24T22:18:23+0200] [ALPM] removed mullvad-vpn-cli (2020.4-1)
[2020-05-24T22:18:23+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/log/mullvad-vpn/
[2020-05-24T22:18:23+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/cache/mullvad-vpn/
[2020-05-24T22:18:23+0200] [ALPM-SCRIPTLET] sudo rm /etc/mullvad-vpn/settings.json
[2020-06-02T00:11:23+0200] [ALPM] installed mullvad-vpn-cli (2020.4-1)
[2020-06-02T00:11:23+0200] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service → /usr/lib/systemd/system/mullvad-daemon.service.
[2020-06-16T23:42:45+0200] [ALPM] upgraded mullvad-vpn-cli (2020.4-1 -> 2020.4-2)
[2020-07-05T04:26:13+0200] [ALPM-SCRIPTLET] Removed /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service.
[2020-07-05T04:26:14+0200] [ALPM] removed mullvad-vpn-cli (2020.4-2)
[2020-07-05T04:26:14+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/log/mullvad-vpn/
[2020-07-05T04:26:14+0200] [ALPM-SCRIPTLET] sudo rm -rf /var/cache/mullvad-vpn/
[2020-07-05T04:26:14+0200] [ALPM-SCRIPTLET] sudo rm /etc/mullvad-vpn/settings.json
[2020-07-21T01:46:47+0200] [ALPM] installed mullvad-vpn (2020.5-1)
[2020-07-21T01:46:47+0200] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service → /usr/lib/systemd/system/mullvad-daemon.service.
[2020-10-21T22:38:40+0200] [ALPM-SCRIPTLET] Removed /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service.
[2020-10-21T22:38:42+0200] [ALPM] upgraded mullvad-vpn (2020.5-1 -> 2020.6-1)
[2020-10-21T22:38:42+0200] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service → /usr/lib/systemd/system/mullvad-daemon.service.
[2020-11-14T16:59:05+0100] [ALPM-SCRIPTLET] Removed /etc/systemd/system/multi-user.target.wants/mullvad-daemon.service.
[2020-11-14T16:59:05+0100] [ALPM] removed mullvad-vpn (2020.6-1)
[2020-11-14T16:59:05+0100] [ALPM-SCRIPTLET] sudo rm -rf /var/log/mullvad-vpn/
[2020-11-14T16:59:05+0100] [ALPM-SCRIPTLET] sudo rm -rf /var/cache/mullvad-vpn/
[2020-11-14T16:59:05+0100] [ALPM-SCRIPTLET] sudo rm -rf /etc/mullvad-vpn
[philip@Acer ~]$

The service is no longer running and you’ve removed all leftover files, so the only thing left I can think of is rebooting.

1 Like

No, reboot does not help.

Popup-message still coming up.

Mullvad_Banner

[philip@Acer ~]$ systemctl list-unit-files --state=enabled
UNIT FILE                                             STATE   VENDOR PRESET
var-lib-snapd-snap-bitwarden-26.mount                 enabled disabled     
var-lib-snapd-snap-bitwarden-31.mount                 enabled disabled     
var-lib-snapd-snap-chromium\x2dffmpeg-15.mount        enabled disabled     
var-lib-snapd-snap-chromium\x2dffmpeg-17.mount        enabled disabled     
var-lib-snapd-snap-core-10185.mount                   enabled disabled     
var-lib-snapd-snap-core-9436.mount                    enabled disabled     
var-lib-snapd-snap-core18-1885.mount                  enabled disabled     
var-lib-snapd-snap-core18-1932.mount                  enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-128.mount enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount enabled disabled     
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1474.mount enabled disabled     
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1506.mount enabled disabled     
var-lib-snapd-snap-signal\x2ddesktop-325.mount        enabled disabled     
var-lib-snapd-snap-signal\x2ddesktop-335.mount        enabled disabled     
var-lib-snapd-snap-snapd-8140.mount                   enabled disabled     
var-lib-snapd-snap-snapd-9721.mount                   enabled disabled     
org.cups.cupsd.path                                   enabled disabled     
apparmor.service                                      enabled disabled     
avahi-daemon.service                                  enabled disabled     
bluetooth.service                                     enabled disabled     
cronie.service                                        enabled disabled     
getty@.service                                        enabled enabled      
lines 1-23...skipping...
UNIT FILE                                             STATE   VENDOR PRESET
var-lib-snapd-snap-bitwarden-26.mount                 enabled disabled     
var-lib-snapd-snap-bitwarden-31.mount                 enabled disabled     
var-lib-snapd-snap-chromium\x2dffmpeg-15.mount        enabled disabled     
var-lib-snapd-snap-chromium\x2dffmpeg-17.mount        enabled disabled     
var-lib-snapd-snap-core-10185.mount                   enabled disabled     
var-lib-snapd-snap-core-9436.mount                    enabled disabled     
var-lib-snapd-snap-core18-1885.mount                  enabled disabled     
var-lib-snapd-snap-core18-1932.mount                  enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-128.mount enabled disabled     
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount enabled disabled     
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1474.mount enabled disabled     
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1506.mount enabled disabled     
var-lib-snapd-snap-signal\x2ddesktop-325.mount        enabled disabled     
var-lib-snapd-snap-signal\x2ddesktop-335.mount        enabled disabled     
var-lib-snapd-snap-snapd-8140.mount                   enabled disabled     
var-lib-snapd-snap-snapd-9721.mount                   enabled disabled     
org.cups.cupsd.path                                   enabled disabled     
apparmor.service                                      enabled disabled     
avahi-daemon.service                                  enabled disabled     
bluetooth.service                                     enabled disabled     
cronie.service                                        enabled disabled     
getty@.service                                        enabled enabled      
haveged.service                                       enabled disabled     
lightdm.service                                       enabled disabled     
linux-module-cleanup.service                          enabled disabled     
ModemManager.service                                  enabled disabled     
NetworkManager-dispatcher.service                     enabled disabled     
NetworkManager-wait-online.service                    enabled disabled     
NetworkManager.service                                enabled disabled     
org.cups.cupsd.service                                enabled disabled     
snapd.apparmor.service                                enabled disabled     
snapd.service                                         enabled disabled     
systemd-timesyncd.service                             enabled enabled      
tlp.service                                           enabled disabled     
ufw.service                                           enabled disabled     
avahi-daemon.socket                                   enabled disabled     
org.cups.cupsd.socket                                 enabled disabled     
snapd.socket                                          enabled disabled     
remote-fs.target                                      enabled enabled      
fstrim.timer                                          enabled disabled     
pamac-cleancache.timer                                enabled disabled     
pamac-mirrorlist.timer                                enabled disabled     

42 unit files listed.
~
~
~
~
~
~
~
[philip@Acer ~]$

Can you not simply block this application in the notification settings?

Can I do it in the Terminal?

I have blocked Mullvad app in notification settings.

No luck !