[HowTo] Enable emoji fonts

Difficulty: ★☆☆☆☆

:information_source: Much was borrowed from gabrc52’s guide How to enable system-wide color emoji support.

Preface

Long-overdue, this guide will aid in enabling system-wide unicode emoji so they are interpreted as images, rather than unicode reserved spaces without an assignment.

Configuration

There are a couple of ways you can begin:

Using Nano
:heavy_dollar_sign: In xdg-temrinal or preferred emulator:

nano /etc/fonts/local.conf

for GVFS-enabled desktops
:gear: In Run Application or similar=

pkexec touch /etc/fonts/local.conf
gedit admin:///etc/fonts/local.conf

gedit used in this example, replace with whatever your desktop’s default editor is.

Then, paste the following into the editor.
:spiral_notepad: In /etc/fonts/local.conf:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

 <alias>
   <family>sans-serif</family>
   <prefer>
     <family>Sans</family>
     <family>Noto Color Emoji</family>
   </prefer> 
 </alias>

 <alias>
   <family>serif</family>
   <prefer>
     <family>Serif</family>
     <family>Noto Color Emoji</family>
   </prefer>
 </alias>

 <alias>
  <family>monospace</family>
  <prefer>
    <family>Monospace</family>
    <family>Noto Color Emoji</family>
   </prefer>
 </alias>

</fontconfig>

Available fonts

Use any font from the table below, available from a variety of sources —

Package Source Font name
noto-fonts-emoji Official / Extra Noto Color Emoji
ttf-twemoji AUR Twemoji
otf-openmoji AUR OpenMoji
ttf-joypixels Official / Community JoyPixels

:heavy_plus_sign: I am willing to make additions as suggested! If you know of another emoji fonts not represented here, then let us know in the comments below and I’ll append the table with it!

Corrections

Added JoyPixels as recommended by @drjackal
Resolved name and package errors in table

2 Likes

I’ve never needed to create an /etc/fonts/local.conf to accomplish this. Using a font like Noto and using a matching Emoji font has always been enough.

2 Likes

Joypixel

I f… up my fonts somehow and lost my emojis in VS Code. Then i stumbled over Your post.

Thanks a lot! I just added the aliases to /etc/fonts/local.conf, set the font to monospace in VS Code, Kate and Konsole and now i have my emojis back and even much better now, because systemwide. + :100:

The font used in the screenshot is noto-fonts-emoji with Noto Mono 9pts as Fixed Width in the font system settings

2 Likes

Glad it helped you out!

thanks a lot, it worked