How to stop Dolphin from always opening on the wrong monitor?

So, I’m starting to finish up my Manjaro installation, however one very annoying issue I’m currently facing is that some programs always open up on the wrong monitor, notably Dolphin, which opens in the furthest corner of my second monitor.

I’ve already tried a few fixes to this issue that I had found, however they ended up either doing nothing or messing other things up. I’m wondering if there’s any fix that would help here.


Welcome to the forum! :wave:

Since you’re a new user, I’d recommend you take a look at the link below:

Another tip. Do not edit your OP just to say that you’ve found a solution. Preferably, reply to your own post and write your solution there.

That way, you can mark the thread as solved yourself by clicking on the hamburger menu at the bottom of every post (the solution option is hidden there). Adding a Solved on the thread title is discouraged as per forum rules under the section “How to Post”.

Thanks! :+1:

1 Like

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.


1 Like

I solved the issue. I needed to uncheck “Allow apps to remember the positions of their own windows, if they support it” in Window Management > Window Behavior > Advanced.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.