How to set DNS server?

I added the DNS server in the System-Settings, but it doesn’t appear to propagate (I also tried setting the method to manual and automatic (only addresses)) ?

( nmcli dev list || nmcli dev show ) 2>/dev/null | grep DNS
IP6.DNS[1]:                             2a02:8070:b590:ca00:6e63:9cff:fe4a:65f5 is the router. There is no DNS-Server setting on that router.

Problem is I cannot resolve from my Desktop or phone when connected to said router, but I can resolve it when using mobile internet, hence why I am trying to change the DNS-server.

Have a look here:

and here:

or here:

1 Like

Slack is down for today.

The DNS is from your router. You should check of you can set the upstream DNS directly in your router’s settings. This way, all your devices use it.

unfortunately, already looked for that. Will need to buy a different router

Ah sorry, I misread you post.

The above message should give hints. The NetworkManager GUI should have the option to set the DNS. Your setting is the “alternative” servers that are probably not used as the primary server.

The first answer has the instructions in the first link.

1 Like

Rebooted the machine and now it has picked them up. Can connect to slack again :slight_smile:

Perfect, a restart of NetworkManager or a reconnect of your network should have sufficed but a reboot can’t hurt.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.