How to scale my display to 125%

I was using the gnome-desktop. My resolution is 1080p. When I set scaling to 100% it looks very small and when I set to 200% it looks very big. Is there any way to set in 125% or 150% in display scaling?

Not sure it’s possible in Gnome on Xorg yet. But I believe it’s possible on wayland.
It’s called Fractional Scaling.

How to enable it?

Change to wayland session in your login manager.

But since you are using nvidia it might not work.

I think so… I tried to enable it but it doesn’t work

Windows and MacOS are the only ones who do fractional scaling properly, maybe Sway (Wayland) does as well.

I use a Retina Macbook Pro (2880x1800, which is too small, 2x scaling is too big) and I don’t bother using fractional scaling because it’s nothing but problems. I just set my screen to 1920x1200 (i.e. one of the supported built-in modes) and it looks great. So maybe just pick a different available resolution and let the hardware do what it does

Not really the answer to your question but you should give KDE a try. I have been using gnome for years until buying a matebook 13" 2020.

I tried different things (wayland, patched gnome like in ubuntu…etc) but Manjaro KDE is by far the best out of the box experience. Works well and no screen tearing like in ubuntu and as a bonus i enabled hardware acceleration for video playback on chrome and indeed it works vety well (Intel GPU for my setup)

EDIT: In wayland it works well as well but most of the software has a blurry fonts issue. Some of the do offer a way to run the app in wayland but most of them don’t.

Correct me if I’m wrong, I’m still learning, but this worked for me:
Settings Manager -> Settings Editor -> xsettings -> Xft -> DPI enter the value you want. For me 125 was too big so 110 looked perfect.

Probably a bit late for you, but I’m sure there are other people (like me yesterday) wondering about this. I got it to scale to what looks like 125% by first typing into the terminal:

xrandr --output [Your output device here] --scale 1.75x1.75

Which makes everything super tiny. Then going to the display settings and changing the scale to 200%. Seems perfect as far as I can tell. No blurry fonts issue like with the Wayland solution.

1 Like

https://wiki.archlinux.org/index.php/HiDPI#GNOME

Fractional Scaling on X11 Gnome is possible, but requires patches from Ubuntu which were not up-streamed yet.
I’ve patched mutter and gnome-control-center with the patches from Ubuntu which are available on Manjaro.
Basically one needs to install mutter-x11-scaling and gnome-control-center-x11-scaling from the repo and fractional scaling on Xorg should work. Please keep in mind that this is a experimental feature from Ubuntu.
PKGBUILDS can be found here and here.

Gnome officially only supports fractional scaling on wayland as was already pointed out.

1 Like

Brand-new to Manjaro (installed it about 2 hours ago) and I can’t find these settings anywhere. I’ve opened Settings and Manjaro Settings and Tweaks, but no luck.

I found the mutter package, but can’t find ‘gnome-control-center-x11-scaling’ anywhere. Is that in one of the non-stable repos, or…?

They are currently both in testing and will likely be pushed with the next stable update.

Thanks a lot, this worked very well on xfce. They should’ve just put this settings somewhere under display settings

xsettings is only for xfce