How to preserve cpupower-gui settings?

Dear Community,

How should to preserve cpupower-gui settings?
Thanks in advance.

As i used to use it, i have saved my settings to a profile. And then with right-click on the tray icon change the profile. But i don’t remember if it worked after reboot. I think the program have some bugs saving settings. I was having some similar problem but i don’t remember exactly…

Thanks for your reply. I am in similar situation. The application forgot all my CPU frequency settings at shutdown. Is it the original intention of the developers?

I am still looking forward the solution.

see if this helps:

Thanks for the proposal. Today night I am going to check that.

Maybe this helps.

Maybe it will help, because this command does nothing:
sudo pamac remove power-profiles-daemon
Just drops this message:
Error: target not found: power-profiles-daemon
So, what can I do?

For one thing dont use sudo with pamac.

For another … the link above states

… so … did you do that ?

I tried your solution. That doesn’t work. cpupower still forgets the new frequencies.

So, i did.
Other proposals? From anybody?

Are the frequencies configured using cpupower-gui saved to cpupower configuration?

cat /etc/default/cpupower

What is status of cpupower.service?

systemctl -l status cpupower.service

And are frequencies being changed by an active tlp.service?

systemctl -l status tlp.service

What is changing my cpupower governor?
CPU governor randomly switching to powersave thus heavily limiting performance

The configuration is not saved.

The status of cpupower.service:
○ cpupower.service - Apply cpupower configuration
Loaded: loaded (/usr/lib/systemd/system/cpupower.service; disabled; preset: disabled)
Active: inactive (dead)

I do not understand the last question.

I do not understand the last question

Power management package tlp is included in Manjaro Cinnamon ISOs. If tlp.service is active it might be controlling CPU governor and overruling frequencies set by cpupower-gui-user.service

I suggest

  1. Edit /etc/default/cpupower.conf to configure frequency settings

    To set a range of frequencies, delete the comment tags # from


    and set frequencies to match CPU available power states

    To set one fixed frequency, delete the comment tag # for #freq=
    and add the desired frequency e.g. freq="3.5GHz"

  2. Start and enable cpupower.service

    systemctl enable --now cpupower

If cpupower.service is working as expected it should look like this:

[nik@gnomic ~]$ systemctl status cpupower
● cpupower.service - Apply cpupower configuration
     Loaded: loaded (/usr/lib/systemd/system/cpupower.service; enabled; preset: disabled)
     Active: active (exited) since Sun 2024-02-04 15:07:18 GMT; 2s ago
    Process: 202706 ExecStart=/usr/lib/systemd/scripts/cpupower (code=exited, status=0/SUCCESS)
   Main PID: 202706 (code=exited, status=0/SUCCESS)
        CPU: 7ms

Feb 04 15:07:18 gnomic systemd[1]: Starting Apply cpupower configuration...
Feb 04 15:07:18 gnomic systemd[1]: Finished Apply cpupower configuration