How to permanently disable swapfile

Every time my RPi4 boots, a swapfile is created in /dev/zram0. I don’t want that.

The swapoff command did not help.

Here is my fstab file:

# <file system> <dir> <type> <options> <dump> <pass>
PARTUUID=b99d8715-01  /boot   vfat    defaults        0       0

It’s not a swapfile. It’s compressed RAM used for swap.

Disable the service:

sudo systemctl disable --now zswap-arm.service

Optionally, uninstall the package afterwards:

sudo pacman -R zswap-arm
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.