How to install scanner driver for brother printer brscan5?

I am using my brother printer brother-mfc-L5750-DW as a scanner. If I scan with simple-scan always only the first two pages are scanned than it is stopping.

I have looked for an appropriate scanner driver for solving this problem. So far I am using brscan4 which is available on pamac. But after research brsan5 should be the correct driver for this brother scanner. But brscan5 is not available on pamac neither via console on sudo pacman -S brscan.

How can I install this driver brscan5

Thanks for help, Rulinux

Brscan5 is in the AUR.

The answer is in the question, install it from the AUR.

In terminal:

 pamac build brscan5

brscan5 is not available in pamac AUR

Thanks to jrichard for giving a helpful solution for installing brscan5:

pamac build brscan5

I will try it out, if the scanner will work than for brother-mfc-L5750-DW with simple-scan.

You mean Add/Remove Software? Sure it is if you enabled access to the AUR in Preferences. Search, then click on AUR on the left panel.

You are right and not right. If you search in pamac under “ALL” software sources only brscan4 is shown.

But if you go only into AUR packages search than you can find in fact brscan5. This never happened to me that under “ALL” there is are not ALL in fact. There must be a bug in pamac.

It is by design, for now, because of too much people using AUR with Pamac, and auto suggestion and searches flood the AUR servers and cause issues.

I can understand but this is not logical. “ALL” means all for me all otherwise I would search only in the specific software package sources.

One can argue it is now all repositories, AUR not really being one (despite the name). See I still am right :stuck_out_tongue:

No I have installed the correct scanner driver for this model brscan5 and also brscan-key but the scan (with simple-scan and also scanlite) always stops after the first 2 pages with duplex scan. There was a time when it worked with an older version of Manjaro.

Does anyone has a clue what can I still do?

I know. :wink:

He is.

They’re the same results as running pamac search brscan. There are 6 results.

I’d say contact Brother, but we’re lucky they support GNU / Linux at all. They only support Debian / Ubuntu and Red Hat / Fedora, so we’re on our own with anything else.

Yes, I have contacted brother. If I get an answer I will let it know to the forum.

Meanwhile I have installed SCAN to ftp. Links are in German but you surely will find it also in English by yourself. But maybe even the screenshots are already enough for explanation.
The screenshots in the description of Part 1 are not up to date.
Part 1 setting up scan to ftp
Part 2 setting up scan to ftp

The build of brscan5 is currently failing:

curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading

That’s because upstream has published a new version. The package is flagged out of date. You can either wait until the maintainer updates it, or update it yourself manually.

Thanks. That sounds meaningful. But how can I update AUR manually? The link you have given does not show any update command as far I can see.

I’ve actually tried to figure out what could be the new URL, but I have not manged it…

Hint: All you need to do is change one number in the URL. The new version is 1.2.7_0. :wink:

1 Like

I’ve found the variable in the source, which should be updated, but I have faced a rather strange issue:
I tried to add my public key to my AUR account, but I got the error message “invalid password”. I can not wind my head around it (note, that I am not a developer, nor any IT specialist). Giving the password again in the profile is only needed if I am about to change the password itself, which is not my intention. I’ve made the futile effort of writing in my current password in both of the fields, but to no avail. This hinders me from uploading any merge requests.

Furthermore a lib is missing deep in the pkg tree, which I am too tired at the moment to debug. This COVID killed all my stamina and perseverance.

Why? Are you planning to maintain an AUR package? I never linked to the Arch wiki page for that. However, I did link to the Manjaro wiki which explains how to install an AUR package manually. It doesn’t mention a word about SSH. :wink: