[How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC

Panfrost is not stable yet hence I asked to use software acceleration.

Also jellyfin can only do software acceleration as there is no vpu support for any arm gpu/vpu yet.
I run jellyfin server on nanopi neo plus2 with just 1gb ram and have been using it happily since almost a year now on) 720p h264 only.
You dont need desktop environment to run server services.
With gt king pro you should be about to do 1080p easily.

Unfortunately… My videos are basically 4K

Is there any way to flash back to Android after flashing in Manjaro(into emmc)?

Yes just use amlogic usb burning tool from beelink forum link.
There is a tutorial also.
Select your device model from the given link


Actually I’ve try that but…it still step into the Manjaro. no matter I use the USB Cable to flash or SD Card, nothing change…

You need to follow the right steps and flash android image using usb burning tool.

Maybe you can press and hold reset key which is either on the sides or the bottom

If you connect cable into otg usb-A to Usb-A when thr burning tool is opened and ready to flash then it should automatically detect the device.

It just can not be detected…I wiped out all the data in EMMC using GParted in SDCard’s manjaro system(also tried not format the EMMC and format to EXT4, nothing different)

Are you using the Burning tool windows application? I have tested it many times and it have always worked fine with or without anything on eMMC.

Please follow these steps:

  1. Power off the Device.
  2. Start burning tool in windows.
  3. Select the Image as per your device model/serial number.
  4. Press Start.
  5. Connect USB-A to USB-A in the computer and the OTG Labelled USB port.
  6. Insert the power pin in the device.
  7. It should detect the device.

These are the steps in Official Tutorial and have always works for me. If it doesn’t work for you then please check if the USB-A to USB-A cable is functional, the Windows pc have the right drivers needed.

Good Luck.

1 Like

Unfortunately, I follow the Official Tutorial and tried more than ten times(include USB Cable Flash and SD Card Flash), but still can’t recognize my device. It can be recognized before I flashed Manjaro into the emmc. I don’t know if it is caused by the loss of recovery or other errors.

Is there anyway to flash the Android OS into EMMC from SD Card’s Manjaro system?

No we don’t have flashable Android image.

You should try pressing and holding reset key or maskrom key when connecting the power button for it to enter into recovery mode from where you can flash Android using burning tool.

Are you using Windows 10 ? I had issues getting it detected in burning tool too.

Yes I use Windows 10 20H2 Version.

And this is how I do with them… Just nothing happen

Does it make usb connection sound?
If not then either your cable or USB port have a problem, even when device is not in recovery mode it will establish a usb connection with the host pc.

Try a different cable or different port.

Another then this i don’t have any other option.

No,but it used have the sound (before I flash the Manjaro into EMMC), I will try another USB Cable this afternoon, I think it’s not the USB Port’s problem because I’ve tried the same operation in 3 different PC.

Update: Still no usb connection sound after new USB Cable connected. I will try last time when I go home with my old Computer, If still doesn’t work, It may be that there is a problem with the USB Port(OTG) of the machine itself

PS: Finally!!! I tried power cable and usb cable plugin-in, and still press the reset Btn, it make sound!!!

Thx for @spikerguy 's Help!! Thx everyone!

1 Like

Hi all,
i tried to install manjaro arm xfce vim3 for my tv boxes, HG680P and Polytron PDBF2 , amlogic s905X
i use meson-gxl-p212.dtb
its work fine on armbian before
but im facing the problem on firstboot
i got error “failed to start light display manager see systemctl status lightdm.service”
i try enter tty console and run command “systemctl status lightdm.service”
give me

Lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2020-10-04 01:13:17 WIB; 33 min ago
Docs: man:lightdm(1)
Process: 769 ExecStart=/usr.bin/lightdm (code=exited, status=1/Failure)
Main PID: 769 (code=exited, status=1/Failure)

oct 04 01 01:13:17 pep systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
oct 04 01 01:13:17 pep systemd[1]: Stopped Light Display Manager.
oct 04 01 01:13:17 pep systemd[1]: lightdm.service: Start request repeated too quickly.
oct 04 01 01:13:17 pep systemd[1]: lightdm.service: Failed with result ‘exit-code’.
oct 04 01 01:13:17 pep systemd[1]: Failed to start Light Display Manager

i got some problen on both devices and both image (Vim2, Vim3)

recently i tried vim1 without any succes, never got boot setup

any solution?

its first time i use manjaro and still understanding linux os

No idea about this, the same images are working fine on their respective boards.
I cannot think of something that would be causing the lightdm to stop.

Currently I’ve been super busy in my day job and will be busy in the coming weeks so I won’t be able to reply fast.

Maybe someone who have a similar board can try it for you.

1 Like

I have tried both files meson-g12a-sei510.dtb and meson-sm1-sei610.dtb on my A95X F3 Air (S905X3) tv box.

www aliexpress com/i/4000298674631.html

But it does not work, hold the reset button, and no booting from SD card at all. no picture in the monitor. any one got it working before?

I do not have much experience with sm1 boards maybe @TheMojoMan or @dante6913 can advice something

What is the kernel that you are using?
Did you tried the https://yadi.sk/d/ZMQW85B-P6QejA u-boot.ext?

Hi and thank you for all the hard work.

I still have a few questions.

It works on most Amlogic SoCs as it does for CoreElec I guess?

Is the system stable and usable on a daily basis? And are there any limitations?

In the list above I don’t see the Minix U22-XJ, does that mean it doesn’t work on it? And among all the Android boxes with SoC S922X (AM6 Plus, GT-King Pro etc …) which do you think is the fastest and works the best?

Thank you .

Hello and welcome to the forum,

Depends on what you want to do with ur.
Limitation: gpu support is not stable yet.
There is no vpu support so all video playback is over software acceleration.

Technically it should work but it is not tested so cannot confirm anything until you try it.

Most are same just a little difference in ram and emmc speed doesn’t really make much if a difference.

Good luck.