How to install anbox on manjaro?

Instead of this, do this:

It seems that the kernel itself loads ashmem but not binder, so mounting binderfs works for me.
Also don’t forget following these steps.

Follow this if you haven’t yet.

1 Like

@SameExpert
so I have to perform the mkdir and mount step everytime I boot and now anbox is working
but there is no internet inside anbox
I tried
sudo systemctl start systemd-networkd
but no results

in a post above shows how to add to fstab

Disable systemd and use network manager, how to is posted in the arch wiki link above

what’s fstab? and which post?
I can’t find it

It’s a file located in /etc folder.

/etc/fstab automounts for you everytime you boot your PC. Open it, add this line at the end and save it:

binder                       /dev/binderfs binder   nofail  0      0

That’s because systemd-networkd should start before anbox-container-manager, but you have already started anbox-container-manager. So you should stop anbox container manager:

sudo systemctl stop anbox-container-manager

You should also enable systemd-networkd and anbox-container-manager so that you don’t need to start it everytime, by:

sudo systemctl enable systemd-networkd anbox-container-manager

still internet not working

@SameExpert

I directly copied/pasted this code
$ nmcli con add type bridge ifname anbox0 -- connection.id anbox-net ipv4.method shared ipv4.addresses 192.168.250.1/24
from archwiki
but it’s still not working.
Did I need to change any parameters?

It should work. Try rebooting you PC.

[Make sure you have done these steps properly]:

This is what I typed after rebooting my PC and anbox launched successfully.

riyango@cosmoblaze ~> sudo systemctl enable systemd-networkd anbox-container-manager

[sudo] password for riyango: 

Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-networkd.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-networkd.socket → /usr/lib/systemd/system/systemd-networkd.socket.
Created symlink /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service → /usr/lib/systemd/system/systemd-networkd-wait-online.service.

riyango@cosmoblaze ~> sudo systemctl start systemd-networkd anbox-container-manager

riyango@cosmoblaze ~> anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity`

But there is still no internet

I don’t know why. The problem must be with Anbox itself, not Manjaro.

  • Did you try opening any webpage in WebView Browser Tester?
  • Are you using anbox-image or something else?

I have tested through the webview tester and brave browser and it’s the default anbox image

did you install dnsmasq?

also try to use only one networking method at a time.

what’s dnsmasq?
I have tried that networking option and copied/paste the code from archwiki but still not working.
So did I need to change any parameter in that code?I just copied and pasted directly

Read the wiki page

How do I install anbox module dkms, I have kernel 5.9 I know it not there in aur anymore. Should I install kernel 5.4 or below

read the arch wiki and this thread, DKMS is no longer needed

I follow all instruction but I always fail i even got error while making anbox-git and tried with snap I have 5.9 kernel and fish as default shell how I install anbox

This is my first reply on this forum. Just guide me if I did any mistake.

I’m on Linux 5.10.13-2-MANJARO kernel. I have run ls -1 /dev/{ashmem,binderfs} command, and it output as follows.

/dev/ashmem
/dev/binderfs:
binder
binder-control
hwbinder
vndbinder

Then I installed anbox-git AUR package, and it completed successfully.
But when I try to enable anbox-session-manager.service by running sudo systemctl enable anbox-session-manager.service but it gives Failed to enable unit: Unit file anbox-session-manager.service does not exist. output.

When I try to run anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity command, it takes a while and output [org.freedesktop.DBus.Error.ServiceUnknown] The name org.anbox was not provided by any .service files

I have search through internet but I found nothing… Thank you in advance!

EDIT:

Solved by enabling the service by sudo systemctl enable /usr/lib/systemd/user/anbox-session-manager.service command.

1 Like

ok so finally with all your help I figured out how to install anbox with linux59 here is the quick guide
so first
let’s issue


$ sudo mkdir /dev/binderfs
$ sudo mount -t binder binder /dev/binderfs

then after mounting binderfs

add the entry in the /etc/fstab file

binder                       /dev/binderfs binder   nofail  0      0

then install any anbox-image from aur
then after install image install anbox-git from aur
then first to enable network I used systemd-networkd
using this command


$ sudo systemctl enable --now systemd-networkd.service

then
enable anbox container


$ sudo systemctl enable --now anbox-container-manager.service

then enable


$ systemctl --user enable --now anbox-session-manager.service

and reboot your system
and then most probably anbox should be working

10 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.