How to install a specific version of linux headers?

Hello there,

I am try to using Manjaro in a parallels VM. My problem is, that the guest tools expect the same linux-headers as the kernel of manjaro.

$ uname -r

but the installed linux-headers are

$ sudo paceman -Q | grep headers
linux-api-headers 6.4-1
linux65-headers 6.5.9-1

parallels expect the version 6.5.5-1

How can I install this specific version?

I think you should update your kernel to the current 6.5.9. It is a rolling release, only updated systems are supported.

And linux-api-headers does not equal linuxXX-headers.

linux64 is EOL - not in the repo anymore.

And rightfully so - you need headers corresponding to the kernel - always.

One could suspect your package database is not in sync with mirror - usually happens when you do not use yu with pacman -S

sudo pacman -Syu linux65-headers

It is recommended to install headers for all currently installed kernels (after system update), this could be done via this command:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

(credit to @dalto)


thank you very much for your reply.

Anyway this doesn’t solve my problem because I need an older Version of linux65-headers. The installer of parallels expect the version 6.5.5-1 but pacman installing the newest one which is 6.5.9-1.

because of that parallels won’t install the guest-tools.

What package exactly you want to install and how? Before trying to bork your system by installing previous kernel versions maybe we can help you in your real task?

Partially updated systems are not supported. You don’t install an older, possibly insecure version of a package and expect things not to break.

1 Like

Hello Wollie,

at this time I don’t tried any ways to install the linux65-headers-6.5.5-1 because I don’t know how.

My main problem is, that I can’t install the parallels (for Mac) guest tools on my manjaro virtual machine.

I had this problem a few months ago and wrote the support of parallels, they ignored me for a few days and then replied I should try to update my parallels after that it worked. BUT it worked because the added the new kernel.

Now I installed a new version of Manjaro and the actual kernel is newer than the supported one of parallels, if I am waiting a few weeks they will add the new support.

But I don’t want to install a virtual machine and wait a few weeks to get it running.

Because of this I’m trying to find a solution to get this problem fixed in the future.

hello ben,

sure I know but I don’t have a other option, cause parallels is to slow with updates for arch based linux.

So this is the package?

Please tell us how you exactly intend to install it and from where you get it.

Hello Wollie,

the parallels guest tools are from my hypervisor parallels.

I can’t paste links but if you search for parallels you will see the software. It is an hypervisor for Mac, and the guest tools are drivers to communicate with the virtual machine from my Mac.

Like the guest tools of VMware or Hyper-V

Sorry, this is still too unclear to me. I’m familar with

  • Manjaro repo
  • Arch
  • Flatpaks
  • etc.

but still have no idea how you get the code and by what procedure you intend to install it…


You can’t. Manjaro doesn’t have archived repos. So you can either find a way to patch Parallels, install kernel+headers from your cache (if you have them) or edit PKGBUILD and compile whatever version yourself OR use a supported kernel in the first place.

It comes thru a iso from parallels which is mounted after install of the os.

Could it work with kernel 6.1, eventually? Or others?

only if I downgrade manjaro to the same version.

kernel 6.1 is not a downgrade of 6.5. How do you deduct you need 6.5.5?

you see it in my first question. There is the error log of parallels, which tells, I need 6.5.5-1

So your VM is still 6.5.5. Why not updating it, installing the headers and then mount the ISO? Would you expect it still asking for headers for 6.5.5?

1 Like

I installed the newest iso from today, how can I update Manjaro to 6.5.9?

I thought it is the newest version