How to hide mouse cursor with mpv and kodi?

I am using Manjaro for nearly all my stuff (manjaro kde for main desktop pc, for my MPD music player in my vim3l, for my parents pc etc…). Until recently I was using my main pc as my video player, but i decide to build a htpc (x86 base, x570 motherboard and ryzen 4350g APU). The goal is run kodi as interface, to organize and browse my collection, but use mpv as player. There is a few function that only mpv have, like their interpolation technic that is excellent in 60hz display… I decide to give a try to kodi only because there is the external player function. First i wanted to use libreelec but it’s too basic. I use manjaro xfce as base for my setup, i keep xfce for administration purpose.

Kodi is working fine, after configuration of the “external player” function, when i’m in kodi session any video is read by mpv but the mouse cursor do not disapear. In xfce session the cusor disapear at it should when i play a video with mpv. I try to disable the function in kodi settings to have a mouse but it do not change the problem in mpv.
This problem seems to be specific to the session that the kodi package create at installation.
Best regards

It’s not a solution to your specific problem, but as a workaround, you can use unclutter to hide mouse cursor every time after mouse inactivity. Maybe it helps.

1 Like

Thank you for your answer, i try to install it and add it to xinitrc. It is not working, so i try to start it via a ssh shell and i got this :
$ unclutter
[src/util.c:5] ERROR: Received error: Failed to connect to the X server.
unclutter: Failed to connect to the X server.

Edit : sorry to be stupid, i just add -display :0.0 and it works. Thank you.

Maybe someone have a more “elegent” solution ?

Edit 2 : well, another problem, it is not working when i add it to xinitrc, only when i directly start it in a terminal (ssh).

Edit 3 : i look for a way to start this command with kodi, xinitrc do not work, i also try to create .desktop file in .config/autostart without success

For this user adding to xinitrc works. Maybe it helps.

I use Ubuntu MATE and for me works to put unclutter into Startup Applications.
What Desktop Enviroment do you use?

How about start unclutter before kodi and kill after kodi exits (as an ugly workaround)?
unclutter & kodi; killall unclutter

I found the solution but forget to come here to report it.
I red the Lightdm conf files and it seems to not read xinitrc but only the scripts in xinitrc.d directory. So i create a script with unclutter and it works.