How to hide GRUB menu ? when

Hello all, I am on xfce only

GRUB menu is not hidden on boot or reboot, how do I hide it ???

$ head /etc/default/grub

GRUB_DEFAULT=saved
GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true
 

I looked in /etc/grub.d/00_headers L310-318

# No hidden timeout, so treat as GRUB_TIMEOUT_STYLE=menu
timeout="${2}"
style="menu"
fi
cat << EOF
if [ x\$feature_timeout_style = xy ] ; then
  set timeout_style=${style}
  set timeout=${timeout}
EOF

Do I change this in here or there is other way to do this ???

You can Use this configs:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR=“Manjaro”
GRUB_CMDLINE_LINUX_DEFAULT=“quiet udev.log_priority=3”
GRUB_CMDLINE_LINUX=“nomce”

and don’t forget to do “sudo update-grub” after you save /etc/default/grub file.

2 Likes

Thanks @xAndre, but that did not help. It just prolonged the boot time to 10 sec. since GRUB_TIMEOUT=0 is deprecated according /etc/grub.d/00_headers file.

Try if one of these 2 alternative settings work for you:

GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=menu

or

GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden

Hello @Wollie, I tried both and nothing, I also tried

#GRUB_TIMEOUT=3
GRUB_TIMEOUT_STYLE=hidden

it did’t help, it reverts to default which is 5 ces. and menu
Thank anyway.

You also tried this configs that i told?

@xAndre, yes, and nothing.

I’m on Manjaro 20.1 mikah with KDE Plasma and i use this configs. I don’t know why XFCE doesn’t work. :thinking:

@xAndre

I am also on 20.1 Mikah only xfce. Colud you check your /etc/grub.d/00_headers file and see if there’s anything weird say from L300-320 ?? Something like I initially posted ??

My “/etc/grub.d/00_headers” is empty or do not exists.

For lack of proper solution, I used this solution from the archived forum.
So in the /etc/grub.d/30_os-prober file I changed this line of code

adjust_timeout () {
  if [ "$quick_boot" = 1 ] && [ "x${found_other_os}" != "x" ]; then
    cat << EOF
set timeout_style=hidden # was timeout_style=menu
if [ "\${timeout}" = 0 ]; then
  set timeout=10
fi
EOF

And it works, but I don’t know how it will behave if trying this with dual boot.
So for anyone that tries this, its at your own risk.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.