How to get Manjaro? ISO failed

I broke my Manjaro/KDE doing an update some months ago - gave up till now. Going to try this again with a new install but no joy. I downloaded the Manjaro-KDE ISO from the net website and I downloaded Rufus. (apparently the only install available is to create a bootable USB)

So I put the info into Rufus’ fields and it reported that the ISO file is incompatible and told me that it would try to load the dd file instead. (???) All completed and Rufus reported “FINISHED” so I put it into my Lenovo Thinkstation E31 and it booted the live version of Manjaro.

I installed Manjaro-KDE onto the 500 gB HDD and it appeared to be successful but when I try to boot from the HDD the machine tries to go to an online website in console mode. It seems that the only way that I can get a usable USB installation is to wait until after Jan 2 and to buy one from a 3rd party supplier. I’m going to guess that the dd file (as opposed to the ISO file) is at fault. (???)

I still have the other 500 gB drive with Manjaro on it that I tried to update. I kept it in hope that maybe someday I might learn enough to recover it but in the meantime I’ll persist in trying a fresh install on a diferent drive. Any suggestions would be welcome - but we’ll need to keep it in some pretty basic / simplistic terms. I’ll never be a Linux guru. Tnx for all.


Create a Ventoy USB, and then just copy your ISOs over to the stick. No need to do anything special for each and every ISO.

Ventoy is available for Windows and Linux. For a running Manjaro system, you can install it from the official Manjaro (community) repository.

pamac install ventoy

What does that mean? Can you elaborate or provide additional info?

1 Like

Another option would be Etcher


Or why not try mintstick/manjaro.

Etcher is no longer in our repositories due to electron hell. AUR users are not that happy either.

There is an AppImage somewhere.

Initiating & establishing link.
Intel R Boot Agent GE v1.3.81
Copyright C 1997 2011 Intel Corporation

Client MAC address FC 4D D4 32 D9 C6 GUID: EC53DB27

DHCP | - | -

ERROR 1962 no operating system found

Repeat Boot Sequence automatically in 1 sec

Loop repeating inadfinitum … Whatever this was supposed to do has apparently failed on my installation. I’ll try Ventoy. The computer will boot into a ‘live’ (volatile) version of Manjaro so I’ll need to complete all the operations before shutting it down. I’ll see how that goes. I tried a download the other day but there’s no access to the hard disk and it didn’t tell me where it downloaded the file to - and I never did find it. That’s what makes it so much fun though… LOL At 77 y o, I think that I might be getting too old for this sort of thing. :slight_smile:

Thanks, Winnie. I appreciate you.

1 Like
  1. Dax, you did not mentioned that you turned off Secure mode in BIOS/UEFI and also turned off CSM (compatibility support module). Did you? I think it could be the reason why motherboard firmware do not see Manjaro’s boot loader.

  2. Also you can try to check ISO file you downloaded: if their hash sum are equal to original to get to know that ISO file was not damaged during downloading.

Oh, woe is me! I’ve gone from bad to worse - from the frying pan into the fire! I went into the BIOS and changed the secure mode and CSM. (dunno if they should be on or off but I changed them from what they had been) Now, the machine quit sending any video signal to the monitor!

I removed the Nvidia digital card and tried using the analog output on the mb. No joy. I replaced the Nvidia card with an ATI Radeon card. Still no signal to the monitor - it just bounces the little [analog] / [digital] icons around the screen and suggests that I check my video cable.

When I power up the machine, it runs and completes the POST, verifying with a single BEEP but then I don’t know what it does afterward since there is no video. I have tried pressing F1 to go into BIOS but ??? don’t know it that happens or not. I was hoping to go back into BIOS and change the settings back the way that they were but now I’m pretty much 'dead-in-the-water with no options that I can imagine. ???

I started up the old Windows laptop and used Rufus to CLEAR the DD Manjaro program that it’d placed onto my 4 Gb USB stick. Then I downloaded Ventoy and tried that but it ran along for a while on the wait-O-meter and finally stopped and said that it had an error. I tried it again twice more with the same result, so I went back to Rufus and did the operation again to put the Manjaro program back onto the USB stick.

With no video ouput on the main machine, I’ve totally run out of ideas to try. At this point, even if I were to buy a verified Manjaro USB boot stick from a 3rd party distributor - it seems that all would be futile until I can devise a way to get back into the BIOS to change those parameters back to the way they were. If anybody has a thought of a solution - I’d sure like to hear from them. Did I just destroy my computer? Oh, woe!

I am sorry, Dax, is it non-typical case for my 5 PCs I had/have before/currently: “if to turn off CSM and Secure boot options in BIOS, then PC became unbootable or send no video signal”.

I advise and queue the next actions:

  1. did you tried to manually switch you display to target video input from the PC? May be it switched into another input port, IDK

  2. reset BIOS. and boot up the PC again. If you can’t find user manual for your PC, if it is a desktop PC, you can try to reset BIOS/UEFI by doing this: pull out the power cord, remove 3 Volts battery from motherboard’s socket (remember polarity of the battery). Press power btn in try to power PC on (it needs to empty all stored energy in capacitors of PSU, motherboard).Wait for a few tens of minutes. Plug back the battery onto motherboard’s socket. Connect power cord. Turn the PC on.

and request community review for these fixes.
If someone will approve those fixes, you can try to do this.

VIOLA! (and VOILA!!!) The Lenovo E31 is percolating again! I took it over to the trade college yesterday and it was ready to pick up by noon today! They even loaded it up with Manjaro KDE Plasma like I had been trying to do. So what did they do?..

The machine was handed off to one of their senior students as a project and I sat down with him for a talk when I picked it up today. Curt said that he tried everything that he could think of to do but it would only come alive and report a single BEEP with a dark monitor and no clue of the trouble. (That’s what it’d been doing for me too.)
[​IMG] [​IMG] upload_2023-1-12_15-34-40.jpeg

He said that he’d experienced a similar problem with some game consoles that wouldn’t respond and that he found out that if you pulled the RAM cards out and reseated them, that it would reset the microprocessors back to default parameters. So he pulled the RAM cards out of the Lenovo E31 and reseated them. And it WORKED! The BIOS came back, the video card sent a signal to the monitor and the machine began looking for a boot sector.

I asked him about the BIOS settings and he said that he didn’t need to do anything with that because it already had done a reset of the factory default settings when he looked at it. Whether I did that when I powered it down and started it 4 consecutive times - or when he pulled the RAM cards accomplished the reset - we really don’t know. Anyhow that’s moot at this point.

He put the Manjaro KDE OS on my USB stick and installed it onto the 500 Gb HDD. I asked what application he’d used to transfer the ISO file and he told me that he’d used Etcher. He said that he’d heard other people describe the problem with Rufus causing the DD error.


Anyway, it cost me $5 and 24 hours later - all is well again. I LOVE it when a plan comes together! :) I’m proud of those kids over there!


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.