How to enable Hibernation in Manjaro?

I want to enable Hibernation option in Manjaro… I know that it is disabled by default in most of the case… But in my case I can see Hibernation button but can’t use it… Why?

It is like when I hibernate my pc and open it, it almost take same time as before to boot and nothing special. It just shutdown.

Could you please tell how can I enable it?

My Manjaro and System Specifications:-

“Operating System: Manjaro Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.15.21-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-5010U CPU @ 2.10GHz
Memory: 3.8 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 5500”

If need more info. please tell…

Output of Systemd-analyze
“Startup finished in 4.566s (firmware) + 3.312s (loader) + 4.263s (kernel) + 21.958s (userspace) = 34.101s
graphical.target reached after 21.958s in userspace”

if needed :slight_smile:

By the way! I have tried the way to do so, but still it didn’t help me… Like copying UUID and pasting it on GRUB… not sure what we say to it… But I tried it in my Manjaro that I have installed earlier… and had to reinstall due to of some problem… I guess it is okay. Now I am having a fresh install of Manjaro pease tell me how can I enable Hibernation…

You need to create a swap parition/swap file to enable hibernation. See Swap - Manjaro

Please have patience with your topics, and you can edit your first comment to update it with details, so is not looking like you are powerposting … Aside the Swap part suggested above, see also Power management/Suspend and hibernate - ArchWiki

1 Like

Maybe your forgot to update grub. Also you also have to configure and regenerate the initramfs.
I did it few weeks ago, my root partition is btrfs but my swap file is located in my home partition in xfs.
There are quite a lot of operations to do, i followed what they say on the archwiki as @bogdancovaciu told you.
Do not forget this issue if this applies to you (from archwiki):
If the swap file is in /home/, systemd-logind will not be able to determine its size and thus will prevent hibernation with the following message: Failed to hibernate system via logind: Not enough swap space for hibernation. See systemd issue 15354 for two workarounds.

Hi @Jitesh,

You need to have swap space, at least as much as you have RAM, IIRC.

Have a look here:

https://wiki.manjaro.org/index.php/Swap

1 Like

BTW I know what is needed for it… like it needed a swap partition… I have of something 8gb cause I am using Manjaro in 4gb ram pc… And I guess 8gb should be must for swap. BTW could you please tell from scratch…

So, that I can do without having any error…

I have tried all the way as I told earlier… I copied UUID of swap partition and pasted in GRUB by writing some extra commands (copy paste but not UUID). So, that’s what I had also did… but didn’t worked for me… Could you please tell by detail ??

I honestly don’t know how to do it, as I’ve never done this, seeing as I don’t use hibernation. I only go by what I’ve read here.

That’s also why I removed the solution mark, as I don’t really know the steps or have really helped you.

Best I can do is point you here:

https://wiki.archlinux.org/title/Power_management/Suspend_and_hibernate#Hibernation

I being confused… I did what it said in the link you gave me earlier but now a new… omg, could you please help me to do it… I can do it now. BTW I read the article about swap that you sent me. And I did what they said. But now I think I need to set up hibernation… If you know how to do please tell… I am ready to give all outputs :slight_smile:

It is like boring to read forms and those kind of things :no_mouth:

I prefer to use swap partition rather using swap file… cause it is easy to create a swap partition. BTW could you please help me? to enable hibernation?

BTW your links had helped me that’s why I had added solution mark :slightly_smiling_face:

Thanks. But helping didn’t solve it yet, only you can do that. :wink:

I am really confused in it… BTW I have a swap partition, but useless cause I can’t do anything with that… :no_mouth:

In other distros, for me it was easy to setup cause we just had to copy UUID and paste in grub after that update then hibernate… but here case looks different :confused:.

OK, I’ve said repeatedly that I’ve never done this, so if something gets borked it’s not on me.

Did you create a swap file or a swap partition?

Edit:

Please provide the output for:

swapon

I guess I was following someone else with same thing…

NAME TYPE SIZE USED PRIO
/dev/sda9 partition 8G 0B -2

OK, so it’s a partition. Now we must get the UUID. Please provide the output for:

blkid

Tip:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

```
pasted text
```

This will just cause it to be rendered like this:

Portaest sed
elementum
cursus nisl nisi
hendrerit ac quis
sit
adipiscing
tortor sit leo commodo.

Instead off like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

I followed this link and it helped in my case… I guess I had forgot one thing thing to do was something to add resume in hooks :face_with_hand_over_mouth:

I don’t know that is right way to do or not but yeah… I guess it is working fine… :grinning:

1 Like

If it’s working, then I’m no longer necessary, which is cool. Glad you got it managed in the end.

I guess even here you helped me… Thanks a lot.

BTW! could you please tell me more about hibernation when and how should we use it… I mean should we have to take regular restart something so that it not break or something not happen wrong or it is fine… even if I don’t do restart or something like that it is going to handle…