How to disable auto black screen?


I just installed Manjaro XFCE. If I’m away from the computer for a few minutes the screen goes black. How can I disable this?
I see on this forum that people say you can go to System Settings → Workspace Behavior → Lockscreen. On my other PC I run Plasma Desktop and I have this menu there, but I can’t find any “System Settings” in XFCE.
Can anyone help me please?

KDE and Xfce each use their own settings management.


Xfce power management has a Presentation Mode to disable screensaver or suspend settings

Left click Power Manager plugin in system tray to turn it on

Power Manager Plugin Properties has an option to show an additional indicator when Presentation Mode is on


xfce:xfce4-power-manager:panel-plugin [Xfce Docs]

Or use this command to toggle Presentation Mode on/off

xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/presentation-mode -T

Thanks guys. I found the Power Management menu, but switching off the “Display power management” didn’t seem to work. But I will test out the Presentation Mode :slightly_smiling_face:

The XFCE Power Manager rather confusingly groups “Blank after” together with “Put to sleep after” and “Switch off after” under the “Display Power Management” main toggle – but that toggle in fact only affects latter two; former is a pure-software thing.

Over here it works to set “Blank after” explicitly to “Never” and disable that main toggle; my screen is then never blanked nor switches off; no “Presentation Mode” needed

(of course also set “Never” on the System tab for “System Power Saving”)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.