How to completely delete firefox of Manjaro

Hi I have been trying to delete firefox off of Manjaro but It does not seem to want to let go!
I have tried via add/remove programs, I have tried through terminal.

sudo pacman -R firefox
sudo updatedb
I even went in and manually deleted the ~/.mozilla directory

no matter what I tried firefox still shows up in my “start menu”

I have logged in and out, restarted. run stacer/bleachbit everything I can think of, but it just stays on the system. It won’t open, but the icon still exists.

I would really appreciate it if someone smarter than me could tell me how to get it off my system.

See if you have a .desktop file of Firefox in the directory ~/.local/share/applications/ and if yes, simply delete it.

This would explain why it shows up in the Whisker menu even though you removed it from your system.

1 Like

That did it! thank you very much for your solution! :blush:

quick question again. when I run the command locate firefox now it shows me these files:

am I safe to delete these as well?

1 Like

I don’t have any of these files in the /etc/ directory on my system.

To find out which package (if any) owns these files, run pacman -Qo path/to/file for each file.
For example:

pacman -Qo /etc/manjaro-firefox-developer-edition.ini

The output will show you which package owns these files. If no package owns them, you can delete them, but if they belong to some package, leave them be.

Thank you again for teaching a newbie!

I got these results on all 3: is owned by manjaro-browser-settings 20201114-1

could this be that I think it was set as the default browser?

1 Like

This package contains some browser settings for various browsers (Firefox, Chromium, etc).
For example, I know that it sets as the default home page in some browsers, which of course can be changed from within the browser.

The PKGBUILD file of this package can be found here.

1 Like

Thank you. I’ll leave it be since I’m not 100% sure what to do with the PKGBUILD file. as long as I got firefox off my system, I’m happy.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.