How to change Cheese softwares' webcam settings?


I thought there used to be menu for settings but i don’t have it now. How do i change Cheese’s webcam settings now? Icon on the left gives just general menu, and arrow on the right minimize the window. Clicking Photo/Video/Burst won’t give any settings menu, neither Shot button nor Effects.

(i would attach a screenshot/link if this allowed but it seems not to be allowed)

1 Like

Click the overflow menu (3 vertical dots) in the upper right and choose Preferences.

1 Like

No settings menu evident on mine either (Manjaro KDE). Will be happy to upload a screenshot having obfuscated my ugly mugshot first in GIMP. :blush: :roll_eyes:

Could this be a theme issue?

1 Like

Most definitely. Try a different GTK theme.

1 Like

Thanks, I will do so & test in case it helps the OP (I mostly use other software for webcam stuff).

Suppose it’s always expected to have UI inconsistencies when running GTK stuff on a (mostly) Qt-based system; I already did some stuff to try to integrate the look and feel so will try to document better what I do in future (I do log most stuff e.g. software installation, system upgrades) but not this, as of yet.

1 Like

Hello! Thanks for the replies. Yeah, i don’t see any triple dots (or any dots) in Cheese’s ui.
I’m on Manjaro Xfce.

Upper right corner there’s 4 icons: “minimize”, minimize, maximize and close.

Seems like a bug reported upstream:

The second linked page suggests as a workaround to use dconf-editor in order to access the application’s settings (dconf-editor /org/gnome/cheese).

I also tested cheese-git from the AUR and it has the same behaviour.


Thanks for posting those links. Seems like a rather short-sighted move on their part and effectively turns what was a quite useful utility into little more than a point-and-shoot affair (can’t change resolution etc.)…


I suppose this is the only solution we got around atm, so i mark this as solution, though i’m not familiar with dconf things, Terminal won’t launch anything with that.

The another available webcam software Kamoso was so laggy and gave odd tint on liveview that i hoped Cheese were the one i could use :sweat_smile:

You have to install the package dconf-editor from the repositories and launch it using Whisker menu or by running dconf-editor in a terminal window.

When launched, navigate to /org/gnome/cheese and there you can modify the application’s settings.

1 Like

This issue is present in possibly every DE except GNOME, it is not a GTK theme issue. Here is the patch which fixes it (enables Cheese to use CSD in all DEs). I don’t know whether the upstream devs will accept it.

(for some reasons, I cannot put link in my posts, so I entered it as a code)

Someone made a Launchpad PPA with this patch, and I can confirm that it works in Linux Mint.

It would be great if someone could make an AUR with from either this Debian package (I don’t know how to do that) or by applying the patch to the upstream source code, or even better, if this small patch is included in Manjaro’s default repositories.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.