How do you make Pulseaudio automatically switch to headset input when plugged in?

When I plug in Apple earbuds, the output port automatically changes to them, and I can listen just fine, but the input still remains internal microphone instead of the headset microphone. Is there any way to fix this? The picture shows how the input device does not change before and after plugging in the earbuds.


Check in the audio config, there’s an option for that, “add the new output when it’s plug in” or something like that

That is the OPs point - it adds the new output but not the input…

Did you activated “Automatically switch all running streams when a new…” also?

If you have High Fidelity Playback enabled you won’t be able to use the microphone on the headset, as far as I can determine. Try setting it to headset mode … but the sound quality won’t be good enough for music, unfortunately.

If it’s a wired headset, does it have a single four-pole 3½mm plug? That might also be the issue, depending on the socket on your machine.

1 Like

The automatically switch all running streams… only works for the output. I think I found a part of the problem. When I plug in the headphones, the settings show that the headset microphone is unplugged until I manually switch to it, does anyone know a fix? The output, however, correctly works through the headphones.

You might want to try reading this
Under point 7.7 Correctly detect microphone plugged in a 4-pin 3.5mm (TRRS) jack

I tried various options for acer although my specific model is not in this list HD-Audio Codec-Specific Models — The Linux Kernel documentation

maybe you will get lucky!

please post system information

inxi -Fxxz

and list of audio capture devices

arecord -l

and use </> or Ctrl+Shift+C so information is formatted correctly

Audio: Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8
Sound Server: ALSA v: k5.8.3-2-MANJARO

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3204 Analog [ALC3204 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

If the headset microphone is detected as unplugged Pulseaudio will trying to avoid connecting to a device that is not detected

I think @BG405 was on the right track about this

Apple earbuds use a different wiring standard compared to the jack socket on the laptop
I posted about this before - Headphone Microphone Not Detected

incorrect jack connections may be why the microphone is showing as unplugged, but it can be caused by other problems too
it is not difficult to obtain a headset adaptor to correct for a difference in wiring
but some Apple headsets have built-in remote control buttons and might not work even if the jack connection is corrected