How do I report a Raspberry Pi bug?

After messing around with a network issue I’m having, I’m confident that this has to be a bug in Manjaro. It works out of the box on Raspbian 64-bit.

Where do I report this as a bug? This is a bug somewhere in the kernel configuration or the system configuration, and it only appears in the Raspberry Pi version.

I’ve posted the bug details and my attempt to diagnose it here.

If it’s a kernel issue, you can file an issue here if it’s just a configuration issue in the kernel or on the Raspeberry Pi kernel github if the issue has not been reported there already.

The PiOS kernel and ours are the same. We just have more modules enabled that people here want.

Gentoo avahi wiki:


The pi4 kernel:


After some consideration, I think this is probably just a bug in how the system is configured, not the kernel config.

Where do I report bugs like that?

It depends on what part of the system the issue is within.

A distribution (like Manjaro) is simply lots of different software put together to form a working system.
In our case, most of our software packages come directly from Arch Linux (and Arch Linux ARM), so we only maintain some packages.
Things like avahi and other network software, we get from Arch Linux ARM and is largely the same as it is on Manjaro x64.
So to troubleshoot this further I would try setting this up on an Arch Linux ARM system, to see if it’s a Manjaro problem or an Arch problem.

That’s a great suggestion, thanks.

So, when it comes to things like (for example) /proc/sys/net/inet4 are these up to Arch or Manjaro? Because some of those settings are different from Raspbian (sadly, these aren’t the root cause of the bug).

Those are likely a result from the kernel config options, but could also be up to the init system and other services.

Strit, I tried to install Arch ARM, and unfortunately that didn’t go well. I couldn’t get it working, something about there being a kernel issue with my SD card? I gave up.

What would you recommend as my best path forward? Should I just file a bug against the kernel as you suggested above? Or is there a better venue for this, in case it’s in the init system or other services?

Hi Strit. I finally got Arch working, and everything works fine. I’m using the install from here: , with the exception that I had to make some tweeks to uboot due to a bug related to my board.

So again, avahi on Arch works just fine. I can discover other devices and be discovered. So, this is clearly a Manjaro specific bug.

Now, do you have any idea where I should post this?

Well, main idea would be to find out where the differences are.

As far as I know, we use the same packages for the network stuff, but Arch may have services enabled we don’t.

I’ve root caused this about to the limit of my ability. I’m not sure how to take this further. If someone told me what to look for I’m happy to do that work, but I’m out of my depth. Is there not a place I can report this?

As we don’t know what the cause is yet, this forum thread is probably the best place for now.

Maybe someone with more knowledge can guide you better to find out more about the issue.

Alright, then what should my next steps be? To summarize the issue, I’m running socat as sender and receiver from my laptop to my Raspberry Pi, and there is no problem using Raspbian or Arch, but on Manjaro socat never receives these packets. I run sudo tcpdump -i eth0 host and it prints the multicast packets as they come in, so the system is receiving them, just not socat. I’ve poked around /proc/sys/net/ipv4, changing everything on Manjaro to match the values in Arch, but it had no effect. I turned on /proc/sys/net/ipv4/conf/*/log_martians but no martians were to be found in journalctl.

Is there someone else who is more knowledgeable here who can help me?

I’m not sure if I’m more knowledgeable, but I did my own tests.

Since I didn’t found which image you used and I don’t have a spare monitor, I used “Manjaro-ARM-minimal-rpi4-22.06.img” on my older “Raspberry Pi 3 Model B”. I just connected power and Ethernet.

After the first boot I used ssh root@manjaro-arm to connect to it and answered the OEM setup questions. I did not add the first user to any special groups.

The pi did a reboot and I used ssh xabbu@manjaro-arm to connect to it again. After this, I used sudo pacman -Syu socat inetutils to update and install the needed packages. Since the Kernel was updated, I did a reboot again.

I used ssh again to connect to it and ran as a normal user

socat UDP4-RECVFROM:6666,ip-add-membership=,fork EXEC:hostname

to wait for packages and send the hostname back. I used the device instead of the IP.

On a different system on the same network, I run this command,

socat STDIO UDP4-DATAGRAM:,range=

The network uses a different IPv4 range, so I changed the command to matched it. (But I believe the range is not really necessary.)

>$ socat STDIO UDP4-DATAGRAM:,range=

The Pi did respond as expected. There is no kernel problem.

[xabbu@manjaro-arm ~]$ pacman -Qi linux-rpi4
Name            : linux-rpi4
Version         : 5.15.56-1
Description     : The Linux Kernel and modules - Raspberry Pi 4 64-bit kernel
Architecture    : aarch64
URL             :
Licenses        : GPL2
Groups          : None
Provides        : kernel26  linux=5.15.56
Depends On      : coreutils  linux-firmware  kmod  initramfs  firmware-raspberrypi
Optional Deps   : crda: to set the correct wireless channels of your country [installed]
Required By     : None
Optional For    : base
Conflicts With  : kernel26  linux  uboot-raspberrypi
Replaces        : linux-raspberrypi-latest
Installed Size  : 43.79 MiB
Packager        : Manjaro Build Server <>
Build Date      : Fri 22 Jul 2022 03:20:50 PM CEST
Install Date    : Sun 07 Aug 2022 11:38:53 AM CEST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

So the question is, what is different on your system? Which image did you used? It really looks like a firewall problem, but I’m sure you checked that.

Stranger and stranger.

Is it possible this is a Raspberry Pi 4 B issue? That’s the system I have. The images I used were the 64 bit ones available through rpi-imager at the time (I used the Manjaro Plasma), but I updated them both to the latest software before testing.

Oh, and as far as firewalls are concerned, ufw isn’t even installed.

Always use Images download from Manjaro Downloads

However, since I don’t have a monitor I can use, I can’t test “Manjaro-ARM-kde-plasma-rpi4-22.06.img” . But the KDE images have firewalld enabled, are you really really sure you disabled it or created appropriate firewalld rules?

Great! Super duper. Disabling firewalld worked.

Now what is firewalld? Why is the Raspberry Pi distribution using something different than other Manjaro distributions (ufw)? Why is it misconfigured to deny multicast traffic? As far as I’m concerned this is still a bug. This should work out of the box.

It is a nftables frontend, developed by RedHat. See Firewalld - ArchWiki

Because its better integrated in KDE. (Plus it is usually considered superior to Canonicals ufw.)

It is not “misconfigured”, the firewall does its job. Plus ufw would deny this kind of traffic too. There are some default rules to allow multicast traffic, for DHCP for example, but not on port “6666” for IP

Not with a firewall enabled. This works as expected, the firewall blocks traffic if there is not a rule for it. The default rules are very specific and don’t allow UDP traffic for IP on Port 6666.

Okay, fine, but it should work for mdns.

To get this to work, I had to explicitly enable it:

firewall-cmd --zone public --add-service mdns --permanent
sudo systemctl restart firewalld

This is what I’m advocating should be enabled by default, not some random port and address that I’m using for socat. That was just used to debug the issue.

So how do I file this missing mdns as a bug somewhere?