How do I get rid of Read Only on all my partitions (even on newly formatted seperate hard drive)

Hello Manjaro Community. I am very new to Linux and have been facing a very exhausting issue for the past two days since installing Manjaro. Every answer I could find so far only worked half the way until something wasn’t reproducible anymore.
My issue is, I can’t write on any (except 1) of my mounted partitions. (Curiously it’s a random NTFS Drive I use for Windows programs). I can also write in /home/user/ but nowhere else.

Also important to know is, that I run Manjaro in Dual Boot with Windows 10. (I disabled Fast Startup)

I don’t really know what I am doing, but I have tried things like sudo chgrp adm and sudo chmod g+w or chown -R user /mnt/point (I tried different mounting points and only got error messages) or remounting with read/write permission or other things that I don’t remember.
Oftentimes I don’t get an error but it also doesn’t do anything.
Of course I also tried reinstalling multiple times.

It could be that some of these approaches are the right solution and they just don’t work bacause I am doing something wrong.

I am very grateful for any help on this matter.


# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=04CB-9640                            /boot/efi      vfat    umask=0077 0 2
UUID=45c891a1-90bf-484c-8b11-c12985cad0a5 swap           swap    defaults,noatime 0 2
UUID=79f82edf-9642-445b-a4d0-140b06d78eb1 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0


Disk /dev/sda: 931,51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000DM003-1ER1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: BDA688F4-6EC3-43C4-8BD4-B0804EAF1DEF

Device     Start        End    Sectors   Size Type
/dev/sda1   2048 1953523711 1953521664 931,5G Linux filesystem

Disk /dev/sdb: 119,24 GiB, 128032974848 bytes, 250064404 sectors
Disk model: INTENSO SSD 128G
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 84934A9F-7F2C-4031-94AE-3519188AE8D3

Device         Start       End   Sectors  Size Type
/dev/sdb1       2048   1085439   1083392  529M Windows recovery environment
/dev/sdb2  163824029 169969663   6145635  2,9G Linux swap
/dev/sdb3  169969664 250064370  80094707 38,2G Linux filesystem
/dev/sdb4    1323008 163824028 162501021 77,5G Microsoft basic data
/dev/sdb6    1085440   1323007    237568  116M EFI System

Partition table entries are not in disk order.

Disk /dev/sdc: 1,82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: ST2000DM008-2FR1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 9052A64D-9104-4A4E-9E0A-5805E4BE74F6

Device     Start        End    Sectors  Size Type
/dev/sdc1     34      32767      32734   16M Microsoft reserved
/dev/sdc2  32768 3907026943 3906994176  1,8T Microsoft basic data

Partition 1 does not start on physical sector boundary.

Disk /dev/sdd: 931,51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10EZEX-08W
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x3706d653

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdd1        2048 1953519615 1953517568 931,5G 83 Linux

System Information

System:    Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=79f82edf-9642-445b-a4d0-140b06d78eb1 rw quiet 
           apparmor=1 security=apparmor resume=UUID=45c891a1-90bf-484c-8b11-c12985cad0a5 udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7A34 v: 2.0 serial: <filter> 
           Mobo: Micro-Star model: B350 PC MATE (MS-7A34) v: 2.0 serial: <filter> UEFI: American Megatrends v: A.H0 
           date: 11/01/2018 
CPU:       Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 
           stepping: 1 microcode: 8001137 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76821 
           Speed: 1377 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 1377 2: 1377 3: 1375 4: 1377 
           5: 1377 6: 1377 7: 1377 8: 1378 9: 1376 10: 1377 11: 1375 12: 1375 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: Sapphire Limited 
           driver: amdgpu v: kernel bus ID: 1e:00.0 chip ID: 1002:687f 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu FAILED: ati unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") s-diag: 1245mm (49") 
           Monitor-1: DisplayPort-2 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 96 size: 510x290mm (20.1x11.4") diag: 587mm (23.1") 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.37.0 5.7.15-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.5 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel 
           v: kernel bus ID: 1e:00.1 chip ID: 1002:aaf8 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 20:00.3 chip ID: 1022:1457 
           Device-3: C-Media Anua Mic CM 900 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 
           chip ID: 0d8c:0134 
           Sound Server: ALSA v: k5.7.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 
           v: kernel port: f000 bus ID: 19:00.0 chip ID: 10ec:8168 
           IF: enp25s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 3.76 TiB used: 1.17 TiB (31.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC45 scheme: GPT 
           ID-2: /dev/sdb vendor: Intenso model: SSD 128GB size: 119.24 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 0A scheme: GPT 
           ID-3: /dev/sdc vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 scheme: GPT 
           ID-4: /dev/sdd vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
Partition: ID-1: / raw size: 38.19 GiB size: 37.34 GiB (97.77%) used: 8.26 GiB (22.1%) fs: ext4 dev: /dev/sdb3 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 2.93 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 41.5 C mobo: N/A gpu: amdgpu temp: 44 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1329 
Info:      Processes: 298 Uptime: 1h 20m Memory: 15.65 GiB used: 2.24 GiB (14.3%) Init: systemd v: 245 Compilers: 
           gcc: 10.1.0 Packages: pacman: 1184 lib: 318 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
           inxi: 3.1.05 

Please don’t change permissions or owner on system files and folders.

Linux is not Windows and doing so can cause big problems which can only be solved by reinstalling the system.

Create a mount unit - then enable and start it.

If a new partition is formatted using a Linux filesystem it is safe to change owner and permissions on the partition’s mountpoint e.g. /data/games

sudo ugo+rw /data/games

Ok thank you. I didn’t do that in my previous installations but had the same issue.
edit: I will try what you suggested.

Try to disable fastboot in win

Hello. Do you mean fast startup? I already disabled that.

Thank you very much for your very comprehensible guide. I did everything as described. But I am not sure how I should go on with changing the owner and permissions on the partitions mountpoint.
edit: I forgot to mention that the drives are still read only even though I wrote rw in the options. But that will probably be solved when I know how I should change the owner and permissions.

edit2: I think I did it! I have no Idea if it should be done like that, but after doing what linux-aarhus wrote, I used sudo chmod 777 directory to get the permissions to write.

Thank you so much!

Do not ever 777 anything. That’s a terrible habit. I haven’t used that command in years.

I can also write in /home/user/ but nowhere else.

Yeah, that nowhere else is what we call root and if you started writing things around you would have to reinstall every week, lol.

The best tool to manage NTFS partitions is gnome-disks utility. Just use that and manually set mount options rather than auto. Also set it to automount at boot.
Mount them to /run/media/USERNAME/folder
Why? Because USBs show up there as well so you can have a single bookmark for all.

I am sorry to say - bad idea.

Because the /run tree is a volatile structure created at runtime. Creating mount points in that tree will pose issues at boot time when the mounts are defined in fstab (Gnome disks creates fstab entries).

1 Like

Thank you very much, I will be careful with root.

Thank you! ugo+rw works flawlessly. Without your help I would have given up, but now I’m excited to see what Manjaro has to offer! :smiley:

Then I should just symlink there? Is that OK?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.