How do I downgrade gtk3 and remove tracker3 to get Manager Accounting working?

Hi there,

I use accounting program manager.io, which is being shipped as Appimage (in Aur repos and original website). After last Manjaro update, I run the program, but unable to open any datafiles and this due to that problem:
Appimage does not work, crashes - Manager Forum

now there is a solution provided her
https://bugs.archlinux.org/task/72300?project=1&string=gtk3

it says to downgrade and remove tracker3. I cant downgrade, I don’t keep old versions in cache and I don’t understand how to remove tracker3 from GTK3.

Please, can anyone advise me how to properly do these things or maybe there is another solution to that?
Thanks
Saulius

Downgrading packages, especially ones as important as gtk3 is neither recommended nor supported. It will leave you in a partial upgrade state which can and will cause breakage.

Building gtk3 yourself and using the tracker3=false build flag may be a temporary solution for now.

Ok, I can try.
Can you recommend any tutorial on how to do this properly on manjaro? I know very basic - make && install, but that’s it

Thank you.
S

Install prerequisites:

sudo pacman -Syu --needed base-devel git yay

Download the PKGBUILD from ABS and change to the working directory:

yay -G gtk3 && cd gtk3/trunk

EDIT: updated folder path

Now open the PKGBUILD in your favorite text editor either via terminal (i.e., vim, nano, micro) or file manager. Your profile says you’re using KDE, so maybe open it in kate:

kate PKGBUILD
  1. Remove tracker3 from the depends() array on line 16.
  2. Change the build flag from tracker3=true to tracker3=false on line 41
  3. Save the changes to the file
  4. Build the package and install it:
    makepkg -srcif
    

Since you’re now temporarily using a modified version of gtk3, you don’t want a package update to overwrite your changes. In Add/Remove Software Preferences under Advanced, click the + button under Ignored Upgrades, type gtk3, select it and click the Choose button.

From now on, gtk3 won’t be updated automatically. However, when there’s an update available, you’ll be notified. You can ignore that and proceed with updating all your other packages as usual.

When the issue is fixed, you can remove gtk3 from the Ignored Upgrades list and allow it to be updated.

1 Like

thank you.
I’ll give a try and will let you know of the result.

S

Hi there, I’m having the same problem as the OP.

I have tried your recommended solution but ran into a slight hitch. After downloading from the ABS, I found that the PKGBUILD file doesn’t exist in the ~/gtk3 directory. Instead there are two copies of it, in the following directories:

~/gtk3/repos/extra-x86_64
~/gtk3/trunk

I therefore updated both copies of the PKGBUILD file as per your instructions, but when I tried to make the package I got the following error message:

==> ERROR: PKGBUILD does not exist.

I imagine this is because it’s looking for the file in the ~/gtk3 directory.

Can you please suggest how to get around this problem?

Thanks very much for your help.

You run the makepkg command in the same folder as the PKGBUILD file.

I forgot Yay does that now. I’ve edited my post above. For some reason it’s doing a full checkout instead of an export.

Thanks very much for that, it all seems to work well. It took quite a long time to do the update, about 10-15 mins or so, lots of compiling, but it’s all good.

I know this might be a bit ambitious because really I’m still learning, but I was originally trying to get Manager working by manually installing the latest package via the AUR rather that using the AppImage file. I know it’s more complicated that way but I looked at it as kind of a learning experience.

Unfortunately the last supported version of Manager on the AUR was 20.9.63, which stopped working since a recent large update of Manjaro. So I downloaded that AUR git package and updated the PKGBUILD and .SRCINFO files to the new pkgver I wanted (from 20.9.63 to 21.10.13) and changed “Manager.zip” to “Manager-Linux-x64.zip” to suit the new distribution changes. I also changed “ManagerDesktop.exe” to “ManagerDesktop” in /usr/bin/manager-accounting to suit new native executable.

Everything seemed to install OK but the program doesn’t run, just nothing happens, with no journal output. I left a comment in the AUR about this for help but no one has replied.

I’m not sure if this comes under your area of expertise as it’s more an Arch issue, but if so would you have any ideas as to why it wouldn’t be working?

Also do you know whether the new Manager Accounting distribution still requires mono? I tried /usr/bin/manager-accounting with and without “exec /usr/bin/mono” in the launcher but I got the same result both ways. Thanks!

It does not. I just did a little testing with 21.10.25 and discovered it requires .NET Core App Runtime 5.0.10, but we currently have 5.0.8 in the reops. The Arch community package (dotnet-runtime) has been flagged out of date since August. Apparently something that depends on it isn’t compatible with anything newer at the moment.

Error:
  An assembly specified in the application dependencies manifest (ManagerDesktop.deps.json) was not found:
    package: 'runtimepack.Microsoft.NETCore.App.Runtime.linux-x64', version: '5.0.10'
    path: 'libSystem.IO.Compression.Native.a'

Unfortunately we’ve reached quite the impasse here. This is proprietary software, so I’m going to have to refer you back to Manager.io support. Perhaps make a post on their forum as well.

No worries, thanks so much for your help. At least I got Manager up and running again.

Cheers.