How could I speed up my boot?

Hi everyone, I apologise in advance for any mistakes, but I have recently installed Manjaro and being the first time for me on Linux, I am trying to learn.
My problem right now is the boot which is very slow, I’ll leave you the result here.


Startup finished in 25.920s (firmware) + 6.917s (loader) + 2.973s (kernel) + 37.025s (userspace) = 1min 12.836s reached after 37.025s in userspace.

systemd-analyze blame

2.722s plymouth-quit-wait.service
 5.839s dev-sdb4.device
 5.363s systemd-journal-flush.service
 2.353s ModemManager.service
 2.304s dev-loop2.device
 2.300s plymouth-start.service
 2.299s dev-loop5.device
 1.962s apparmor.service
 1.859s dev-loop3.device
 1.833s dev-loop4.device
 1.815s dev-loop1.device
 1.763s upower.service
 1.494s cups.service
 1.424s systemd-fsck@dev-disk-by\x2duuid-F259\x2d76C6.service
 1.359s colord.service
 1.343s ufw.service
 1.231s lvm2-monitor.service
 1.108s udisks2.service
 1.077s NetworkManager.service
 1.027s dev-loop0.device
  919ms systemd-tmpfiles-setup-dev.service
  892ms systemd-vconsole-setup.service
  881ms polkit.service

How can I improve it?
I premise that I have 16gb of ram and an Intel® Core™ i5-4460 processor and AMD Radeon™ R9 380 Series gpu, I also wanted to ask if anyone has any tricks to speed up Manjaro in general.
Thanks in advance.

Please post your system information.

Hello @lorenzo :wink:

  1. Don’t use snaps. That will eliminate all dev-loop devices.
  1. If you don’t have lvm partitions, you can mask it:
sudo systemctl disable --now lvm2-monitor.service
sudo systemctl mask lvm2-monitor.service
[quote="lorenzo, post:1, topic:139485"] `2.722s plymouth-quit-wait.service` [/quote]
  1. Remove the boot splash screen plymouth.

Here is also a good summary: Improving performance - ArchWiki


I could be wrong, but I believe that Plymouth doesn’t actually affect boot speeds, it’s just misleading because it waits for everything else to be done?

Confirmed. You are right. Thanks for the correction.

start by running systemd-analyze critical-chain to see if something is blocking unreasonably

systemd-analyze blame seems to be misleading for most people. Stop recommending it!

Thank you very much for the fast feedback, btw I have done it but my boot seems quite the same as before, I navigated around the forum but I was nor able to find any solutions…

What’s going on with your BIOS, it takes almost 30 seconds before it starts loading GRUB.

GRUB itself takes 5+ seconds to then load your kernel. Reduce the timeout to 1 second in its configuration file /etc/default/grub (and issue a sudo update-grub command then) so it doesn’t wait that you validate the kernel or that the timeout is reached.

SystemD critical chain would be also good to have.

i have the second most modern chipset from msi amd and it takes 17 seconds in bios. Many desktop computers just have bad bios.

Sorry for the bad command. I’ll leave you the new output:

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @40.073s
└─ @40.073s
  └─plymouth-quit-wait.service @16.887s +23.185s
    └─systemd-user-sessions.service @16.751s +115ms
      └─ @17.626s

Set to 1, reboot and this is the output of systemd-analyze critical-chain

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @43.468s
└─ @43.468s
  └─plymouth-quit-wait.service @17.882s +25.585s
    └─systemd-user-sessions.service @17.789s +65ms
      └─ @19.194s

It looks really weird as plymouth should not be in critical chain? Never seen an output like that so i don’t know if it is normal.

That doesn’t seem to be a proper complete output. Also give both output of the systemd commands time you change something.

then how could I resolve this?

I’ll post a new output of systemd-analyze critical-chain:

I upload also these other two commands:

I don’t know what to do… My boot is really slow…

Do you use many snap programs? dev-loopX.device could be indicating this, and i seem to remember that disabling snap fixed someone else’s long boot time.

If you want to try something else, maybe just disable plymouth. It should not have an effect, but some have said it worked for them, maybe bug or maybe something else.

“I don’t know what to do… My boot is really slow…” Mine is slow too, but I turn it on in the morning, then go make coffee and assorted morning chores. May not be what you want to hear, but it works. “A watched pot never boils”

How is you BIOS initialization almost 50 seconds now? Are you going into the BIOS just to increase that everytime you post a new command output?

I also don’t understand why your critical chain starts at 20+ seconds. Mine starts at basically 0.

Also, if you have a HARD DRIVE there is nothing to do at some point, this is SLOW.

Is sdb a SSD or HDD? Looks like a HDD. Naturally it is slower.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.