How can i Run a trainer.exe on manjaro with wine ? thank you

How can I Run a trainer.exe on manjaro with wine ? Thank you

The Name of the Trainer for my game is

GreedFall v1.0-v20191219 Plus 16 Trainer.exe

wine GreedFall v1.0-v20191002 Plus 16 Trainer.exe                        
0024:err:module:process_init L"C:\\windows\\system32\\GreedFall.exe" not found
~ >>>

Most of the gaming tools won’t work on Linux. If you are knowledgeable enough, some of them may launch, but only fraction of them will work correctly, because those tools expect different paths and environment, so they are lost with emulated space.

This seems to be the case. This trainer expects to see “C:\windows\system32\GreedFall.exe” but it doesn’t exist in your wine prefix, does it? So you would have to first install the game through wine, make it work correctly there (this will require some fiddling) and then try to use trainer in the same prefix. It will still may fail to launch or work.

P.S. This is a super weird location for the game’s exe…

2 Likes

The game is working fine and I do have a launch option

So what should I do move it to the same Directory ?

Thank u

I am opening the terminal in same directory

chmod: cannot access 'GreedFall': No such file or directory
chmod: cannot access 'v1.0-v20191002': No such file or directory
chmod: cannot access 'Plus': No such file or directory
chmod: cannot access '16': No such file or directory
chmod: cannot access 'Trainer.exe': No such file or directory
~ >>>
~ >>> inxi -Fxxx0                                                              
System:
  Host: tempo-tempo Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Micro-Star model: MPG Z490 GAMING EDGE WIFI (MS-7C79) 
  v: 1.0 serial: <superuser/root required> UEFI: American Megatrends v: 1.10 
  date: 05/21/2020 
CPU:
  Topology: 8-Core model: Intel Core i7-10700K bits: 64 type: MT MCP 
  arch: N/A L2 cache: 16.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 121639 
  Speed: 1800 MHz min/max: 800/5100 MHz Core speeds (MHz): 1: 1800 2: 1800 
  3: 1800 4: 1801 5: 1801 6: 1800 7: 1801 8: 1801 9: 1800 10: 1800 11: 1800 
  12: 1800 13: 1800 14: 1800 15: 1800 16: 1801 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 01:00.0 
  chip ID: 1002:67df 
  Display: x11 server: X.org 1.20.9 compositor: gnome-shell 
  driver: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.38.0 
  5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:06c8 
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aaf0 
  Device-3: Microsoft LifeCam HD-3000 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-3:3 chip ID: 045e:0810 
  Device-4: Corsair CORSAIR VOID ELITE Wireless Gaming Dongle type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-7:5 chip ID: 1b1c:0a55 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9462/9560 driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:06f0 
  IF: wlo1 state: up mac: 54:8d:5a:cf:90:6d 
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: N/A 
  port: 3000 bus ID: 04:00.0 chip ID: 10ec:8125 
Drives:
  Local Storage: total: 2.96 TiB used: 75.01 GiB (2.5%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS250G2B0C-00PXH0 
  size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: 202224805724 
  rev: 211070WD scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 250GB 
  size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 serial: S4EUNJ0N400962W 
  rev: 2B2QEXM7 scheme: GPT 
  ID-3: /dev/sda vendor: Toshiba model: HDWD130 size: 2.73 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: 403TJDBAS rev: ACF0 scheme: GPT 
Partition:
  ID-1: / size: 227.94 GiB used: 75.01 GiB (32.9%) fs: ext4 dev: /dev/dm-0 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 35 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1214 
Info:
  Processes: 409 Uptime: 2h 06m Memory: 31.28 GiB used: 3.16 GiB (10.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1432 pacman: 1424 
  snap: 8 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05 
~ >>>        

posted this in 2 different places

You can’t. Directories under Linux and Windows are different, even if you install Windows only game, it will probably be through Lutris or Steam that place it deep within special app and then Proton folders.

It’s like you would try to start a fire. You have wood and paper ready in one city and fire in another city… and you wonder, why the wood/paper can’t find itself…

There are ways to install game and the utility in the same place but this requires some Proton fiddling knowledge, one that I don’t have. Probably you will have to use Protontricks (which you can install from AUR) utility to do that, but it’s still won’t be a guarantee that the trainer will work.

Once Protontricks is installed, you launch it in terminal with command:

protontricks --gui

This will open a window:

Screenshot_20201012_232354

Then follow the UI.

P.S. Thanks for the inxi info. It looks like you have only one GPU which is AMD and this simplifies things.

1 Like

You can possibly use the trainer on Linux. I’ve used multiple trainers and save editors on Linux before. But luckily for my programs, most of them let me find and choose where specific directories are within the program itself.

Since it sounds like your program doesn’t do that, you’ll need to find where your game is installed. Since the game is a Windows game, most likely whatever directory it’s in will have a Windows layout.

You need to set a wine prefix to set it to use that directory, as if the program is working in that directory. It’s easier via Lutris imo. That is what I used for some tools.

Unfortunately you’ll have to look up how to set that all up yourself since I don’t have the program in front of me, and don’t have access for a long while.

Easiest way is to install a game via lutris, see how that is set up, and follow the same kind of setup to setup for your trainer.exe

im on the archlinux repository for winetricks
but dont see how to install

how to install?

I guess your solution would be to make a batch script to start the game and the trainer under the same Wine virtual environment. I don’t believe just placing the trainer in the game executable (//EDIT: game executable FOLDER) will work, you need to start them both in same environment, not simply same ‘prefix’.

@realmain

Many thanks for ue help
the game is installed through lutris and it runs just fine

is there a way to install ```
protontricks through command line ?

yay protontricks

Then follow the questions (choose the number, most likely it will be 1, and so on).

If you don’t have yay, install it first:

sudo pacman -S yay

It all can be done in the pamac, so with graphical interface.

1 Like

yay protontrcks
no packages match search

You should be able to literally copy the same exact setup for that game in Lutris, but for the EXE file, select the trainer. That’s what I do for some of my game trainers / save editors.

You were too quick, I had a typo, which I already corrected. Copy the command again.

Ah, if the game is installed with Lutris, then Protontricks probably won’t help as it looks game in Steam library.

what should i choose here please

~ >>> yay protontricks
2 aur/protontricks-git 1.4-1 (+15 0.72)
A simple wrapper that does winetricks things for Proton enabled games. (Git Version)
1 aur/protontricks 1.4.2-1 (+46 3.46)
A simple wrapper that does winetricks things for Proton enabled games.
==> Packages to install (eg: 1 2 3, 1-3 or ^4)

I already said. 1
Learn to read it, you have two choices:

2 aur/protontricks-git 1.4-1 (+15 0.72)
1 aur/protontricks 1.4.2-1 (+46 3.46)

In your case protontricks will be better (but the second version would work as well).

Since GUI works only for Steam, find if in terminal it can be used with Lutris.

EDIT: I found this info:

If you have a different Steam directory, you can export $STEAM_DIR to the directory where Steam is.

If you’d like to use a local version of Winetricks, you can set $WINETRICKS to the location of your local winetricks installation.

Frankly… I don’t understand it. :frowning: How can I export it? Will it work with non-Steam game thou even if you put a path to non-Steam game directory?

@michaldybczak can u please look did i do it right ?

new file mode 100644
index 0000000..2a75298
--- /dev/null
+++ /home/tempo/.cache/yay/python-vdf/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Abhishek Mudgal
+# Contributor: Ivan Semkin (ivan at semkin dot ru)
+
+_pkgname=vdf
+pkgname=(python-vdf)
+pkgver=3.3
+pkgrel=1
+pkgdesc="Library for working with Valve's VDF text format"
+arch=('any')
+url='https://github.com/ValvePython/vdf'
+license=('MIT')
+depends=(python)
+makedepends=(python-setuptools)
+checkdepends=(python python-nose python-coverage python-mock)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ValvePython/vdf/archive/v$pkgver.tar.gz")
+sha256sums=('554ef526e779f475d686a19d9abd90f3f0325286127f6dc643e7f6ea03490cce')
+
+build() {
+  cd "$_pkgname-$pkgver"
+  python setup.py build
+}
+
+check() {
+  cd "$_pkgname-$pkgver"
+  python setup.py test
+}
+
+package() {
+  cd "$_pkgname-$pkgver"
+  python setup.py install --optimize=1 --root="${pkgdir}/"
+  install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"

Why did you open PKGBUILD? In theory you should review it, but if you don’t understand it, you say No and go further. Don’t agree blindly :stuck_out_tongue:

Just open Pamac, go to settings, enable AUR support, find Protontricks and install it from there. It will be way easier than using command.