How can I make the background of the whisker menu transparent?

I know there is a slider but it only changes the opacity of the sidebar thing and I want the whole background transparent,
can I?
thank you for the help,
have a nice day

In the past it was possible :thinking: Maybe XFCE4 Team has removed it in newer versions?

Its present… I think the problem is that using the available properties option (background opacity):

You only get partial transparency, like this:

There is an (old) example of using compiz:

But otherwise I dont find much …

1 Like

I should better read… i was thinking of the panel :slight_smile:

I would say it might be more the throw than the catch in this case.
But sure. Lets just blame both equally. :slight_smile:

The issue does partially interest me because it seems like it shouldnt be so difficult …
(I dont use XFCE though … so no spelunking from me)

Additionally for the panel. Use a transparent picture:
Here is a transparent.png

Change the style to “background image” and add the picture.

No, you can make it as transparent as you want.
Open panel preferences, click on color…

Click on +

Then move the button from the left slider to the bottom and the button from horizontal slider to the left.

(I would add some pics but somehow links are not allowed. :thinking:)

1 Like

Well using compiz worked to some extend but it affects the whole window(including the icons) and that isn’t what I want(I want the background only)
anyway thank you for the help

Nope, it does change the background of the menu :


and it proves being totally useless !

Here the vanilla background (useful) :

Did you miss the general idea of this topic and all of the previous posts including the one with pictures outlining how your ‘solution’ does not suffice ?

:no_mouth:
I may have partly missed it (even If I don’t get the use case : transparency makes it impossible to use.)
Obviously ~/.config/gtk-3.0/gtk.css #whiskermenu-window settings do not allow opacity or background=none.

Stuff I learned in the process is to relaunch with this :

killall -HUP xfce4-panel

or

xfce4-panel -r

Ah to be fair it looks like the second pic got reduced to the hyperlink only. :woman_shrugging:

Maybe adapting Xfwm Effects could help ?

My wording may have been bad,sorry about that ,when I said side bar I meant the menu your arrow pointed to,
–see second picture
what I want is the white bit(the one with the terminal,firefox and stuff) to be also transparent

EDIT: Here’s a solution that’s suitable for all kinds of backgrounds/wallpapers, not just dark ones.

The steps are as follows:

Composite (in xfwm settings) must be activated and opacity must be lowered to at least 99% within whisker menu > properties for this to work!

Create and edit this .css file from terminal:
nano ~/.config/gtk-3.0/gtk.css

Paste this into it:

#whiskermenu-window {
	background-color: rgba(0,0,0,0.7);
	color: #ccc;
}
#whiskermenu-window button {
	background-color: transparent;
	color: #ccc;
}
#whiskermenu-window button:hover {
	background-color: transparent;
	color: #fff;
}
#whiskermenu-window button:checked {
	background-color: transparent;
	color: #fff;
}
#whiskermenu-window treeview {
	background-color: transparent;
	color: #ccc;
}
#whiskermenu-window treeview:hover {
	background-color: transparent;
	color: #fff;
}

Save the file by pressing:

Strg+O

(Confirm with ENTER), then exit nano:

Strg+X

Finally restart whisker menu:
xfce4-panel -r

Enjoy!


Wallpaper by @Lunix
(The resulting look from the code posted above differs slightly from the whisker menu in the screenshot in order to make it work with brighter backgrounds as well)

3 Likes

You did what I want but it didn’t work for me,when I restart the panel this message gets printed to the terminal:

Gtk-Message: 15:39:10.014: Failed to load module “colorreload-gtk-module”

and the whisker menu stays at the same style as it was before
EDIT:Thank you and everyone who replied.

1 Like

Do you have any custom themes installed/applied?

yes,I have the “zorin-grey-dark” theme
I will try to disable it and see
EDIT:switching to “mutcha sea” makes the app tree semi transparent,not fully

Would you mind switching to any of the matcha dark themes and try again?

they all make the app tree semi transparent(not fully)