How can I make the background of the whisker menu transparent?

Is there any error message now after restarting whisker?

Yes,this
Gtk-Message: 16:33:39.633: Failed to load module "colorreload-gtk-module"

Beauty doesn’t have to be useful. :wink: :stuck_out_tongue_winking_eye:

1 Like

When playing around with the .css file I mostly got errors when there were any syntax errors.

Could you delete the .css file and create a new one, then paste the above content as is? You can use a file manager for that instead of nano.

ok will do it and update

:+1: I assume that you have both composite enabled and lowered opacity within whisker settings…

1 Like

After tinkering around doing what you said + removing some things unnecessary things I put off of the gtk-3.0 folder
I no longer get an error when restarting the panel,but still I get semi transparent menu

EDIT: What is the output of
nano ~/.config/xfce4/panel/whiskermenu-8.rc

The file doesn’t exist so it says new file

That’s strange, since you applied changes to the whisker menu settings…
Can you check with thunar? Maybe yours is called whiskermenu-20.rc or something…

EDIT: If there is another whiskermenu rc file with a number higher than 8, your whisker menu may look funny now :innocent: If that’s the case, then just delete the newly created file (needless to say to always make backups before deleting anything)

deleted all of the config files I saw with the term “whiskermenu” in them and restarted the panel,nothing changed as far as I can tell,
anyway thanks for the help

1 Like

Hope that that’s still the case when you log out/in again.

I’m out of ideas at the moment, but you’re welcome :slightly_smiling_face:

EDIT: One last idea is to replace

transparent

with rgb values, e.g.:

rgba(0,0,0,0.1)

and see, if anything changes… :thinking:

nothing changed as far as I can tell,
but never mind the issue don’t waste your time on it,
also thank you for the help,
have a nice day.

1 Like

I’m having an issue where my menu got resized so I removed it from the panel and put it back but I can’t get the background of it transparent.

All the settings are the same but the background stays black.

Only the sides can get transparent using the whisker menu settings gui(as far as I know),
I wanted the inside(where the terminal and stuff are) to be transparent so I asked here,
I didn’t get something that worked for me ,try this maybe it will work for you

To the suggestion on such discussion, try to also add

#whiskermenu-window entry { 
 	background: transparent; 
} 

To ~/.config/gtk-3.0/gtk.css

Sorry, but did you ever find a solution to this problem? As you may imagine I have the same problem, only half the whisker’s menu is transparent.
Thanks and have a good day.

I didn’t but people suggested solutions here so try them though I don’t know if they are safe

Note:I do NOT guarantee that any software, themes or anything I mention here is safe to use in any way, nor do I guarantee that it won’t harm your software(Operating System… etc) or hardware or somehow spy on you.
I discovered that the Blackbird and the Matcha theme with it’s variants allow you to fully or partially accomplish the goal, I say fully or partially because I haven’t done much testing.
just use the default transparency slider on the whisker menu(you should be using one of the themes I mentioned or a theme that accomplishes the goal)