How can i change the scaling KDE Plasma. Everything looks too big after changing my laptop's display

Installed the lastest version of manjaro KDE Plasma after changing my laptop’s display. Everything looks too big and i cant change my resolution from 1366 X 768 (683:384).
Here’s my display specs

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
eDP connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1366x768      59.99*+  40.00  
   1280x720      59.99  
   1024x768      59.99  
   800x600       59.99  
   640x480       59.99  
HDMI-A-0 disconnected (normal left inverted right x axis y axis)

Everything looks too big on my screen, in windows(with same display) i usually keep my scaling to 125% and i would like it to be the same in here.

If this global scale feature would go less than 100%, i think that would’ve fixed my problem.
Let me know if you need more info.

if the picture is accurate, than everything is looking good…
go to system settings/fonts and check ‘force font dpi’ and set it to 80 for example, click apply, and see if that helped

no this doesnt help, it only changes the font size i think.
The picture accurate.
Look at this image
see the firefox’s title bar and my task bar and the whole screen looks so big, i just want all this to get smaller a bit. In Windows OS i used to changed the scaling and in the previous manjaro version i was able to lower the scaling but now i cant. idk if its a because of the latest version or my new display.

if your previous manjaro was also kde, you couldnt go below 100 in global scale from system settings…
in firefox go to settings/more tools/customize toolbar and uncheck ‘title bar’ click done; also change the density to normal;
right click on the panel, select enter edit mode and change panel height

Please edit your topic title to make it clear and concise as well as remove your cry for help. The descripiton of the issue should be in your post, not the title.

Please see:

Your post will be hidden until this is addressed.

Thanks, I have fixed the title.

1 Like

Thanks for the tips but i still have to use my firefox and other apps in 80% zoomed out.
These fixes are limited to one or two applications. But all my application looks bigger or upscaled. Isnt there any way to just make my screen zoomed out a little bit?

try this command:
xrandr --output eDP --scale 1.2x1.2

I tried this and it fixed my issue but my task bar seems to be misplaced and everything resets after the restart.

and if you try this:
xrandr --output eDP --scale 1.5x1.5
did this setting also misplace your panel?

Yes this one too.
but i tried 1.1x1.1 and this one completely fixes my issue.

xrandr --output eDP --scale 1.1x1.1

Can you tell me how i can keep this setting as default so that i dont have to configure my screen everytime i restart my machine?

Try this:

In the /etc/environment file put this line:


to make it permanent you need to use a script … install: arandr, and try with it

okay, this works.

Woah!! Thank you so much. This worked like a charm.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.