"Hotspot Login" pops up in Network Login app when waking from sleep

Just came back from lunch, woke up my manjaro Gnome desktop and now get a full screen ‘Hotspot Login’ web page at http://nmcheck.gnome.org opening in the app ‘Network Login’, at every network connection.

I understand this is how the network manager checks for connection to the internet. And the network connection icon also has a question mark in the system menu (top right of screen), indicating a network problem - but everything is working perfectly. Only the connection check seems to be broken.

Wired connection to the router, no wifi involved.

About to check my manjaro Laptop to see if it has the same problem.
All I changed today is to install the ‘Fractal’ matrix client, wonder if that’s caused this issue…also installed an OpenWRT update on the router yesterday evening…


Checked my laptop, has exactly the same issue.

I’m guessing this is a problem on Gnome.org.

It does not seem to be Gnome specific: I am having a similar, probably related problem here. All over sudden - without having updates or anything - a one week fresh Manjaro KDE installation displays the notification: “This network requires login” and the W-Lan symbols turns red.

This is however, my private network at home and also, the internet access is working fine. The error is obviously a false one. But where does this come from?

1 Like

Apparently its arch related.

Arch changes the network check url and its 404 right now:


See this short thread on twitter:


Changing the domain in /etc/NetworkManager/conf.d/20-connectivity.conf to the GNOME networkcheck domain indeed fixed it for me. Thanks for the heads up.


Luckily the only program that seems to be having an issue with this on my side is Spotify. All of the others still properly connect to the internet.

As cluuub said, editing the /etc/NetworkManager/conf.d/20-connectivity.conf solves this issue. As this file was empty/not existing, here’s what I put into it:


You can put other or your own service there instead of gnome’s. Here’s more information on how to do this: networking - Set URL for captive portal detection - Ask Ubuntu

other info here: NetworkManager - ArchWiki


The issue seems to have gone away for me even though https://www.archlinux.org/check_network_status.txt is still a 404.

I did not find any “20-connectivity.conf” under /etc/NetworkManager/conf.d/, it was empty.

However, I found one under /usr/lib/NetworkManager/conf.d/20-connectivity.conf, and it referred to uri = http://www.archlinux.org/check_network_status.txt.

Can you change that file instead, because there are other files that belong to NetworkManager here under /etc/NetworkManager/?

Found this information.

“If a default NetworkManager.conf is provided by your distribution’s packages, you should
not modify it, since your changes may get overwritten by package updates. Instead, you can
add additional .conf files to the /etc/NetworkManager/conf.d directory. These will be read
in order, with later files overriding earlier ones. Packages might install further
configuration snippets to /usr/lib/NetworkManager/conf.d. This directory is parsed first,
even before NetworkManager.conf.

I’m new to Linux and Manjaro, coming from Windows 7.
And sorry for stupid questions, I also suffer from a severe fatigue syndrome, and can no longer read manuals and long instructions.

Funny. I just block those uris :

1 Like

This means your .conf.d files (and the original .conf) will be read after the files in /usr/lib, meaning applied last - they have precedence.

So, if you are somehow missing the .conf.d file you can create it.

sudoedit /etc/NetworkManager/conf.d/20-connectivity.conf


sudo nano /etc/NetworkManager/conf.d/20-connectivity.conf

or any other way … and put the desired lines in there.

Another example one-liner might be

printf "[connectivity]\nuri=http://nmcheck.gnome.org/check_network_status.txt" | sudo tee /etc/NetworkManager/conf.d/20-connectivity.conf
  1. Open as Administrator in Nautilus


  1. Right click
    New Document > Empty File

  2. Open it

  3. copy and paste this in “Empty File”


  1. Save

  2. Change name “Empty File” to “20-connectivity.conf”

  3. Reboot


Thanks @IceCube, but don’t have Nautilus in gnome, are using Double Commander and Dolphin in Manjaro.
But Nautilus and Dolphin seems to be similar programs.

The issue is gone without manually fixing.

Confirmed. Like like the German Regime does - wait, until its solved…

This issue is back again for me today. Anyone else experiencing it?

Looks like https://archlinux.org/ is down for maintenance so that may be what’s causing it.

Yes. I experienced it today. I have never scene this before. :thinking:

Good to know that there is an easy fix, if it gets annoying.