Hosting hotspot not working after system upgrade

I’m currently facing a problem where when starting my hotspot on manjaro it will show up on other devices, but I’m unable to join the network. This has occured after updating the system about a month or two ago. I’ve tried restarting the wifi adapter, deleting and creating a new hotspot and even rolling back to a previous version of manjaro via timeshift and updating the system from scratch. When I rolled back to the previous version from about 3 months ago the hotspot worked perfectly fine, but once i updated I was again unable to join the hotspot with any of my devices.
At this point I really don’t know what to do and I would really appreciate any kind of help. Thanks.


Tried this?

Hey there,

I was facing the same problem (and now facing it again), what I found was that it only didn’t work for WPA2-Networks and iPhones connecting to the Network. (Now my iPhone doesn’t even want to connect to the Network even if it is open.) So try out making the Network open, with no encryption and see if that works. (I believe this is about a recent update of wpa_supplicant)