High cpu usage while browsing!

I’m coming from windows, one thing I did notice: while I browse youtube using brave/firefox or any browser on windows 10 my average cpu usage was 10-30% but same browsers on manjaro xfce shows 30-80% even sometimes its 100%
I’ve tried with hardware acceleration turn on/off on browser and my startup services was minimal but no improvement!
most people say’s linux use less resouse than windows but in my case It reversed!
I’ve tried many other distro’s such as endeavor, zorin, mint, lite and more… same everywhere!
is there any way to reduce the cpu use? or is it normal on linux?

my pc config:
amd athlon 3000G
8gb ddr ram
256gb ssd


no it’s not normal. Normally Linux and also the browser’s taking less ram. (I tried many Distros)

Did you try other images from ohter repositories, like Flatpak, the arch version and the community version?
(enable the aur and Flatpak in pamac)

Normaly Flatpak takes more ram.

best regards

1 Like

Due to some rather annoying legal issues, a lot of Linux distros have stopped including video hardware acceleration by default for certain codecs. Because of this, your CPU is forced to pick up the slack when playing video.

However, there is a bit of a legal loophole to get drivers with the necessary codecs. I am unable to find a very good installation guide, but there is an alright one on this site created by the Manjaro team. After following the instructions (no need to click any of the links), run sudo pacman -Syyu and then reboot.

Each distro has its own workaround for the loophole, so this will only work on Manjaro.

Are the browsers stock? Or have you added addons?

there are a lot of files! which one to use?

I use official browsers from firefox, brave and only google translate extension was installed

Just follow the instructions at the top of the page, no need to click the links

ok… thank u

Welcome to the forum! :wave:

While @fasto’s advice is sound if you have an AMD GPU, you never did tell us what GPU you’re using.

Please see post your system inforatation as outlined here: [HowTo] Find system information

Global information

[muhammadabir@muhammadabir-pc ~]$ inxi -v7azy
  Kernel: 5.10.174-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=5756bca5-337d-4836-9a98-a7d5ab6fa86b rw quiet splash
    resume=UUID=334f86d2-da70-4a2d-b500-5269e3967068 udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: A320M-A PRO (MS-7C51) v: 1.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1.30
    date: 11/08/2019
  Message: No system battery data found. Is one present?
  RAM: total: 5.8 GiB used: 1.23 GiB (21.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64 type: MT MCP
    arch: Zen/Zen+ note: check gen: 1 level: v3 note: check built: 2019
    process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
    microcode: 0x8108109
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2082 high: 2658 min/max: N/A cores: 1: 2658 2: 1387
    3: 2658 4: 1627 bogomips: 28012
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rdrand rdseed rdtscp rep_good sep sev
    sev_es sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a
    ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 29:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 35.0 C
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model-id: IPS 0x2022 built: 2022
    res: 1920x1080 hz: 60 dpi: 3048 gamma: 1.2 size: 16x9mm (0.63x0.35")
    diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 29:00.1
    chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 29:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.10.174-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 223.57 GiB used: 6.97 GiB (3.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SU650 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 028a scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 214.77 GiB size: 210.34 GiB (97.94%) used: 6.97 GiB (3.3%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 5756bca5-337d-4836-9a98-a7d5ab6fa86b
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: 334f86d2-da70-4a2d-b500-5269e3967068
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 3 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-4:2 info: CASUE USB KB type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 2a7a:938f class-ID: 0300
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 5-1:2 info: Logitech Mouse type: Mouse driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 100mA chip-ID: 046d:c077
    class-ID: 0301
  Hub-6: 6-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 35.6 C mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (RPM): N/A
  Processes: 226 Uptime: 2m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 942 libs: 293 tools: pamac Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25

At least what I can say is that firefox is running at about 10-20% CPU load constantly. Sometimes for a second it goes to ~50%, but everything is running at 900Mhz. So in fact, it just shows that it at 20% of 900Mhz (~180Mhz). Don’t get the idea that 20% means that it is 20% of the base frequency, so for me 3Ghz, and it can boost up to 4.1Ghz.

I don’t know how you can determine this on Windows. Maybe it runs all the time at the base frequency? :man_shrugging:

How did you enable hardware acceleration? I just followed this: Firefox - ArchWiki and it worked.

Your AMD GPU video hardware acceleration is disabled by default.

Try to install nonfree-mesa

# locally trust the ci key
sudo pacman-key --recv-keys B728DB23B92CB01B && \
  sudo pacman-key --lsign-key B728DB23B92CB01B

## add the repo configuration:
sudo sh -c "curl -s https://nonfree.eu/$(pacman-mirrors -G)/ > /etc/pacman.d/mesa-nonfree.pre.repo.conf"

## include the repo configuration:
sudo sed -i '/^\[core\]/i \Include = /etc/pacman.d/mesa-nonfree.pre.repo.conf\n' /etc/pacman.conf

Well… sort of.

Acceleration using free codecs such as VP9 was never lost.

The non-free packages just repatch for those codecs like h264.

On the other hand - OP probably never enabled the relevant configurations/flags to use hw-accel in any case.

I used windows 10 default task manager :neutral_face:

My guess is that old AMD Vega would not have VP9 hardware acceleration, but use H264 or H265

Youtube still supports H264 (avc1), see here:

$ yt-dlp --list-formats CKp5GXe1sLs

133 mp4   426x240     30    │    4.05MiB  25k dash  │ avc1.4d4015  25k video only          240p, mp4_dash
242 webm  426x240     30    │    6.12MiB  37k dash  │ vp9          37k video only          240p, webm_dash
134 mp4   640x360     30    │    6.63MiB  40k dash  │ avc1.4d401e  40k video only          360p, mp4_dash
18  mp4   640x360     30  2 │ ~ 28.56MiB 169k https │ avc1.42001E 169k mp4a.40.2    0k 44k 360p
243 webm  640x360     30    │   12.34MiB  75k dash  │ vp9          75k video only          360p, webm_dash
135 mp4   854x480     30    │    9.51MiB  58k dash  │ avc1.4d401f  58k video only          480p, mp4_dash
244 webm  854x480     30    │   18.55MiB 113k dash  │ vp9         113k video only          480p, webm_dash
22  mp4   1280x720    30  2 │ ~ 48.25MiB 286k https │ avc1.64001F 286k mp4a.40.2    0k 44k 720p
136 mp4   1280x720    30    │   25.88MiB 157k dash  │ avc1.4d401f 157k video only          720p, mp4_dash
247 webm  1280x720    30    │   33.70MiB 205k dash  │ vp9         205k video only          720p, webm_dash
298 mp4   1280x720    60    │   41.41MiB 251k dash  │ avc1.4d4020 251k video only          720p60, mp4_dash
302 webm  1280x720    60    │   46.63MiB 283k dash  │ vp9         283k video only          720p60, webm_dash
299 mp4   1920x1080   60    │   83.72MiB 508k dash  │ avc1.64002a 508k video only          1080p60, mp4_dash
303 webm  1920x1080   60    │  101.60MiB 617k dash  │ vp9         617k video only          1080p60, webm_dash


Your iGPU should support VP9. see: https://en.wikichip.org/wiki/amd/athlon/3000g → Graphics → Hardware Accelerated Video Capabilities