Help setup a Brother printer in Arm

I found these steps below on how to setup my Brother MFC L2700DW printer from. However I am getting stuck at locating the lib32-glic in the aur repos.

sudo pacman -S yay
Then as user, install the printer driver from the AUR
$ sudo pacman -S lib32-glic to install a dependency
$ yay -S brother-mfc-l2700dw

Printer driver should be installed.
You may need to do the following: if these are already done, reissuing the commands is safe
$ sudo pacman -S cups cups-pdf
$ sudo systemctl enable org.cups.cupsd.service
$ sudo systemctl start org.cups.cupsd.service

In FIrefox or other browser, enter the URL of localhost:631
This should bring up the cups page
Install your printer. I don’t know your Linux skill level, if you have never done this before, come back for help. The yay installed driver should appear as
Brother MFC-L2700DW for CUPS (en)

If this printer is on a LAN network, do the following to enable the scanner
$ pacman -Q sane ( to see if sane is installed. If not install it)
$ yay brscan4
$ sudo brsaneconfig4 -a name=“Brother” model=“MFC-L2700DW” ip=“your printer’s IP”

Done

Any lib32- packages are meant is multilib packages for x86_64 operating systems.
It won’t work on ARM

That printer driver package in the AUR is also using i386 sources, which will not work on ARM either.

Ask Brother if they have “aarch64” sources/binaries of that driver.

I will try to contact them in regards to the binaries for aarch64. I did notice that they have drivers for raspbian. Is it possible to depkg the raspbian driver and build it for aarch64?

https://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=mfcl2700dw_us_eu_as

Raspbian drivers are probably armv7h (armhf) based, which won’t work on Manjaro, since we are armv8 (arm64) based.

Maybe some info can be found on the Pine64 forums, for example:
https://forum.pine64.org/showthread.php?tid=9064

I also found this page:
https://www.openprinting.org/printer/Brother/Brother-MFC-L2700DW

Anyway, not sure if usefull, but I post it anyway in case it could be usefull

Thank you. It looks like the folks from pine64 were able to install their printers as driver-less using cups and a package called nss-mnds. I will have to give this a try. Also I will post all the steps taken once I figure it out.

package called nss-mnds
this is so net bios names work, optional, I use ipp://ip-address
driverless/airprint was originally an apple thing, for iphone et all
needs
printer capable of it (drivers in printer rom, most wifi printers are)
a cups capable of it (2.3 or >)
on network, can be done over usb, hard
There are posts in this forum, but the previous incarnation
(pick driverless-generic)

I installed the GUI called printer manager in repo. I got nothing showing up in the settings and it will not detect anything. According to the post on pine64 it is a systemd issue. I don’t understand the statement below how they set up the systemctl.

//
cups-browsed.service
org.cups.cupsd.service
I think it automatically pulls in the 3 others I see
After systemctl is set up, localhost:631 will work.
//

1 Like

Did you enable those 2 services?

Yes, I wrote that, sorry forgot
I keep expecting systemd to be magic, keep getting disappointed
Yes, enable and start

I guess my question is, where do you enable them and what is systemd?

**After doing a google search i found the command to use in terminal:
systemctl enable --now cups-browsed.service
systemctl enable --now org.cups.cupsd.service

After enabling the cups in systemctl and installing the nss-mnds package, printer settings could now detect and locate my printer. However, when I complete the descriptions of my printer and apply, I get a cups server error: server-error-internal-error.
Any ideas what went wrong?

I hope you didn’t pick printer make, printer model,
that won’t work
For airprint, pick driverless-generic as printer
OR, maybe systemctl restart org.cups.cupsd.service
Unfortunatly, the ppd will be a bit feeble
Oh,BTW when cups asks for a login, making assumptions again
You didn’t do it thru cups, did you?
localhost:631 (in browser)
Anyway, login as root, whenever I have logged in as user,
was never able to recover from that error, had to remove/reinstall cups

I had forgotten to change the hosts line on the nsswitch to: hosts: files mdns_minimal dns mdns

/etc/nsswitch.conf

Either way I’m getting the same results. Wdt , when you mention browser, are you referring to the printer settings GUI? By default it connects to /run/cups/cups.sock from there I can select network and then printer. I am able to get all the way to the descriptions of printer page. After I get the cups internal error. Even when I select generic cups-brf, I input my device ipaddress and am able to locate my printer. I select driverless and still comes up with cups internal error.

I tried to connect to localhost:631 and it seems to work as it still can detect my printer. But as soon as I try generic-cups or select brother from network list, I get the cups internal error.
I don’t know which browser you were referring to. Am I suppose to activate cups through Firefox?? When I type in my device ipaddress into http://printeripaddress I don’t see options there for CUPS as it only shows printer stats

:: I reread my first thread, it says to use Firefox and type in address bar: “local host:631” and that will get you to CUPS page. This may be the answer I was looking for

Yes firefox will do as browser or chromium or konqueror or…
Check /var/log/cups/error_log, somewhere is a place to set error level higher
A search give various reasons for this error, I never have had that
Again, when in cups page (localhost:631) when you modify,
it will ask for a login, do as root

I was able to login to the cups localhost:631 in the browser. I can see that my printer is found with a driverless Brother MFC-L2700DW driver found under Printers tab. I am not sure what I’m suppose to configure to make this work. It fails when I try to print a test page… Does anyone know what to do from here? I feel that Im so close… Also when I try to modify printer I do not see the option for driverless-generic.

::I chose another driver that is IPP Everywhere and am able to communicate with printer. When i send it a job like print test page, I get an “out of memory” on printer. Is there a way to clear the printer memory?

is a slight variation on driverless, mainly the ppd
They both have “airprint” type drivers
Maybe turn it off, then on to clear mem?
Often, the printer has an web page, if you go to
printers ip address, in browser, some have few settings,
others have many. Depends on model
Often, you have to set a password to get everything
I would guess that this printer has a large page (many tabs),
do be sure airprint is enabled, it probably is, but check

I checked the printer web page, there were no such options. I tried to reboot the printer and that also didn’t seem to work. I’m running out of ideas…

OK, just yesterday I was trying to get an older brother “airprinting”,
without success. I did notice, going to printer web page, that I had to login
to see more than the first tab, do pick a password that you will be able to remember next year
https://wiki.debian.org/CUPSDriverlessPrinting

If you go to localhost:631/admin then click on add printer, do you see your printer listed?