Help me installing a software that is not in repo, aur, flatpak, snap

Hello everyone…

Don’t get me wrong for the tittle but I need a software to install immediately for academic purpose. The software is available for windows, ubuntu, Fedora, CentOS, opensuse. But it’s not AUR not even in Flatpak or Snap. So after some research, I got the idea of debtap and alien. So I download tar.gz file ( for ubuntu 20.04) hoping to find a .deb file but there is no deb file. In the readme file there are instructions of how to make some directories, move files in them and run the program. I searched a lot but could not find any solution.

Now I really need that software. So my request to the community…

  1. Can anyone make that software arch based.

If that not possible…

  1. Can anyone help me to install that on Manjaro.

I am new, so kindly tell me the installation process one at a time. I am dropping the software link below.

*** Apologies for grammatical errors and typos

Link: Glade Downloads - Peardrop Design Systems

For your convenience the installation process in ubuntu given below…

1.Unzip the glade4_linux64_ub20.tar.gz file to any directory

2.Set the environment variable GLADE_HOME to this directory e.g. export GLADE_HOME=/home/user/glade4_linux64_ub20

  1. Prepend $GLADE_HOME/bin to your PATH environment variable e.g export PATH=$GLADE_HOME/bin:$PATH

  2. GLade is compiled with rpath, but you may need to set


  1. Add $GLADE_HOME/bin to your PYTHONPATH environment variable e.g export PYTHONPATH=/usr/lib/python3.8:$GLADE_HOME/bin

Also add any other directories that contain python modules you require to use - see the Python docs for this.

Did you try the same commands (for Ubuntu) in Manjaro ? That would most likely work.

I did not understand all those commands and I don’t know how to merge? Can you explain it in a way that a beginner can understand?

I loathe to suggest this, I really do, but since it’s available for Ubuntu, have you tried or have a look at debtap?

I know it’s frowned upon, but it might just be handy here.

Nevermind. But the instructions look as if they’d work a charm.

I have tried debtap, but theres no deb package for this file, It seems like its a precompiled file.

  1. Extract the .tar.gz file (right click on it, and click “extract here”) to your home folder.

  2. Add the line export GLADE_HOME=$HOME/glade4_linux64_ub20 to the end of the hidden file .bashrc, in your home folder. (Press ctrl + h to see hidden files)
    Add the following lines to .bashrc

  3. export PATH=$GLADE_HOME/bin:$PATH


  5. export PYTHONPATH=/usr/lib/python3.9:$GLADE_HOME/bin
    (you will have to change it to the current python version for future versions of python)

  6. Restart your computer for the changes to take effect.

I did not understand what that means.

Do you know whether the source code is released under a free license? Then it could be potentially added to Arch repositories and subsequently to Manjaro.

Its an open source software but I think the owner has closed it. But its free in various distro just not in Manjaro. I found most of these types of software only available for Fedora, CentOS or Ubuntu. Seems like people do not use arch based system that much. Thats quite frustrating.

Not the way it is currently. It’s bundled with shared libraries and hardcoded RPATHs. They would be better off releasing it as an AppImage or Flatpak.

This post was created by a Manjaro user:

So I have to add those 4 lines (2,3,4,5) at the end of .bashrc file and restart the computer. Thats it?

From the instructions you posted, it seems that is all.

There must be some executable binary file in the directory glade4_linux64_ub20, and you will have to run it to open the software.

I have add those lines in the bottom of the bashrc file. Is this okay?

Yes, restart your computer (in case I did not interprete the instructions correctly, the software Glade won’t work. This certainly won’t break your operating system).

It won’t find anything in /usr/lib/python3.8/. You’ll want to change that to /usr/lib/python3.9/.

So, I need to copy/move that bin folder from the package to /usr/lib/python3.9.?

Yes, I did not find python 3.8 in /usr/lib/…

No, change that line in your ~/.bashrc.

okay got it. In the last line I just need to change 3.8 to 3.9. I am going to restart my laptop now. If it’s work I will reply.

I restarted my laptop. Can you tell me now how to run that software, which file to run and how to run?