Help installing xrdp on Manjaro

I’m trying to install xrdp on my Manjaro system using yay but it is failing during the prepare() stage with the following error:

/home/user/.cache/yay/xrdp/PKGBUILD: line 34: patch: command not found
==> ERROR: A failure occurred in prepare().
    Aborting...

Can someone please advise what is going wrong here and how I can properly install xrdp? Any help would be greatly appreciated!

You lack the required tools to build the package. :point_down:

sudo pacman -Syu base-devel
1 Like

Based on the article XRDP on Manjaro (fixing the blank screen issue), here is a bash script that automates the process of installing and configuring xRDP on Manjaro Linux with the XFCE desktop environment:

  1. Install the required packages:
sudo pacman -Sy base-devel xorg-server-devel yay
yay -S xrdp xorgxrdp-git
  1. Edit ~/.xinitrc to use xfce4-session instead of xfce-session:
sed -i 's/SESSION=\${1:-xfce-session}/SESSION=\${1:-xfce4-session}/' ~/.xinitrc
  1. Allow anybody to start X:
echo "allowed_users = anybody" | sudo tee -a /etc/X11/Xwrapper.config
  1. Configure xrdp:
sudo systemctl enable --now xrdp.service
#!/bin/bash

# Function to install and configure xRDP
configure_xrdp() {
    # Update system
    echo "Updating system..."
    sudo pacman -Syu

    # Install xrdp and xorgxrdp-git from AUR
    echo "Installing xrdp and xorgxrdp-git..."
    sudo pacman -Sy yay base-devel xorg-xserver-devel
    yay -S xrdp xorgxrdp

    # Allow any user to start an X session
    echo "Configuring Xwrapper..."
    echo "allowed_users=anybody" | sudo tee -a /etc/X11/Xwrapper.config

    # Configure .xinitrc file for XFCE desktop
    echo "Configuring .xinitrc..."
    sed -i 's/^\(SESSION=${1:-xfce-session}\)$/#\1 # original\nSESSION=${1:-xfce4-session}/' ~/.xinitrc
    sed -i 's/^\s*\(local dbus_args=(--sh-syntax --exit-with-session)\)$/#\1 # original\nlocal dbus_args=(--sh-syntax)/' ~/.xinitrc
    sed -i 's/^\(exec $(get_session "$1")\)$/#\1 # original\nexec $(get_session "$SESSION")/' ~/.xinitrc

    # Enable xrdp
    echo "Enabling xrdp service..."
    sudo systemctl enable --now xrdp.service
}

# Call the function
configure_xrdp

To use this script, save it to a file, for example configure_xrdp.sh, then make it executable with the command chmod +x configure_xrdp.sh. Finally, run the script with ./configure_xrdp.sh.

It took me quite a bit of effort to get it to work, hopefully if I have to do it again sometime I can just copy/paste it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.