Helldivers 2 issue with anticheat

Thats exactly what i see in my pamac GUI too…

Instead only i should said, only a third package.

I’m a little lost with what you’re trying to say here - for the avoidance of doubt, could you confirm the output of pamac list -i | grep steam? I may be completely wrong of course, but it would help rule at least one thing out.

Editting to add: It’s worth noting, that if you are running the Steam (runtime) version already, it might be worth trying Steam (native). At the very least, swapping the version of the Steam runtime used will give you another roll of the dice when it comes to the anticheat compatibility.

I’m not the topic creater… i just couldn’t follow you because you said first:

But that was not really precise, because there is no package with that name… instead Steam (Steam) from official Repo’s and Steam as flatpak and the last one is Steam (native) (steam-native-runtime).

$ pamac list -i | grep steam
steam                                     multilib  4,2 MB

Maybe @SirEtrigan you could also try Steam Flatpak version, when nothing else helps.

Would also be intresting to know, which Proton Versions did you try and if you had enable Steam Shader Caching in Downloadsettings.

If you not happy with manjaro, don’t go back to Ubuntu instead better give Linux Mint a chance :face_with_peeking_eye:

Yes - as I said, Manjaro went and changed the names of things since I last touched the Steam packages, meaning my instructions were a bit off. Now there isn’t any correspondence between the packages and the shortcuts that are added to the launcher. In any case, there are two versions of Steam in the repositories: the steam package, which corresponds to “Steam (Runtime)” in the launcher, and the steam-native-runtime package which corresponds to “Steam (Native)”. This is in addition to Steam from Flathub.

If you’re using plain-old steam / “Steam (Runtime)”, it’s possible that using steam-native-runtime / “Steam (Native)” will produce different results. In principle the same is possible for the Flatpak version of Steam as well, although somewhat less likely.

Verify game files.
Make sure you’re using latest Proton 8 or Proton Experimental for test.
Delete the Prefix /.local/share/Steam/steamapps/compatdata/553850/ when switching Proton version or changing startup parameters during troubleshooting.
Try %command% --use-d3d11 startup parameter to force D3D11 and the use of DXVK

I like manjaro but there are some issues that I am trying to solve, like with this crappy anti-cheat. I am gonna now reinstall manjaro for my peace of mind, when I am done with that I’mma try to do it your way guys. And I’ve tried every possible Proton version with and without Shader Caching that is available on steam + ProtonGE.

Thanks for your post but I already did that… twice :grin:

EDIT: I mean that I did this for every proton version, I didn’t mean to sound passive-aggressive or something.

I have got good and bad news. After reinstalling manjaro and installing steam through flatpak, the issue with anti-cheat is gone :smile: but there is another error. Requires a graphics card that supports at least Direct3D feature level 12_0. I’ve had this same issue on ubuntu, but installing protonGE solved it. Unfortunately, protonGE didn’t help here on manjaro. Anyway, I am happy that this bloody anti-cheat error is gone :grin:

Go to game properties and put --use-d3d11 in Launch Options.

Which version did you downloaded? Minimum (small) iso or the Full (big) iso?
In the Fullversion, there is Steam also Pre-installed… would be intresting to know,
which was the Steam version you had installed.

I think it was a full ISO. But steam wasn’t preinstalled.
About the steam version, I’ve mentioned this in the post above that I’ve installed it through flatpak, which is the runtime version.

Didn’t work. :face_with_diagonal_mouth:

This looks more as a minimum iso, steam should be pre-installed in the full iso.

Except if there was some changes for the full iso, that steam no longer is a part of the full installation.

Default pre-install should be Steam from the official Repo.

You’re 100% right. I’ve checked the ISO, and it was the minimum one :smile:

Well, when you not a power user or veteran, i think its probably the best way to always install the full version.

You may install some useless packages what you maybe not really need, but sooner or later you have to install a few pre-installed tools anyways… it makes your path into linux area more complicated, specially when you new.

Same error?

I’ve been using Linux for years now, mainly for school or server stuff. But I know what you mean.

Yeah, error still persists :face_with_diagonal_mouth:

Hmmm, strange that you running here in so many differend problems but in ubuntu there was it working with the exception that your performance was horrible.

I have no real experience with this Steam>Properties Launch commands, i see sometimes on ProtonDB %command% also but i never got to the point if additional package install is required for this stuff or not.

Look what i found:

The OP has a nvidia 3060 and it was working but no longer (probably after HD2 Patch from dev?)… and you can expect it, it was a Windows User…

My recommendation, try to archive your first Manjaro Gaming experience with other games, start some directx11 and 12 games and find out, if this problem only in relation to HD2 or another problem.

Some dude also said he should use %command% --use-d3d11 maybe give that a try.

And it looks like that Mangohud is required for this command.

Mangohud is compareable to MSI Afterburner Overlay (famous for Windows Users).

Okay, I have played Deep Rock Galactic in DX12 mode for an hour without forced steam play compatibility, and it worked great. Also, I played CS2 for about half an hour, and it worked great too. So I don’t really know what could cause issues with Helldivers 2.