Helldivers 2 issue with anticheat

Hello there! I’ve been trying to solve it on my own but after 7 hours of work I just gave up. After some pondering I’ve decided to install manjaro because I have heard that this distro is fine for “gamers”. So after installing cs2 I found myself in disbelieve because in run better than on Win 10. After two competitive games I downloaded Helldivers 2. And here began my fight with this error. I do not know what to do. Any ideas?

the version helldivers2 is not for linux at this time
check always if this can run on others os

According to https://www.protondb.com/app/553850 users have had succes on proton, run it through steam?

It worked on Ubuntu (but poorly), and it works on SteamOS, which is based on archlinux. But I still have issues here on manjaro.

I did run Helldivers 2 on steam. And even tried different versions of Proton that are available on steam. Still no success.

I’m not sure if GE proton is something that steam provides, this used to help me get some games running.

I’ve got the same error on GE proton. I dunno what to do. Is there a possibility that some debugger is causing this? If yes, how can I disable it?
The game works great on SteamOS which is based on Arch like manjaro as far as I know. So it should work fine.

He used Manjaro and it worked, use starting parameter:


Alot people also reported a fullscreen issue, a ini file can be tweaked for borderless window mode.

other Manjaro users:

The game has big problems with AMD GPU’s also, post your system plz.

Even alot Windows gamers, got problems with Helldivers2.

Im also bought this game yesterday from a keystore for only 30€ but i had no time yet to install it.

Anyways, this game need patches and you will get better results after adjustments from Proton and the developer… the game not running away, i normaly wait for first discounts on new games
to play it with greater quality :slight_smile:

Here is info about my pc. I tried using the starting parameter that you’ve provided but the same error persists. Meaning there is an issue with GameGuard which is an Kernel-Level Anti-Cheat. But I still do wonder why am I the only one who’s got this error message on the internet. Before I came here I’d been googling for hours with no real results. What really bugs me is this WinLicense error of which screenshot I’ve had provided in the post at the beginning. I am sure that I mentioned that the game worked on Ubuntu, in the answer to the user stephane. It worked very poorly but there wasn’t any error with GameGuard nor with WinLicense. So my focus would be on these two rather on the starting parameter of the game itself.

  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=1398a57d-d9a2-4231-b2e3-0bbb239eedfc rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASRock model: Z370 Extreme4 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: L4.21B
    date: 04/01/2021
  ID-1: hidpp_battery_0 charge: 49% condition: N/A volts: 3.8 min: N/A
    model: Logitech G Pro Wireless Gaming Mouse type: N/A serial: <filter>
    status: discharging
  System RAM: total: 32 GiB available: 31.28 GiB used: 3.51 GiB (11.2%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 64 GiB slots: 4 modules: 4 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: ChannelA-DIMM0 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: G.Skill
    part-no: F4-3000C16-8GISB serial: N/A
  Device-2: ChannelA-DIMM1 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: G.Skill
    part-no: F4-3000C16-8GISB serial: N/A
  Device-3: ChannelB-DIMM0 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: G.Skill
    part-no: F4-3000C16-8GISB serial: N/A
  Device-4: ChannelB-DIMM1 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: G.Skill
    part-no: F4-3000C16-8GISB serial: N/A
  Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 811 high: 935 min/max: 800/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 935 10: 800 11: 800 12: 800 bogomips: 88824
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep
    smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel DG2 [Arc A770] vendor: ASRock driver: i915 v: kernel
    arch: Gen-12.7 code: Alchemist process: TSMC n6 (7nm) built: 2022+ pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 ports: active: DP-1 empty: DP-2, DP-3,
    DP-4, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 03:00.0 chip-ID: 8086:56a0
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: DP-1 model: Acer PG241Y P serial: <filter> built: 2022
    res: 1920x1080 dpi: 92 gamma: 1.2 size: 609x348mm (23.98x13.7")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.5-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Arc A770 Graphics (DG2)
    device-ID: 8086:56a0 memory: 7.75 GiB unified: no
  API: Vulkan v: 1.3.276 layers: N/A device: 0 type: discrete-gpu name: Intel
    Arc A770 Graphics (DG2) driver: mesa intel v: 23.3.5-manjaro1.1
    device-ID: 8086:56a0 surfaces: xcb,xlib
  Device-1: Intel DG2 Audio vendor: ASRock driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:4f90
    class-ID: 0403
  Device-2: Universal Audio Volt 2 driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:5
    chip-ID: 2b5a:0021 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Info: services: NetworkManager,systemd-timesyncd
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.59 TiB used: 147.19 GiB (9.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Crucial model: CT1000P3SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 33.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3B7QCXE7 temp: 35.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 043 scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-224DB rev: SB01
    dev-links: cdrom
  Features: speed: 48 multisession: no audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 147.19 GiB (64.6%) fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:2
    label: N/A uuid: 1398a57d-d9a2-4231-b2e3-0bbb239eedfc
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1 label: N/A
    uuid: C3B6-0402
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:4 size: 100 MiB fs: vfat label: N/A
    uuid: 0C05-8390
  ID-2: /dev/nvme0n1p2 maj-min: 259:5 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:6 size: 930.89 GiB fs: ntfs label: N/A
    uuid: E0502B81502B5E12
  ID-4: /dev/nvme0n1p4 maj-min: 259:7 size: 522 MiB fs: ntfs label: N/A
    uuid: 12F05F16F05EFF81
  ID-5: /dev/sda1 maj-min: 8:1 size: 465.75 GiB fs: ntfs label: New Volume
    uuid: BA76A5C176A57F2F
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-3:2 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 174c:2074 class-ID: 0900
  Device-1: 1-5:3 info: Logitech Lightspeed Receiver type: keyboard,mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c539 class-ID: 0300
  Device-2: 1-6:4 info: CHERRY Stream Keyboard TKL type: keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s (183 KiB/s)
    lanes: 1 mode: 1.0 power: 100mA chip-ID: 046a:c099 class-ID: 0300
  Device-3: 1-7:5 info: Universal Audio Volt 2 type: audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 7 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 2b5a:0021
    class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: super-speed hub ports: 10 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-4: 2-7:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 power: 8mA
    chip-ID: 174c:3074 class-ID: 0900
  Hub-5: 3-0:1 info: hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-6: 3-2:2 info: Genesys Logic Hub ports: 4 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0610 class-ID: 0900
  Hub-7: 4-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 409 Power: uptime: 32m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 1 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.5 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1158 pm: pacman pkgs: 1136 libs: 326 tools: pamac pm: flatpak
    pkgs: 14 pm: snap pkgs: 8 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh
    v: 5.9 default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33

Oh and btw I’ve seen your post on steam forum which got me thinking to try manjaro ^^

1 Like

From what I’ve heard Intel Arc on Linux has not been a great experience. They’ve focused much more of their efforts on the Windoze drivers and Vulkan performance (which is the most important thing for Proton) is lacking. Apparently some improvements are coming in Mesa 24 - Intel Vulkan drivers on Linux should run more games with Mesa 24.0 | GamingOnLinux

However, none of that explains why you’re having an anti-cheat issue when no-one else on protondb is. I have no idea what could be causing that.

many thing will coming with mesa 24.0

This might not be an issue with Linux/Proton etc. Some Googling for “Gameguard error code 114” suggests that people on Windows are encountering the same error, and it’s being looked into by the developers. There was at least one patch for it, but people are still reporting problems as of the 23rd.

Apparently one estimate is that about 1 in 150 people encounter the error, so it’s rare but not that rare.

1 Like

Interesting, especially the fact that it happens on Windows too. Those 1 in 150 people aren’t all running Intel Arc gfx by any chance? :upside_down_face:

I’ve got no issues on my Win 10. The game works smooth on High/Very High settings (70-90 fps). Neither did I get any issues with Counter-Strike 2 on manjaro. CS2 works here even better than on my win 10 (fps rate is more stable). So I wouldn’t blame intel for the error.

That has changed over the last year. As far as I know (from my own experience and from the internet), the drivers has been significantly improved (on windows and linux as well). And the Anti-cheat thing is very frustrating. I even have reinstalled the whole OS.

Thanks for the information. The future looks promising :grin:

As far as I understood the reports, there wasn’t any conclusion on hardware for the current issues. At launch, it seems that anecdotally it appeared more likely to happen with AMD CPUs, but that should be taken with a pinch of salt as gamers who can’t game are a) salty and b) not the most reliable sources of information. Obviously that doesn’t apply here, though.

One thing that might be worth checking: when installing Steam on Manjaro, there’s “Steam (Runtime)” and “Steam (Native)”. If you’re running “Steam (Native)”, that is very likely to trigger weirdness with things like anti-cheat (as the runtime the anticheat is checking will not be as it expects), so swap to the Runtime version.

1 Like

Is it possible that you are talking about official repo’s (pre-installed steamversion) and flatpak installation?

When i look at pamac UI i only see a version called: Steam-Native-Runtime :man_shrugging:

No; Manjaro has two Steam packages, with the Flatpak version being a third option. In any case, if you’re using steam-native-runtime, this is probably the reason why there’s an issue as that’s linking to system libraries rather than using the official Steam runtime.

The package you should install in Pamac is just steam, and should show up in Pamac’s GUI as “Steam (steam)” - as opposed to the Flatpak version, which is just listed as “Steam”. That will give you an application in your GUI launcher named “Steam (Runtime)”, which should use the official Steam runtime, and might have a bit more luck with anticheat.